FORUMS
Remove All Ads from XDA

H96 Pro Plus

9 posts
Thanks Meter: 0
 
By thebign00b, Junior Member on 22nd August 2017, 06:31 PM
Post Reply Email Thread
Hello world!

I just got this TV box and I think I broke it.

Looking for some advice please.

It comes with Android 7.1.2 and already rooted

I installed SuperSU and it asked if I wanted to update the binaries. So I did. Now the device won't boot at all.

I pressed the reset pin and wiped the system cache as well as done a factory reset. However it still won't boot.

I don't really know where to go from here as I don't know where to get the ROM from and reinstall it. Or even how for that matter.

The logo that comes up when it tries to boot is MBOX.

I would appreciate any suggestions and help.

Thank you for reading!
 
 
23rd August 2017, 07:24 PM |#2  
OP Junior Member
Thanks Meter: 0
 
More
Any ideas anyone please?
2nd September 2017, 11:18 AM |#3  
Junior Member
Thanks Meter: 4
 
More
Hi!
I did do the very same on mine MBOX H96 Pro+ 3g/32g/9377 , and
I've used the USB flash utility (you need a strange male-male usb cable) to flash this firmware:

https://androidtvbox.eu/new-firmware...70602-release/

By using this utility:
https://mega.nz/#!k8hkBDxK!6RVuhh089...Yj61OoDMsVqH8A

With these license files:
https://mega.nz/#!o8w0nKYR!J4_6kjS3j...Hb1AKppmh8xVD0

It is 7.1.1, I think, but it made the box boot again. For the moment I'm keeping SuperSU WITHOUT updating SU, and it works well in asking for Root rights when apps require them, but I'm searching for roms which can be rooted with Magisk, and I found this, which seems interesting BUT I haven't tested it:

http://freaktab.com/forum/tv-player-...7-wifi-chipset

Hope this helps!
The Following 3 Users Say Thank You to Shores For This Useful Post: [ View ] Gift Shores Ad-Free
24th September 2017, 01:11 PM |#4  
Senior Member
Thanks Meter: 25
 
More
Where is the reset button or i have to use toothpick and press thru the av hole then sinultaneously power on the power plug to get into recovery mode ..please help...i am also stuck at boot when updating the binaries of the supersu
27th October 2017, 01:51 PM |#5  
Junior Member
Thanks Meter: 0
 
More
The same thing happened to me, I installed Supersu and did not start again.

I burned an image on an SD card and used a toothpick but had an added problem: If I removed the toothpick, the process stopped.

I stayed the whole process by pressing the toothpick.

If I stopped pressing with the toothpick the process stops .

When finished, remove the toothpick quickly or start again.
11th November 2017, 09:08 PM |#6  
steno66's Avatar
Senior Member
Flag Lugano
Thanks Meter: 38
 
More
Same to me, today installed super su and now won't boot. Thanks, tomorrow I will try this solution. I have another box, the same. It's possible to clone the box upon the broked one?
13th November 2017, 06:25 AM |#7  
urbanman2004's Avatar
Senior Member
Flag Rock Town
Thanks Meter: 59
 
Donate to Me
More
Glad I skipped installing SuperSU on my device
26th January 2018, 08:34 PM |#8  
Billy141's Avatar
Senior Member
Thanks Meter: 11
 
Donate to Me
More
7.1.2 firmware
https://drive.google.com/file/d/1x0r...iew?usp=drives there is no su but is rooted, do not update su
31st January 2018, 01:04 AM |#9  
curiou5's Avatar
Senior Member
Thanks Meter: 44
 
More
Help. I think my 4 mths old H96+ is dead. I tried updating the firmware using SD card burn method. I pressed the reset button and inserted power. The green Android robot appeared showing it was flashing and immediately I stopped pressing the button. The screen went blank and the blue light went off. Thereafter the H96 won't turn on. No blue light but there is light at the optical out connector. Is the H96 fit for the bin.
31st January 2018, 12:10 PM |#10  
Billy141's Avatar
Senior Member
Thanks Meter: 11
 
Donate to Me
More
Mine is MBox too BTW Have you tried booting to recovery I managed to by pressing reset 3x then held for 10 secs around ten secs no sure which side of 10 tho soz cus one way will go update one to fastboot and one to recovery

---------- Post added at 01:10 PM ---------- Previous post was at 01:08 PM ----------

Here is the firmware I've been using...
Stock: https://drive.google.com/file/d/1x0r...w?usp=drivesdk
Supercelerons ATV http://freaktab.com/forum/tv-player-...7-wifi-chipset
31st January 2018, 01:39 PM |#11  
curiou5's Avatar
Senior Member
Thanks Meter: 44
 
More
Quote:
Originally Posted by curiou5

Help. I think my 4 mths old H96+ is dead. I tried updating the firmware using SD card burn method. I pressed the reset button and inserted power. The green Android robot appeared showing it was flashing and immediately I stopped pressing the button. The screen went blank and the blue light went off. Thereafter the H96 won't turn on. No blue light but there is light at the optical out connector. Is the H96 fit for the bin.


What a shame. It is good box but didn't last. It was having some issues before I decided to give it an upgrade.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes