FORUMS

[Help Thread][Unihertz Atom] Ask Any Question, Noob Friendly (2018)

15,765 posts
Thanks Meter: 7,000
 
By sd_shadow, Recognized Contributor on 16th June 2018, 03:35 PM
Post Reply Email Thread
11th November 2019, 12:48 AM |#121  
Junior Member
Thanks Meter: 0
 
More
Hi all!
This post is more like sharing my experience and giving some warning(s). (Android and XDA noob here, but was hacking my webOS devices for years)
My Atom came with Android 9, so I only wanted root access.
Long story short I successfully installed TWRP (the modified version of droidzer1) and Magisk (v20.0) using an OTG cable and a USB stick.
Meanwhile I had a few problems:
- 'fastboot oem unlock' is not working on my Atom, only 'fastboot flashing unlock' produced the desired results.
- TWRP was not "sticking" to the device, after 'fastboot flash recovery recovery.verified.img' I could enter TWRP recovery, but after next reboot the default recovery took over.
- the encrypted /data was painful at first, but USB stick with OTG solved the problem
- TWRP backup was unable to save to my mounted USB stick. In order to be able to do the backup I had to format the /data partition, do the backup there and finally copy the files to the USB stick.
- with the TWRP and Magisk installed doing an 'Erase all data (Factory reset)' proved to be really catastrophic, I got my Atom into a silent state (aka. softbrick), only the preloader was able to chime in on USB. I had to reflash the factory firmware with SP Flash (and for this I had to use a Windows machine because all other things up to this point were done on a Linux ).

Still have to try the 'patched boot image way' of installing Magisk.

Anyway, big thanks to droidzer1 for patching TWRP and to all others for providing bits and pieces of information.

Regards,
Tylla
6th December 2019, 11:42 AM |#122  
Junior Member
Thanks Meter: 0
 
More
Solved
16th December 2019, 08:27 AM |#123  
Junior Member
Thanks Meter: 2
 
More
Seems like we're going to get a new FW update soon. Here's a part of my dialogue with Unihertz Tech support:

Me: May I ask you, if there's any plan about releasing new firmware for Unihertz Atom in the near future?
Unihertz: Yes we will release new update for Atom soon.
Me: Great, thank you for your reply! May I know, when approximately could it be released?
Unihertz: Hello, Our technical teams plans to release the new update within this month. But they did not give us a specitic date. Let's wait for some while.
3rd February 2020, 11:47 AM |#124  
Junior Member
Thanks Meter: 0
 
More
# how i update atom to 2020-01
i update from 2019 to 2020-01 firmware while keep all user data and magisk root.

1. backup your data for assurance. i use `adb backup` and `tar` backup sdcard.

- this backup all app data: `adb backup -f app.ab -apk -obb -noshared -all -system`

- this backup built-in storage: `adb shell cd /sdcard \; tar -cf - . > sdcard.tar`

2. you need stock image and sp flash tool.

3. open sp flash tool, and select the scatter file in stock image.

4. choose *Download Only* action, in *Format All + Download*, *Firmware Update* and *Download Only*.

5. select all partition except *userdata*, so your data will not be erased.

6. click download button.

7. poweroff android, and connect it to computer. download will start automatically.

8. after download finish, disconnect android from computer.

9. now your android is updated, but lose the root permision. power on the android, and check anything is ok.

10. send the `boot-verified.img` in stock image to the android.

11. launch magisk manager on android. choose install magisk by patching the boot image, which you just sent to android from stock image.

12. the patched boot image sould be `Download/magisk_patched.img`. send it the computer.

13. open sp flash tool again.

14. load the same scatter file, but this time just flash the boot partition, and click the filename of boot image, replacing it with `magisk_patched.img` .

15. click download button and flash it just like before.

16. you should get the root permision now.

in this update, the built-in image viewer become google photo,
so i use **simple gallery** instead.
8th February 2020, 08:43 PM |#125  
x111's Avatar
Senior Member
Thanks Meter: 339
 
More
any news about upgrading this little beast to the Android 10 Q ?
3rd March 2020, 03:08 PM |#126  
Junior Member
Thanks Meter: 0
 
More
got an ota update with version number `Unihertz_Atom_20191114_20200227-1932` .
it state that this update will fix bug that **Digital Wellbeing** disappear from **Setting** .
however, no stock rom released on google drive til now,
and it seem that the update is not very important, so i will not update now.
23rd March 2020, 04:04 PM |#127  
Junior Member
Thanks Meter: 0
 
More
does anyone get or fix the bug about microphone after applying update?
my mic become very weak so people are hard to hear me in call.
it seem that many people face this problem on unihertz's forum.
some of them fix it by cut the rubber arround the mic.
31st May 2020, 12:51 PM |#128  
Junior Member
Thanks Meter: 0
 
More
After a little over a year of use, the Atom just all of a sudden froze and turned off. Whether it turned off because I started pushing the power button due to freeze or all by itself, no idea.
It has not turned back on since then .
This occured right after a phonecall, while checking system messages from the main screen (i.e. to see why the phone beeped during the call).
Now that I've thought about it, there was one odd thing I think I noticed: I had received an SMS (from a person I know) during the call and after the brief message there were a bunch of emoji at the end of the message. This kind of struck me as odd, because I did not recall seeing such an emoji collection in the mainscreen message area before and also this person practically never uses emojis like that.
So, did displaying the message trigger something odd? Who can say...

Anyway, after some tries and retries at pushing button combinations and charging overnight I have since been trying to fix this device by flashing it. And nothing helps. I have experience of flashing devices, but not of flashing a MediaTek phone and it all seems really messy . I got the official ROM from Unihertz and there was also supposed to be an official flash tool, but that flash tool seems to be only downloadable from Baidu (or somesuch) and I cannot access it. I have downloaded multiple versions of the flash tool and tried them, but aside from the ones which claim to be too old to support the firmware version, I always get stuck in the same step: DA 100%, red bar. And then nothing .

When I attach the device I get a "MediaTek USB Port" (currently COM12... I think it was, like COM3, originally...). I've tried various versions of the driver too. When the DA 100% red bar has been done, that device "sticks" in the device manager and no longer disconnects, but nothing like a flashing operation still happens. If I then deattach the device, it is no longer recognized by the computer at all. On Windows it just says "Device descriptor request failed". On Linux (I also tried with Linux and get exactly to the same stage as I do on Windows) dmesg shows a similar conclusion: The device is sufficiently offline to not be able to communicate even the "basics" of USB signaling? That can be cured by long pressing the powerbutton, after which I again get successfully to the DA 100% stage. As if that helped .

In desperation, I've tried opening the device up and removing the battery. I also tried connecting testpads on the mother board to ground as suggested in a Youtube video. Nothing has helped in any way: this thing still behaves exactly the same as it did when I realized I have to start troubleshooting it.

The worst thing is that this is right about the only phone I own to which nothing has been done as far as customizations go (the point kind of was to get an easy to carry phone I would not mess up). I bought it for four things: Calls, SMS, Signal, Spotify. No rooting, no other apps installed. Nothing . It never even got wet or thrown about, I only bought it because it was small and had a headphone jack, not because it was "rugged". And now this mess .

Does anyone here have any idea what I could do now? Please tell me if you though of a possible solution while reading this. I have already posted in Unihertz's own forums and emailed them, but I don't know whether they watch the forums or respond to emails, so I figured I'd try here too.

UPDATE: Unihertz replied to my email very soon after I sent it! And when I requested the flash tool they replied to that within just a couple of hours!! I now have the official flash tool version. Unfortunately it behaves exactly the same as the later versions of the flash tool, so I have still not been able to resume from the DA 100% stage .
Post Reply Subscribe to Thread

Tags
atom, unihertz

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes