Remove All Ads from XDA

How to open / modify "vold" and "sdcard" file, Android KitKat 4.4.4

53 posts
Thanks Meter: 3
By m45k, Member on 1st April 2015, 04:53 PM
Post Reply Email Thread
I have a Zopo zp999 and zp920.
On both devices the external sdcard is sdcard0 and the internal card is sdcard1, so all of the apps are installed on the slow external sdcard and the external card is recognized as the internal card..
I looked after for a way to swap these cards and on most smartphones there is a vold.fstab where i could change this - but not on my zopo phones.
on an earlier FW of the zp999 the cards have been in the (for me) correct order (internal sdcard0, external sdcard1) and when i took the two files from /system/bin "vold" and "sdcard" of the old FW to the new one, the order of the sdcards was correct.

for the zp920 is workaround is not possible, now i am searching for a way to open and modify these two files.
can anyone help me with this - please?
Attached Files
File Type: zip - [Click for QR Code] (86.9 KB, 228 views)
1st April 2015, 07:42 PM |#2  
OP Member
Thanks Meter: 3
i tried to change the fstab / fstab.nand / fstab.fat.nand from the boot.img from:
/devices/mtk-msdc.0/11230000.MSDC0   auto      vfat      defaults        voldmanaged=sdcard0:emmc@intsd,noemulatedsd
/devices/mtk-msdc.0/11240000.MSDC1  auto      vfat      defaults        voldmanaged=sdcard1:auto

/devices/mtk-msdc.0/11230000.MSDC0   auto      vfat      defaults        voldmanaged=sdcard1:emmc@intsd,noemulatedsd
/devices/mtk-msdc.0/11240000.MSDC1  auto      vfat      defaults        voldmanaged=sdcard0:auto
with the "Android Kitchen" and cygwin
but after repacking the boot.img and flashing it back to the phone, the phone is stock in a bootloop.
maybe the unpacking / packing is wrong with my boot.img and Android Kitchen / cygwin (there are no errors)

i tried with both, the original boot.img and a boot.img from a marsapa custom rom.
30th May 2015, 09:55 AM |#3  
chinittoh's Avatar
Thanks Meter: 4
i have same problem like yours..hope someone can help..

i want the internal storage be the sdcard0..
6th September 2015, 05:50 PM |#4  
Junior Member
Thanks Meter: 0
Any progress on this? From what I figured out so far it seems that MSDC0 is the internal sd card. So from the fstab you would expect the internal sd card to always be mounted to SDCARD0. But once you insert the external sd card the internal sd card becomes SDCARD1 and the external sd card becomes SDCARD0. This cannot be the intended behaviour as it breaks file paths for apps
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes