FORUMS
Remove All Ads from XDA

Jelly by Unihertz - the smallest 4g Phone Ever

67 posts
Thanks Meter: 13
 
By johnnynmonic, Member on 26th August 2017, 06:39 AM
Post Reply Email Thread
Is there a sub forum for the Jelly yet? Want to see the ROMs that come out.
The Following 2 Users Say Thank You to johnnynmonic For This Useful Post: [ View ] Gift johnnynmonic Ad-Free
 
 
3rd September 2017, 07:09 PM |#2  
Junior Member
Thanks Meter: 3
 
More
YYeeeeeeaaah!! More software for this little miracle!!
5th September 2017, 11:44 AM |#3  
Member
Thanks Meter: 14
 
More
My Jelly Pro was delivered today. Looking good so far - just getting to grips with it.
11th September 2017, 02:14 PM |#4  
Senior Member
Prague
Thanks Meter: 68
 
More
I'got my Jelly Pro today and need root. Any idea how to root my Jelly?
15th September 2017, 06:27 PM |#5  
Junior Member
Thanks Meter: 2
 
More
Custom roms for jelly ?
29th September 2017, 06:30 PM |#6  
Cralex's Avatar
Junior Member
Thanks Meter: 1
 
More
It's a cool little device, and Unihertz seems to be making things easy for the users. Hoping to get TWRP on mine at some point.
30th September 2017, 04:52 PM |#7  
Junior Member
Thanks Meter: 14
 
More
Jelly Pro Stock Boot, Stock Recovery & TWRP
I take ZERO credit for any of this. I just received my Jelly Pro and am reposting information I found useful to get TWRP & root. I take no responsibility if you bork your device.

Enable Developer Options (Settings,About phone,click Build number until you see 'You are now a developer')

Go back to Settings, scroll down to the bottom and you'll see a new ‘Developer Options’ entry right above ‘About phone’

Enable OEM unlocking
Enable USB debugging
I also disable animations, just a preference, but not necessary

Make sure your usb drivers and adb/fastboot is set up on your computer

From terminal:
adb reboot bootloader
fastboot oem unlock

fastboot flash recovery twrp_jelly_pro.img
fastboot reboot

(hold volume-up and power to go into recovery)
****if something went wrong and you get a "command not found" message, click volume-up & power a few times to go into stock recovery, then do a factory reset and try again)

****when going into twrp, DO NOT allow modifications

In TWRP, go to ADB Sideload and swipe to start
From term: adb sideload supersu-XXX.zip
Back in TWRP, go ahead and reboot

should have TWRP recovery and root

hopefully we'll start seeing some ROM's for this little guy....




1. Stock boot: https://mega.nz/#!UbZASJTI!weBJa4uu9...gqPJ7O5UBjDJAQ
2. Stock Recovery: https://mega.nz/#!9SoTVDbY!dZI7XYYSq...KTqDCzy-46Dsd0
3. Twrp recovery: https://mega.nz/#!0WICAZwD!cUSG82h1S...fAl9MrWeClnRBs
4. Latest Supersu flashable zip: http://www.supersu.com/download



(original post: http://www.unihertz.com/bbs/forum.ph...&tid=67&page=3)
(https://www.kickstarter.com/projects...-4g-smartphone)
(https://www.xda-developers.com/jelly...ndroid-nougat/)
The Following 9 Users Say Thank You to javadahut For This Useful Post: [ View ] Gift javadahut Ad-Free
30th September 2017, 09:57 PM |#8  
Junior Member
Flag Montreal
Thanks Meter: 5
 
More
I successfully flashed twrp and supersu, but when I reboot, it just goes right back to twrp, and asks for a pattern to decrypt data... Not sure what I might have done wrong. I was able to reset things by flashing stock boot and recovery via fastboot. (as described at http://www.unihertz.com/bbs/forum.ph...age%3D1&page=3).

I tried again (fastboot flash twrp, sideload supersu) and this time it worked! Just wanted to leave all this here in case anyone else runs into similar problems. Lovely having root again. Can't wait for Lineage to make its appearance!
The Following User Says Thank You to jaddle For This Useful Post: [ View ] Gift jaddle Ad-Free
1st October 2017, 04:13 PM |#9  
Junior Member
Thanks Meter: 14
 
More
I ran into the same issue. When phone was delivered, /data was already encrypted.....with what key I don't know.
2nd October 2017, 02:46 AM |#10  
Junior Member
Thanks Meter: 6
 
More
User "vineethrp" helped me with a similar issue. He is the one that came up with the TWRP recovery and dumped the boot and recovery images. Here are the instructions on post 22:
http://www.unihertz.com/bbs/forum.ph...age%3D1&page=2

The issue, he suspects, is dm-verity. DO NOT modify system when you boot into TWRP and click on "Keep Read Only". I was able to root and it is booting again.
5th October 2017, 02:04 AM |#11  
Member
Thanks Meter: 11
 
More
can we use magisk su?
Post Reply Subscribe to Thread

Tags
android, jelly, nougat, unihertz

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes