FORUMS
Remove All Ads from XDA

T95Z Plus - 3GB - 32GB - Won't boot, disconnects when I plug into PC...

12 posts
Thanks Meter: 1
 
By mancboy1, Junior Member on 14th July 2018, 09:15 AM
Post Reply Email Thread
Hi all, I have an Android T95Z Plus box - It's not working basically.

When connected to TV, nothing apart from the lights changing colors.

I have tried connecting it to the PC so I can maybe re-flash the box, but when I plug it in, the PC makes the sound of something being plugged in then around 10 seconds later, makes the sound of it being unplugged.
I also have tried plugging a USB card reader into the PC with a Micro SD inside, PC recognizes it as a mass storage device, but cannot do anything with it, it also doesn't show up in 'MY Computer'

Does anyone have any ideas or advice?

Thanks,

Chris.
23rd May 2019, 10:49 PM |#2  
OP Junior Member
Thanks Meter: 1
 
More
If anyone else has this issue - I forgot to post how I sorted it. It works now for me by plugging in a USB cable into it and plugging that into a USB plug (phone charger plug)

Hope it helps if anyone else has the issue.
2nd December 2019, 04:39 PM |#3  
Junior Member
Thanks Meter: 0
 
More
I have the same issue can you give solution
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes