Remove All Ads from XDA

Google Play 489 error

216 posts
Thanks Meter: 28
Post Reply Email Thread
After doing all of these:

*delete all account
*cleared playstore, google services, framework cache and data
*disabling and force stop this 3
*full clean restore(after performing this, I can download all my and new apps, but when update comes and try to install it, it gives me 489 error also)

still having this annoying 489 error even I did the steps above specially on updating apps because "sometimes" downloading new app is possible without error and sometimes it does 489 error.

I have 3 gmail accounts on my G2. When I tried downloading on my account 'A' and it gives me 489 error, I switched to my account 'B' and it will download it, and when I tried to switch again on my account 'A' then tried to download new app, it will work. But this only happens rarely because most of the time it gives me 489 error.

I have one solution to download new updates, and that is uninstalling the app and installing it which is really annoying and tiring to do specially when there is 5+ apps that have new versions and like I said, sometimes downloading app is not working it gives me this hilarious 489 error.

Last time, I really want to hammer this phone, but I think my G2 has nothing to do with my problem, it is the play store.

Btw I have:
G2 D80220B KK
Dori Kernel
Titanium backed up apps(i don't think this is the problem, because my last restore of these apps is since March 2014 and all installs and updates are working fine until last week)

blocked apps by titanium
*fused location
*google search
*location services
*smart screen
*smartshare push
*street view
*voice mate

I hope someone can help me here. Or is it possible to install new google play APK from others phone that don't have this problem? Really need some help here.

18th August 2014, 04:59 PM |#2  
Junior Member
Thanks Meter: 2
Trying installing a new gapps package for your android version through recovery.
Just googles gapps package for android (version e.g 4.1.2)
Flashing the wrong gapps results to such errors like yours

Sent from my Nokia_X
18th August 2014, 10:05 PM |#3  
coowkeee's Avatar
OP Senior Member
Flag Philippines
Thanks Meter: 28
Donate to Me
I'm on stock 4.4.2 with stock Gapps, and I came from fresh restore. like I said, Google play works fine until last week. ok, if it is really the gapps, I'll try to install pa gapps and we'll see. Thanks

Sent from my LG-D802 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes