FORUMS

Zip Treble Compatibility Error

16 posts
Thanks Meter: 4
 
By kannss, Junior Member on 24th September 2018, 01:46 PM
Post Reply Email Thread
5th November 2018, 08:38 PM |#11  
Junior Member
Thanks Meter: 0
 
More
The problem for mi 6 continues. what should I do
19th November 2018, 12:55 PM |#12  
Junior Member
Thanks Meter: 0
 
More
Help
Quote:
Originally Posted by kannss

Edit: Problem solved by updating TWRP recovery. Thanks

How do i update it?
7th March 2019, 11:53 PM |#13  
XenGi's Avatar
Member
Flag Berlin
Thanks Meter: 24
 
Donate to Me
More
Same here.

Phone: Oneplus 5t
TWRP: 3.2.3-1

I'm on the newest LOS 15.1 nightly, I already flashed firmware v5.1.7 and now I'm trying to flash LOS 16 but I get the compat error.
22nd April 2019, 11:02 AM |#14  
schlager P.'s Avatar
Senior Member
Flag utrecht
Thanks Meter: 215
 
Donate to Me
More
I had this, too
after reading 1st post I checked out this
https://forum.xda-developers.com/one...0-8-1-t3729673
and error: gone
26th April 2019, 08:01 PM |#15  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by kannss

Edit: Problem solved by updating TWRP recovery. Thanks

Thanks, worked for me too
17th August 2019, 12:03 AM |#16  
MikeyLee's Avatar
Senior Member
Flag Phoenix
Thanks Meter: 639
 
More
Quote:
Originally Posted by Droidriven

If you both read this thread thoroughly, you would both see that just a few posts up, a member solved this issue by updating their version of TWRP to a newer version. All you had to do was read before you posted.

Flash the newest version of TWRP for your device.

The next time you come to XDA looking for a solution, take the time to read through threads BEFORE posting a question.



Sent from my LGL84VL using Tapatalk

I'm on the newest TWRP and getting the same error. Why are there so many smartasses on XDA?
17th August 2019, 02:26 AM |#17  
Quote:
Originally Posted by MikeyLee

I'm on the newest TWRP and getting the same error. Why are there so many smartasses on XDA?

If you'll pardon the humor...

If you consider the universal balance theory, probably to counterbalance the number of dumbasses on XDA.

On a serious note, you may be having the same issue but yours has a different cause.

Sent from my SM-S767VL using Tapatalk
20th September 2019, 06:30 PM |#18  
Junior Member
Thanks Meter: 0
 
More
Im also getting the same error for Redmi note 5
7th October 2019, 04:13 PM |#19  
Titan90's Avatar
Junior Member
Thanks Meter: 0
 
More
It took me hours to fix it as ADB wouldnt work for some reason...
BUT there is allways an indian guy who does tutorials:
https://www.youtube.com/watch?v=kr3kUJF6d0Y
WORKED FLAWLESS!
Hope i can help some ppl in the future that googled like me
19th January 2020, 06:34 PM |#20  
christopherblackwell's Avatar
Junior Member
Thanks Meter: 7
 
Donate to Me
More
Quote:
Originally Posted by XenGi

Same here.

Phone: Oneplus 5t
TWRP: 3.2.3-1

I'm on the newest LOS 15.1 nightly, I already flashed firmware v5.1.7 and now I'm trying to flash LOS 16 but I get the compat error.

The following helped me out:
If you're upgrading from Oreo to Pie, the stock ROM (at least on OnePlus) has a file called "compatibility.zip" inside the zip of the stock ROM
If you have a mac or linux: Just do
Code:
zip -d [path to your stock ROM] "compatibility.zip"
for example
Code:
zip -d OnePlus5Oxygen_23_OTA_053_all_xx "compatibility.zip"
(don't forget the quotes)

If you have Windows, simply use MiExplorer to delete the file from the archive. Don't try unpacking/repacking the zip with native windows/mac.

Once you're done, boot into recovery, flash or sideload the stock ROM and the error should be resolved.
The Following User Says Thank You to christopherblackwell For This Useful Post: [ View ] Gift christopherblackwell Ad-Free
5th May 2020, 08:17 AM |#21  
Junior Member
Thanks Meter: 0
 
More
I have a solution, flash orange fox and now flash rom, 1000% works
Download orange fox recovery lastest version, that is released in 2020 (this enables your STOCK ROM for ota updates released by company). Keep the orange fox recovery .img file in internal storage of your phone and flash it using TWRP. Now try to flash the rom. 100% working.

ADDITIONAL INFORMATION (IRRELEVANT)
TWRP doesn't allow us for ota updates. But orange fox do support. THERE IS PROCEDURE FOR FLASHING STOCK ROM TO ENABLE OTA UPDATES . Check the procedure in YouTube if you want.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes