FORUMS
Remove All Ads from XDA

[Android 4.1+]Proxy/GateWay for Android Auto

2,630 posts
Thanks Meter: 2,087
 
By Emil Borconi, XDA Ad-Free Recognized Developer on 6th July 2018, 06:00 PM
Post Reply Email Thread
9th September 2019, 04:18 PM |#1491  
fma965's Avatar
Senior Member
Thanks Meter: 1,659
 
Donate to Me
More
Quote:
Originally Posted by jeromeo01

The problem in my case is as soon as you connect usb. Bluetooth is not available anymore.
Volkswagen Mib2 head unit.
Making this app impractical as I cannot get phone call or messages anymore from master.

Sent from my SM-G965F using Tapatalk

Have you actually tested it, Android Auto always uses bluetooth for calls regardless of AA Gateway, although your VW headunit may not allow bluetooth devices it is still using it as part of Android Auto.
The Following User Says Thank You to fma965 For This Useful Post: [ View ] Gift fma965 Ad-Free
 
 
9th September 2019, 09:13 PM |#1492  
Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by fma965

Have you actually tested it, Android Auto always uses bluetooth for calls regardless of AA Gateway, although your VW headunit may not allow bluetooth devices it is still using it as part of Android Auto.



Unfortunately yes.
I even have a message on HU informing me I will not be able to use Bluetooth for media anymore.


Sent from my iPad using Tapatalk
9th September 2019, 09:25 PM |#1493  
fma965's Avatar
Senior Member
Thanks Meter: 1,659
 
Donate to Me
More
Quote:
Originally Posted by jeromeo01

Unfortunately yes.
I even have a message on HU informing me I will not be able to use Bluetooth for media anymore.


Sent from my iPad using Tapatalk

Yes but this is normal, i don't think you understand how AA works, this isn't relating to AAGateway at all, when AA takes over your car head unit it will prevent bluetooth from "working" (in the normal sense, as AA is taking control of it) kinda like when a movie takes control of the audio device so it can output at 5.1 when watching a film etc.
The Following User Says Thank You to fma965 For This Useful Post: [ View ] Gift fma965 Ad-Free
14th September 2019, 07:21 PM |#1494  
Junior Member
Thanks Meter: 0
 
More
I'm testing it for about a 2 weeks, works perfect (Pixel 3 master, Nokia 1 slave), but i have an issue with Bluetooth and don't understand where is a problem, in my master phone (Pixel 3) or somewhere else. After fresh reboot head unit and master device, i have smooth connection by bluetooth and head unit, can make a calls, e.t.c. Suddenly, after long connection or few short connections, master phone disconnects from head unit, sometimes connection back, sometimes no, but bluetooth is crashing. When i try to reconnect it manually, master phone doesn't connect to head unit, in this case i have to delete connection with my head unit and pair it again after reboot master and head unit. I recognized, that Bluetooth connection crash faster if i listen to the music from a phone by Bluetooth, i also noticed when i listen to the music when wireless AA is activated, music lagging a lot. I can't understand where is a problem, in my master device or in AAgateway or may be in AAuto app AAmirror, which i use to mirror screen on a head unit.
15th September 2019, 09:30 AM |#1495  
Member
Flag Bucharest
Thanks Meter: 3
 
More
Worked with sony xperia 1 and xperia z3+ on RCD 330 plus, both tested as master and slave. With z3+ as slave i had some little problems, but it's from my phone. With xperia 1 as slave it was charming. Any recommendations for android tv stick? Sticks from first post has hdmi port, i have only usb to my rcd...
15th September 2019, 02:58 PM |#1496  
Member
Thanks Meter: 3
 
More
Im using the latest Alpha builds on my Note9 running Pie (Master) and OnePlus X on 5.0 (Slave). Got it working but AAGateway keeps crashing after a few seconds of use. Im unsure on which device does it crash though, I kept both the phone screens on and I can see that OPX says "Unfortunately, AAGateway has stopped responding" but at the same time AAGateway on my N9 also closes.

Any ideas anyone?
16th September 2019, 01:13 AM |#1497  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by RanMN

Im using the latest Alpha builds on my Note9 running Pie (Master) and OnePlus X on 5.0 (Slave). Got it working but AAGateway keeps crashing after a few seconds of use. Im unsure on which device does it crash though, I kept both the phone screens on and I can see that OPX says "Unfortunately, AAGateway has stopped responding" but at the same time AAGateway on my N9 also closes.

Any ideas anyone?

Try the test version and if that crashes send emil a bug report
Today, 07:45 PM |#1498  
Junior Member
Thanks Meter: 0
 
More
Nobody have bluetooth crash when listen to the music via Aauto music apps (Deezer or Google music?)
Post Reply Subscribe to Thread

Tags
android auto wifi

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes