FORUMS
Remove All Ads from XDA

 View Poll Results: What should be my next focus?

Try to work out how to integrate ODB2/CAN data?
 
18 Vote(s)
94.74%
Build a HUD app to work with HUR(HUDWAY style)?
 
1 Vote(s)
5.26%
Something else?
 
0 Vote(s)
0%

[Android 4.1+] HeadUnit Reloaded for Android Auto with Wifi

2,928 posts
Thanks Meter: 2,373
 
By Emil Borconi, XDA Ad-Free Recognized Developer on 4th August 2016, 01:47 AM
Post Reply Email Thread
14th January 2020, 09:51 AM |#4651  
Member
Thanks Meter: 24
 
More
Quote:
Originally Posted by Emil Borconi

The WiFi launcher for HUR app will only show that option if your phone is on Oreo or older if you are on pie or 10 You should use listening mode inside HUR.

But listeneing mode does not seem to work here when i set hotspot on mobile.. I have
mobile with android 10
atoto head unit (wifi direct does not seem to work)

The only way i can connect is if i enable android auto server on phone manually.. Can you please explain how this shoudl work?
14th January 2020, 09:55 AM |#4652  
OP Recognized Developer
Flag Tg. Secuiesc / Kezdivasarhely
Thanks Meter: 2,373
 
Donate to Me
More
Quote:
Originally Posted by mcaptur

But listeneing mode does not seem to work here when i set hotspot on mobile.. I have
mobile with android 10
atoto head unit (wifi direct does not seem to work)

The only way i can connect is if i enable android auto server on phone manually.. Can you please explain how this shoudl work?

You don't need any of that.
1) In HUR go to settings and enable Listening mode (do not change anything else!)
2) Restart HUR
3) On the phone install Wifi Launcher for HUR and select the atoto's BT from the list, leave all other options disabled.
4) Assuming you are in the car already turn off the bt on the phone, then back on.
14th January 2020, 06:11 PM |#4653  
Member
Thanks Meter: 24
 
More
Quote:
Originally Posted by Emil Borconi

You don't need any of that.
1) In HUR go to settings and enable Listening mode (do not change anything else!)
2) Restart HUR
3) On the phone install Wifi Launcher for HUR and select the atoto's BT from the list, leave all other options disabled.
4) Assuming you are in the car already turn off the bt on the phone, then back on.

So i did the above.. enabled listening mode on hur and nothing else (i.e. no create hotspot )
did as above on phone..


When phone finds atoto bluetooth, I have a tasker scripti which disables wifi and enables hot spot on phone.. wifi launcher starts on its own, but hur on headunit stays on listening mode.. what can i do? shall i send you some logs? what logs would you need??
14th January 2020, 06:20 PM |#4654  
OP Recognized Developer
Flag Tg. Secuiesc / Kezdivasarhely
Thanks Meter: 2,373
 
Donate to Me
More
Quote:
Originally Posted by mcaptur

So i did the above.. enabled listening mode on hur and nothing else (i.e. no create hotspot )
did as above on phone..


When phone finds atoto bluetooth, I have a tasker scripti which disables wifi and enables hot spot on phone.. wifi launcher starts on its own, but hur on headunit stays on listening mode.. what can i do? shall i send you some logs? what logs would you need??

I never said to do any of that stuff.
I said turn on the tethering and do nothing else, that does not mean to disable any other option.

I never ever said turn of the WiFi on the slave or start tethering or anything like that.

Just enable the listening mode on the headunit leave all other settings as they where by default and install WiFi launcher for HUR on the phone. Do NOT START tethering, do not turn off WiFi do not do anything else....
14th January 2020, 09:33 PM |#4655  
kv1dr's Avatar
Senior Member
Flag Gornji Grad
Thanks Meter: 278
 
Donate to Me
More
I really like this application, it works really well on my head unit. I never tried it for more than 40 minutes, but in those 40 minutes, it never crashed. Sometimes it laged a little bit, but I can live with that. But there is some small problem. When someone calls me, HeadUnit Reloaded just crashes. I can still answer the call, because the head unit itself supports bluetooth calling, but to start HeadUnit Reloaded again, I need to kill Google Services for Car (or something like that) on my phone, because otherwise Android Auto on my phone is stuck on "Connected to my Auto" and I can't make any new connections. Does anyone have any suggestions? I am connected using WiFi mode (not using WiFi direct), with hotspot on the phone and head unit connected to my hotspot. Headunit is 9" Dasaita Android Headunit with Android 9.0 and Rockchip PX6 (I think).
15th January 2020, 06:36 AM |#4656  
Senior Member
Flag Muscat
Thanks Meter: 10
 
More
@ggilliland,

Thanks for the intent, it worked a treat on my OP7 Pro with Pixel Experience ROM

@Emil Borconi,

I tried the latest WiFi Launcher 1.5 from XDA and found that while it launched, it shutdown within a few seconds of launching and never made the connection to the head unit. Not sure whats going on but will try and capture a bug report and post it here.

Otherwise everything seems to be running smoothly with not FC after 'X' minutes.

Cheers

Guy
15th January 2020, 08:15 AM |#4657  
Junior Member
Thanks Meter: 1
 
More
Great app, running on my Seicane 9.7" Android 9.1 head unit with my Samsung Galaxy S10+.

Unfortunately I've tried everything to get WiFi direct with no joy.

It works when I set up my phone as a hotspot however is very laggy.

Using with a USB cable is the best result, however maps refuses to work no matter what I do, it seems Android Auto limits or changes the functionality of maps applications.

Starting navigation causes maps to crash, waze won't load at all. The phone app doesn't open at all on the headunit.

Do you have any suggestions on how to get this working?

Also does anyone have any recommendations on resolution and pixel density settings?
I'm currently running 1280x720 with pixel density of 115, I've played with a lot of settings and this is the best I've achieved so far ☺
15th January 2020, 08:56 AM |#4658  
OP Recognized Developer
Flag Tg. Secuiesc / Kezdivasarhely
Thanks Meter: 2,373
 
Donate to Me
More
Quote:
Originally Posted by Guyzer73

@ggilliland,

Thanks for the intent, it worked a treat on my OP7 Pro with Pixel Experience ROM

@Emil Borconi,

I tried the latest WiFi Launcher 1.5 from XDA and found that while it launched, it shutdown within a few seconds of launching and never made the connection to the head unit. Not sure whats going on but will try and capture a bug report and post it here.

Otherwise everything seems to be running smoothly with not FC after 'X' minutes.

Cheers

Guy

Can you send me a bug report from the phone please?
15th January 2020, 08:57 AM |#4659  
OP Recognized Developer
Flag Tg. Secuiesc / Kezdivasarhely
Thanks Meter: 2,373
 
Donate to Me
More
Quote:
Originally Posted by gevaux

Great app, running on my Seicane 9.7" Android 9.1 head unit with my Samsung Galaxy S10+.

Unfortunately I've tried everything to get WiFi direct with no joy.

It works when I set up my phone as a hotspot however is very laggy.

Using with a USB cable is the best result, however maps refuses to work no matter what I do, it seems Android Auto limits or changes the functionality of maps applications.

Starting navigation causes maps to crash, waze won't load at all. The phone app doesn't open at all on the headunit.

Do you have any suggestions on how to get this working?

Also does anyone have any recommendations on resolution and pixel density settings?
I'm currently running 1280x720 with pixel density of 115, I've played with a lot of settings and this is the best I've achieved so far

Try to turn off battery optimisation on the phone for: Google Play Services, Android Auto, Google Maps and Waze
15th January 2020, 09:11 AM |#4660  
Senior Member
Flag Muscat
Thanks Meter: 10
 
More
Quote:
Originally Posted by Emil Borconi

Can you send me a bug report from the phone please?

Which is your preferred/ recommended app for bug reports as I haven't got one installed

Cheers

Guy
15th January 2020, 09:14 AM |#4661  
OP Recognized Developer
Flag Tg. Secuiesc / Kezdivasarhely
Thanks Meter: 2,373
 
Donate to Me
More
Quote:
Originally Posted by Guyzer73

Which is your preferred/ recommended app for bug reports as I haven't got one installed

Cheers

Guy

None, see the OP for exact steps how to capture one. Make sure you capture it after Wifi Launcher for HUR started up and closed down.
Thank you.
Post Reply Subscribe to Thread

Tags
android auto, androidauto, headunit

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes