FORUMS

 View Poll Results: What should be my next focus?

Try to work out how to integrate ODB2/CAN data?
 
18 Vote(s)
94.74%
Build a HUD app to work with HUR(HUDWAY style)?
 
1 Vote(s)
5.26%
Something else?
 
0 Vote(s)
0%

[Android 4.1+] HeadUnit Reloaded for Android Auto with Wifi

3,075 posts
Thanks Meter: 2,577
 
By Emil Borconi, XDA Ad-Free Recognized Developer on 4th August 2016, 12:47 AM
Post Reply Email Thread
20th May 2020, 02:18 AM |#5071  
Member
Thanks Meter: 7
 
More
managed to get wireless AA working

i installed android auto for phone screen then enabled developer mode which then give a the option to start headunit server
20th May 2020, 03:57 PM |#5072  
Member
Thanks Meter: 5
 
More
Sent from my BLA-L09 using Tapatalk
22nd May 2020, 06:30 PM |#5073  
Junior Member
Thanks Meter: 0
 
More
v5.2 Freezing Up
Using v5.2b on my old AN-21 and with my new Galaxy S20 Android Auto will come up and it will appear to be working but the screen will freeze about 5 seconds into it.

Tested with both WiFi and USB.

Tried old USB driver
Tried software/hardware decoding
Tried wipe cache/data/reinstall
Disabled as many things in options as possible to see if it would become stable, no dice.

Halp.
22nd May 2020, 09:04 PM |#5074  
Junior Member
Thanks Meter: 0
 
More
Black screen on Pie device
Hi all!

I purchased a spanking new Lenovo Tab2 running Pie 9 as head unit as it fits my car perfectly and I tried to get HUR to work with my Samsung S7 running Android 8.0.0 and Android auto. Phone has internet access and is hot spot configured. All I got was black screen on the Tab2. Tried USB and when I connect to the Tab2 the screen goes black. Installed WIfi launcher and tried using WiFi and the screen goes black. Changed the settings in HUR to software decoding but no success. Tried different resolutions. Stretch or no stretch. Still black. The phone keeps the Android auto, HUR never take charge. Projection to HU screen is activated in AA. If I stop the AA server the HUR crashes and the black screen disappear .

Any ideas?

Edit: Lowered the phone screen resolution. Changed every screen setting I could find. Still black screen on the HUR. Must be something in the AA screen handover from phone to HUR that freeze the HUR on black screen and halts the handover from the phone.
I have also searched the thread for similar problems, many black screens but no fix? Or have people managed to fix the problem but didnĀ“t bother to post?

Edit2 ----WORKAROUND--
If I have the settings screen in AA active on the phone when starting HUR and hit WiFi, then HUR works on the Lenovo!
I still get the black screen when connecting when the AA home screen is active.

Edit 3

Purchased the app and now it works. Why have different app as trial? Would have saved me several hours if not.
24th May 2020, 12:27 AM |#5075  
Member
Flag Pothole capital
Thanks Meter: 11
 
More
Quote:
Originally Posted by jester450

Looks like I still have the issue of the screen dimming when using HUR. At least with a Joying HU

Sent from my SM-N975U1 using Tapatalk

Ah... so I'm not alone with this particular problem. Have you found a workaround or a fix for this?

I have a Joying head unit - albeit an old one - a Sofia-based model. I'm on Android 6.0.1 (the stable GTX ROM) and I have noticed this problem too - maybe it's been like this for a while, I don't use HUR/Android Auto that often. When I connect my phone, HUR starts, and immediately dims down my display. On a sunny day it's almost unusable, and on a cloudy day it's like being in night mode. I've started to use AA on my phone instead, which kinda defeats the purpose of HUR..

And since my Joying's display lighting settings are buried behind two passworded menus, it's a pain to bring the lighting backup. The setting is still unchanged at 100, and as soon as I bring it down to 99 it immediately comes back normal. I've played with the "don't dim screen" settings I found in HUR but it's not helping.

I hope this gets fixed ASAP!
24th May 2020, 04:09 PM |#5076  
Junior Member
Thanks Meter: 0
 
More
Not working with my S10+
Hey everyone

My device is an s10+ with the latest android version running whereas my headunit is some unbranded Chinese player that has android 9.1 (NOT ROOTED) for my car which is a suzuki swift (2004 model) and am using the trail version of your app right now with the plan of buying it if the problems are fixed

I have followed your instructions but im unable to get the android auto working via USB. the headunit detects the usb cable and i set it to usb tethering as default but it just wont load the interface, instead the app seams to lock up and it relaunches itself if i somehow close it or go to homescreen on the headunit. I have been able to get it working on wifi by installing android auto on my phone and running it as a server but its a tedious process still. What i have done is that i have set a routine on my phone that when it connects to my car via BT it automatically turns on the wifi hotspot which my headunit can then connect to. The problem with this is that after connecting it wont launch the app automatically the first time. I have the setting enabled to launch the app when connected to a specific SSID and it does it but only when i have opned the app the first time manually. So like if i start my car and it automatically connects to my bluetooth and wifi. it wont turn the app on and connect me to android auto. But if i open the app and then close and then disconnect and reconnect my wifi and bluetooth without turning the car off. the app launches and connects me to android auto automatically.

I have tested this with 3 phones (s10+, a50, a7(2018 running android 9.) the a50 and s10 both running android 10 show the same problem where the a7 just works flawlessly. I connect it via usb and it fires up and launches android auto on the head unit. Maybe its an issue with samsung version of android 10. I am yet to check the same with any other phone running android 10 which is not made by samsung.

Dont know what seems to be the problem now. Can anyone help?
25th May 2020, 06:15 AM |#5077  
djluis48's Avatar
Senior Member
Flag Santo Domingo
Thanks Meter: 234
 
More
Hi guys. I want to use my tablet, a Nexus 7 2013 running Android 9 as an Android Head Unit for my car. I installed this app (Paid from the Play store) and want to connect to my phone (Samsung S8+ on Android 9) wireless, but I haven't been able to do it. For some reason it won't connect at all. I installed the Wifi Launcher app on my phone, but Im not sure if it's working correctly. It seems to crash when I press the button on the lower right (don't know if that's the correct behavior.). Is there an updated tutorial or something on how to get this working? It's so confusing. Lots of info on the first post. Can someone help me please?
25th May 2020, 09:44 AM |#5078  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by djluis48

Hi guys. I want to use my tablet, a Nexus 7 2013 running Android 9 as an Android Head Unit for my car. I installed this app (Paid from the Play store) and want to connect to my phone (Samsung S8+ on Android 9) wireless, but I haven't been able to do it. For some reason it won't connect at all. I installed the Wifi Launcher app on my phone, but Im not sure if it's working correctly. It seems to crash when I press the button on the lower right (don't know if that's the correct behavior.). Is there an updated tutorial or something on how to get this working? It's so confusing. Lots of info on the first post. Can someone help me please?

Don't press the red button that closes the app
25th May 2020, 11:18 AM |#5079  
djluis48's Avatar
Senior Member
Flag Santo Domingo
Thanks Meter: 234
 
More
Quote:
Originally Posted by clarkiefishing

Don't press the red button that closes the app

Thanks for making this clear to me. Then how it works? When i open it, it just does nothing.

Also, i was able to get it to work via Wifi, but i wasnt able to get the phone calls to my tablet. It said that bluetooth is not connected, but when i pair my phone and my tablet, my phone doesnt give me the option to send calls to my tablet or anything. Only gives me the option to tether internet via bluetooth to it. Also they don't have an active connection. How can i fix this?

And any help to get Wifi Direct going would be appreciated. On Wifi, AA looks good, but its kind of slow. I belive on Wifi Direct would be faster.
25th May 2020, 11:48 AM |#5080  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by djluis48

Thanks for making this clear to me. Then how it works? When i open it, it just does nothing.

Also, i was able to get it to work via Wifi, but i wasnt able to get the phone calls to my tablet. It said that bluetooth is not connected, but when i pair my phone and my tablet, my phone doesnt give me the option to send calls to my tablet or anything. Only gives me the option to tether internet via bluetooth to it. Also they don't have an active connection. How can i fix this?

And any help to get Wifi Direct going would be appreciated. On Wifi, AA looks good, but its kind of slow. I belive on Wifi Direct would be faster.

You connect the phone to the cars Bluetooth.
In the launcher app select the car Bluetooth connection.
Forget wifi direct.

Have you read the opening posts you can find all the details there.
25th May 2020, 02:10 PM |#5081  
djluis48's Avatar
Senior Member
Flag Santo Domingo
Thanks Meter: 234
 
More
Quote:
Originally Posted by clarkiefishing

You connect the phone to the cars Bluetooth.
In the launcher app select the car Bluetooth connection.

What can i do if my car doesn't allow me to connect 2 bluetooth devices at the same time? Can't have my phone and my tablet connected to the car at the same time.

Quote:
Originally Posted by clarkiefishing

Forget wifi direct.

So Wifi Direct doesnt work??

Quote:
Originally Posted by clarkiefishing

Have you read the opening posts you can find all the details there.

Yeah but its very confusing. Theres A LOT of information in there.
The Following User Says Thank You to djluis48 For This Useful Post: [ View ] Gift djluis48 Ad-Free
Post Reply Subscribe to Thread

Tags
android auto, androidauto, headunit

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes