FORUMS

[APP][Android 4.4+][ROOT] EX Kernel Manager

18,016 posts
Thanks Meter: 87,189
 
By flar2, Recognized Developer on 21st February 2017, 07:01 PM
Post Reply Email Thread
21st December 2019, 07:05 PM |#1101  
Junior Member
Thanks Meter: 4
 
More
I get the notification to install ElementalX 3.08 on my OnePlus 7T Pro but it never downloads.

Anyone able to help?
23rd December 2019, 09:22 AM |#1102  
Senior Member
Thanks Meter: 69
 
More
@flar2 do you mind explaining more about the update for oneplus? did you simply add the auto kill for oneplus brain service or is there anything that you did to fix it?[COLOR="Silver"]

---------- Post added at 09:22 AM ---------- Previous post was at 09:22 AM ----------

[/COLOR @flar2 do you mind explaining more about the update for oneplus? did you simply add the auto kill for oneplus brain service or is there anything that you did to fix it?
23rd December 2019, 04:35 PM |#1103  
Member
Thanks Meter: 21
 
More
@flar2

With software update 10.0.7 for the OP7T Version 2.0.7 and 2.0.8 of ElementalX causes battery drain. I think that it might be because cluster 3 appears to stay maxed out at 2956 mhz. Whenever I flash the stock kernel the drain goes away. Maybe it's a coincidence, I don't know. Any ideas?
23rd December 2019, 05:14 PM |#1104  
Quote:
Originally Posted by rohmbd

@flar2

With software update 10.0.7 for the OP7T Version 2.0.7 and 2.0.8 of ElementalX causes battery drain. I think that it might be because cluster 3 appears to stay maxed out at 2956 mhz. Whenever I flash the stock kernel the drain goes away. Maybe it's a coincidence, I don't know. Any ideas?

It's a known issue, i am going to look into it tonight. Some OnePlus bs
The Following 4 Users Say Thank You to flar2 For This Useful Post: [ View ]
24th December 2019, 01:12 AM |#1105  
Senior Member
Thanks Meter: 199
 
More
Quote:
Originally Posted by flar2

It's a known issue, i am going to look into it tonight. Some OnePlus bs

ill just refer to @Mohammed779:
Quote:

For your information,

This problem is because of the update 10.0.7. The frequency of cluster 3 is stuck at 2.9GHz. which is because of a OnePlus process running all the time.

You'd like to fix it? You need root then flash this module in magisk.

The module basically stops that process after few seconds of rebooting. Works fine on my 7T.

If root isn't your thing, you'd have to go back to 10.0.6.

so there is no real fix here other than killing this process (opbrain), which certainly isnt ideal.

but i heard, that the sources of 10.0.2 has been released, so perhaps this helps.
27th December 2019, 07:44 PM |#1106  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by JakeDHS07

Is there anything on support for the December update? I'm on Pixel 4 XL and from what I've been able to gather the update breaks face unlock if you try and use the current released kernel? Haven't tested myself but just curious if anyone knows of a fix or confirmation.

Face unlock on December patch working flawlessly on Pixel4-1.02 here.
The Following User Says Thank You to lattosimbaste For This Useful Post: [ View ] Gift lattosimbaste Ad-Free
28th December 2019, 11:59 AM |#1107  
Senior Member
Flag Bangalore
Thanks Meter: 422
 
More
@flar2

Please add an option to delete user created profiles (color settings)

Thanks
1st January 2020, 11:37 PM |#1108  
Senior Member
Thanks Meter: 102
 
More
Quote:
Originally Posted by flar2

It's a known issue, i am going to look into it tonight. Some OnePlus bs

I was trying to figure out what blew up my battery... the OP7P update that just pushed the other day (mostly just bug fixes), or the latest update to ElementalX. Then I saw this post.

I did the OP7P update this morning, and the latest ElementalX this morning. I spent my day both yesterday and today the exact same way... wake up, eat, then work on remodeling my parents room. Basically just listening to Pandora and using Bluetooth headphones. After four hours of working yesterday, my battery was at 89%. After four hours of working today, my battery was at 37%. It's also been burning a hole in my pocket all day. I thought it might've been a stuck app or something, but I closed everything I wasn't using in the first 30 mins, when I first noticed the phone being hot.

Is there anything I can check to see whether it's OnePlus, or the kernel? I'm sure you will just say "it's not the kernel", but please have an open mind. Even though you do amazing work (I wouldn't be here, or have purchased your app if you didn't), things happen.

**EDIT**
Cluster 3 does appear to be stuck at 99%

Screenshots:
https://ibb.co/25XT9gh
https://ibb.co/V3BBbRd
2nd January 2020, 03:00 AM |#1109  
DaveedDB's Avatar
Senior Member
Flag Bridgetown
Thanks Meter: 473
 
More
Quote:
Originally Posted by Flapjack

Is there anything I can check to see whether it's OnePlus, or the kernel? I'm sure you will just say "it's not the kernel", but please have an open mind. Even though you do amazing work (I wouldn't be here, or have purchased your app if you didn't), things happen.

**EDIT**
Cluster 3 does appear to be stuck at 99%

Screenshots:
https://ibb.co/25XT9gh
https://ibb.co/V3BBbRd

You could try installing the stock update without the kernel and see if the problem persists
The Following User Says Thank You to DaveedDB For This Useful Post: [ View ] Gift DaveedDB Ad-Free
2nd January 2020, 03:29 AM |#1110  
Quote:
Originally Posted by Flapjack

I was trying to figure out what blew up my battery... the OP7P update that just pushed the other day (mostly just bug fixes), or the latest update to ElementalX. Then I saw this post.

I did the OP7P update this morning, and the latest ElementalX this morning. I spent my day both yesterday and today the exact same way... wake up, eat, then work on remodeling my parents room. Basically just listening to Pandora and using Bluetooth headphones. After four hours of working yesterday, my battery was at 89%. After four hours of working today, my battery was at 37%. It's also been burning a hole in my pocket all day. I thought it might've been a stuck app or something, but I closed everything I wasn't using in the first 30 mins, when I first noticed the phone being hot.

Is there anything I can check to see whether it's OnePlus, or the kernel? I'm sure you will just say "it's not the kernel", but please have an open mind. Even though you do amazing work (I wouldn't be here, or have purchased your app if you didn't), things happen.

**EDIT**
Cluster 3 does appear to be stuck at 99%

Screenshots:
https://ibb.co/25XT9gh
https://ibb.co/V3BBbRd

Check the op7 forms, there is a Magisk module to fix it. For some reason, OnePlus released Incomplete source code
The Following User Says Thank You to flar2 For This Useful Post: [ View ]
2nd January 2020, 04:31 AM |#1111  
Junior Member
Flag Saline, MI
Thanks Meter: 5
 
More
Quote:
Originally Posted by flar2

Check the op7 forms, there is a Magisk module to fix it. For some reason, OnePlus released Incomplete source code

Here's the thread on the problem: https://forum.xda-developers.com/one...0-0-7-t4026777

And the one with the Magisk module: https://forum.xda-developers.com/one...-t4026327/amp/

I installed it a couple days ago and it solved the problem.
The Following User Says Thank You to bjs339 For This Useful Post: [ View ] Gift bjs339 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes