FORUMS
Remove All Ads from XDA

[CWM/ROOT/OTA] Alcatel One Touch Pop S7 / Vodafone Smart Power

300 posts
Thanks Meter: 101
 
By vickdu31, Senior Member on 28th October 2014, 12:30 AM
Post Reply Email Thread
Hi everyone, We rooted the Alcatel OT Pop S7 !
thanks goes to my friend @danycmoi who helped me to get this device rooted !

Quote:

Reminder : We are not responsible if your device get damaged while rooting it...

Here's all you need :
- Recovery.img+le Scatter File (For POP S7 ONLY) : http://d-h.st/BPN (You can try it on Vodafone Smart4Power but backup your phone first !)
- Root_KitKat_4.4.zip : http://d-h.st/vkQ
- MTK Driver_Auto_Installer_v1.1236.00 : http://d-h.st/p3m
- SP FlashTools V5.XX : http://mtk2000.ucoz.ru/down11/SP_Fla...v5.1352.01.rar

How to flash :
0- Copy "Root_Kitkat_4.4.zip" in your SD card.
1- Make sure you have USB debug option checked (in settings/developpers options).
2- Open and install the MTK Auto-Drivers
3- Turn off your phone and connect it to your computer (this will load up the MTK drivers).
4- Remove your phone from computer and make sure its turned off
5- Make sure you have extract "SP Flash Tools" and "recovery.img+scatter.zip"
6- Run SP Flash Tools AS ADMIN
7- Click on "scatter-loading" and select "MT6582_Android_scatter_emmc.txt " from the previously extracted "recovery.img+scatter.zip"
8- Check "RECOVERY" box ONLY, double click on the empty green space on this line and select the file "recoveryCWM__Alcat_POP_S7.img"
9- Click the "Download" button
10- Connect the phone (make sure it was turned off)

You'll see a red line loading and then a yellow line loading. At the end, you will see a green circle saying "OK" !
Congratulation, you have installed the CWM Recovery !
Now, let's root it :

11- Remove the USB cable
12- Turn on you phone by holding VOL+ and POWER button - You will enter the CWM recovery !
13- Select "install zip from SD Card"
14- Select the file "Root_KitKat_4.4.zip" and confirm its installation.
15- Select "reboot to system now"

Your device is now rooted ! Congratulations !
Stock Recovery :
If you want to get the stock recovery back, there you go : http://d-h.st/Fun
About OTA Updates
Alcatel released one more OTA update, you can't flash it directly.
However, here is the .zip (http://d-h.st/Dcc) update 0003 for PopS7, i flashed it with CWM !
It didn't first work because i deoxeded my phone, so i flashed system.img back and it worked.
Warning : This will flash a new recovery, you can flash CWM again using SP Flash Tools.
You can try this EXPERIMENTAL .zip with no recovery flashing (didn't test it) : http://d-h.st/9NSA
They updated some libs (like camera) and some system apps.
Don't forget to thanks my friend @danycmoi
The Following 4 Users Say Thank You to vickdu31 For This Useful Post: [ View ] Gift vickdu31 Ad-Free
 
 
28th October 2014, 01:17 PM |#2  
Junior Member
Thanks Meter: 1
 
More
Thumbs up Tuto
Tuto flashTool

Danycmoi
7th November 2014, 04:20 PM |#3  
Senior Member
Thanks Meter: 13
 
More
do you have the stock recovery img too?

awesome cwm. works for alcatel's "clone" (vodafone smart power). installed root right now
16th November 2014, 06:52 AM |#4  
Senior Member
arges
Thanks Meter: 20
 
More
when we see a android lollipo costom rom for this phone?
17th November 2014, 05:33 PM |#5  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by costyprj

when we see a android lollipo costom rom for this phone?

I doubt it would be anytime soon but I would very much like to see cyanogenmod 11 for this phone.
The Following User Says Thank You to Ratchet66 For This Useful Post: [ View ] Gift Ratchet66 Ad-Free
27th November 2014, 11:39 AM |#6  
vickdu31's Avatar
OP Senior Member
Thanks Meter: 101
 
More
I don't know about android 5.0 and we don't yet have any custom rom !
I think, there will be problems while porting rom because there are only a few mt6582 phones with LTE support... There's a CM11 build for mt6589 but we are far from getting it in our PopS7.
MTK devices are becoming more customisable with time! This is a good point !

Here is stock recovery : http://d-h.st/Fun
27th November 2014, 12:15 PM |#7  
Senior Member
Thanks Meter: 13
 
More
Can't we port it from android l? Same mt6582 chipset.
29th November 2014, 12:32 PM |#8  
MorpheusOp's Avatar
Member
Thanks Meter: 6
 
More
Links are dead!
@vickdu31 the links are dead, i tried downloading and it says: This account's public links are generating too much traffic and have been temporarily disabled!
The recovery its working on the branded Vodafone same phone? Thanks!
30th November 2014, 07:23 AM |#9  
vickdu31's Avatar
OP Senior Member
Thanks Meter: 101
 
More
Hi all, i'm uploadig files again.
I didn't try it in the vodafone, If you backed up your recovery, you can give it a try . @Andrei221 says it's working !)
@Andrei221 , i don't really understand what you mean. Porting android L ? We didn't port any rom to it yet ! You can start working on something if you want but i think our chipset is a bit different than classir MT6582 because it has 4G LTE support !
30th November 2014, 10:34 AM |#10  
MorpheusOp's Avatar
Member
Thanks Meter: 6
 
More
Backup
Hi @vickdu31 . Thank you for re-uploading the links. I`m trying to backup my stock rom from Vodafone. I created the scatter file with MTK Droid Tools. I want to get boot.img and recovery.img but they are 20 MB the both. When i try to create CWM recovery with MTK Droid Tools, loading the files boot.img and recovery.img in right log it says :
Quote:

- Boot kernel version =3.4.67
It is created: C:\Users\Bogdan\Downloads\mtkd\MtkDroidTools\recov ery\vvff_boot_patched_141130-123050.img
It is created: C:\Users\Bogdan\Downloads\mtkd\MtkDroidTools\recov ery\vvff_recovery_141130-123050.img
--- ERROR :Recovery doesn't match by the size
--- task is complete ---

I dont know why they are 20 MB. Can you help me with this? Thank you!
30th November 2014, 10:46 AM |#11  
Senior Member
Thanks Meter: 13
 
More
The stock recovery images are 20mb indeed.

But just flash the recovery from the topic. I have vodafone and IT works flawlessly
Post Reply Subscribe to Thread

Tags
alcatel, kitkat, pop s7, recovery, root

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes