FORUMS

[GUIDE] How to root Vestel Venüs V5 (A.K.A. Teos)?

4 posts
Thanks Meter: 1
 
Post Reply Email Thread
IDEA AND NOTICE

So, according to my researches over the Internet, there are plenty of users owning this device looking for this and here I share what I did to root it. Don't worry about the simplicity. You'll just need a little bit command knowledge.

REQUIREMENTS

/ Vestel Venüs V5 (That's our device! - Please turn on USB Debugging in Developer Settings for everything to work well.)

/ A working Internet connection (You don't want to have a broken root, do you?)

/ Stock boot.img (I extracted+uploaded myself)

/ Magisk Manager (To patch the stock boot.img - Couldn't put a link to it as XDA appears to have censorship against it.)

/ A computer with ADB and Fastboot installed (To flash our boot.img - For Windows, I recommend using 15-second ADB installer to install if you don't have it.)

/ A USB Type-C cable (To transfer our patched image to the computer)

WARNINGS

IMPORTANT NOTE: Please follow the steps as-is. A misstep has the ability to make your phone unbootable without reflashing the ROM.

ATTENTION: BEFORE DOING ANYTHING, TAKE A FULL BACKUP OF YOUR DATA AS WE'RE GOING TO UNLOCK THE BOOTLOADER, WHICH WILL RESULT IN FACTORY RESET!

And as everyone says, I'm not responsible about the possibilities on these type of stuff as it worked on me plus I did a thing that nobody did: Mentioned possible problems and their solution.

TUTORIAL

/ At first stage, download the boot.img and Magisk Manager. Don't forget to install Magisk Manager.

/ Now open Magisk Manager and install Magisk. Select file patching as the installation method and point the boot.img you've just downloaded.

/ When download+patch is done, turn on your PC, connect your phone using USB cable and transfer "magisk_patched.img", which will be placed in your phone's internal storage's download folder.

/ Then, open a command prompt (Windows)/Terminal window (Linux - MacOS), navigate to the folder that you've transferred patched image to.

/ Now restart your phone into Fastboot.

Code:
adb reboot bootloader
/ Make sure your phone is being detected by your PC. For Windows, you have to open Device Manager (devmgmt.msc) and update the device "Android" online.

/ When all done and you made sure your PC detects your phone in Fastboot, unlock the bootloader first.

Code:
fastboot flashing unlock
/ Check your phone. It has to show a warning regarding to bootloader unlocking. If it does, use Vol- button to highlight "Yes". But before having this done, again, make sure you backed literally all your data up. If you're sure, just hit Power button and accept unlocking. Your phone will reboot and will see a warning regarding to software checking. On that screen, press a random volume button and select Fastboot. We're not done yet.

/ Now, finally, flash the image we patched and transferred earlier.

Code:
fastboot flash boot /path/to/patched/image
For my case, as a Windows user;

Code:
C:\adb\fastboot.exe flash boot C:\Users\owZ\Documents\magisk_patched.img
/ When it's done, reboot your phone regularly. Don't forget that the warning I've mentioned will come up until you lock the bootloader, which I don't recommend. Also, since we didn't allow it to do the factory reset before, it's going to do the reset now.

Code:
fastboot reboot
/ When your phone boots up and you set it up regularly, head to Magisk Manager website and install Magisk Manager again. If you want, you can now integrate it to the system using Root Essentials or some other apps.

PROBLEMS

/ When trying to remount/modify /system partition, phone freezes until I do hard reset! - To solve, you have to literally reset your phone!

/ Most of the times; when trying to apply/remove a substratum legacy theme, the phone freezes. - Because it tries to modify /system partition - It requires reset to solve. If you're removing the theme, you can use Lucky Patcher to remove the overlays as LP uses a different method to remove system apps. But be careful that if you remove Android System/System UI overlay, you have to reboot your system (Android System overlays)/System UI (System UI overlays) not to cause infinite boot!

/ Magisk Manager has a few seconds of latency for showing root confirmation dialog - It's a problem with Magisk itself, not the phone.

/ The phone freezes upon opening ES File Explorer - I guess you tried to mount a system partition through it - Clear its data, reboot your phone and try to open it again.

/ After I successfully modify /system partition and reboot the phone, it gets stuck on branding screen - Go to recovery, press both three keys (Power, Vol+, Vol-) using a flat surface to show up the options (I recommend a desk), mount /system there and reboot. If this doesn't solve, do same but also clear cache.

/ Xposed Framework fails to install, freezing my phone - Original Xposed causes that, right. Just install it through Magisk Manager. Don't forget to install patched Xposed Installer there, too. This will also clear Dalvik-cache, which will result in really long boot for the first time as Android detects it as a system update.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes