FORUMS

Installing Custom ROM on Cubot KingKong Mini

20 posts
Thanks Meter: 6
 
By moctir, Junior Member on 14th February 2020, 11:15 AM
Post Reply Email Thread
22nd June 2020, 07:01 PM |#21  
Junior Member
Thanks Meter: 1
 
More
Can Someone update the guide to install any(safe) custom rom on this device? BCS i read all the thread but cant understand some passages, Ty guys

(I dont want to Stick with this chinese spyware)
28th June 2020, 07:15 PM |#22  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Ce3apyc

Actually there is TWRP for this model ported from alcatel by NickyNS. You can pick up it from here.
You can flash it with fastboot along with the patched lk which is to disable the "Orange state" message. After flashing it you should enter TWRP right with the next step (without booting to OS). On this stage you might want to disable encryption in order to have full-fledged backup-recovery option in TWRP next time you use it. To do so you will have to format data partition. After that step you will loose all you applications and user data for them, so you should backup it previously. After you format the data, flash Magisk first, then flash encryption disabling script from this post. Now you can boot to OS.

Note, that attached TWRP is only valid for firmware CUBOT_KINGKONG_MINI_9101C_V06_20191121. Cubot has released a new one and you can try to use the TWRP with it, but there is no guarantee it will work correctly.

Friends ask for help about the Root
I installed TWRP and after hours of searching, I found a method to unencrypt files by installing certain files and because I didn't know what the role of each file was, I installed all of them:
Disable_Dm-Verity_ForceEncrypt.zip
DisableForceEncryption.zip
FCrypt_Disabler.zip
no-verity-opt-encrypt-6.0.zip
(I was desperate and didn't understand what each file did exactly)
Then I installed Magisk Zip by the recovery and the Magisk APK
All installations went through TWRP with no errors at all including the Magisk Zip
But I haven't taken root yet and I still have a question mark instead of a green vi
Did I do something wrong?
What are the steps that need to be done and are they important to order?
2nd July 2020, 09:12 AM |#23  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by robrazil

This is a very important information. When I did a update firmware the usb cable disconnected and the mobile died. Black screen. The side buttons died too. Only blue led turn on when the usb cable is connected on PC. The windows 10 only recognized the mobile as "unknown usb device (device descriptor request failed)". I thought that had lose the mobile. A few days later when I connect the mobile in the PC, the battery image was showed on screen with 18% of charge and I saw in that moment that I could flash the firmware again.
I flashed official firmware and the mobile worked again but now it died again... because I did a wrong recovery boot. I will wait discharge the battery again.

I have black screen too and unworking buttons since 4 days ago. How long will take discharging battery in this state? I try around 10 times a day to power up the phone. I'm very patient but I'm thinking on disassemble phone and battery despite losing the warranty.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes