FORUMS
Remove All Ads from XDA

LineageOS crazy battery stats fix?

9 posts
Thanks Meter: 0
 
By EnchantedPeanut, Junior Member on 11th July 2019, 12:29 AM
Post Reply Email Thread
So basically I recently installed a LineageOS 13.1 unofficial ROM (built from source) on my 2nd phone and it has some issues that I'm trying to fix myself since the developer ditched the ROM entirely a while ago.
The system is kind of unstable and the phone gets quite hot (probably something to do with CPU temps) but since I have root I'm thinking of simply installing Kernel Adiutor, running some init scripts and tweaking the settings to my liking.
The main issue I have with this ROM is that for some reason, the ROM thinks my battery has a capacity of 2000mAh (from AIDA64) when it actually has more than that. The battery indicator drops to 1% very often out of nowhere until I decide to plug in the charger and leave it charging for a while. Eventually it goes back to 1% again though.
When I decide to leave the phone hanging on 1% (even though in reality it rarely is at 1%) it soon reaches 0% and the phone shuts down in the middle of whatever I'm doing.
I have no idea where the root of the issue is. I've tried replacing some libs from the stock ROM and some other custom ones made for this device and it got me stuck on bootloop sometimes so I had to restore TWRP backups, I tried flashing a new boot image that I made which had a ramdisk healthd file from the stock ROM, all repacked nicely on ubuntu 19.04 but the phone got stuck on the Android logo bootloader.
I'm going to try and unpack the kernel to see what I can find but I'd appreciate if anyone could tell what is the root of this issue exactly and some possible fixes, thank you!
 
 
14th August 2019, 05:59 PM |#2  
pavelkin's Avatar
Junior Member
Thanks Meter: 2
 
More
could you specify the model of the phone
The Following User Says Thank You to pavelkin For This Useful Post: [ View ] Gift pavelkin Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes