[ROOT] tutorial for root Bluboo S8 with TWRP

3rd November 2017 06:41 PM 0 Thanks
fanfan7110 Senior Member
As promised, here is the tutorial to root the bluboo s8 with TWRP and even install alternative roms via TWRP.
As always, you do this at your own risk, I am not responsable in case of brick of your smartphones.
This way of installing TWRP is accurate and works with the version V11 of NEEDROM and V14 official ROM. I did not try with the classic factory ROM.

UPDATE 28 NOV 2017 : Added trick (in the procedure) to force the phone to keep TWRP and not restore the original recovery.
Step 1: Prepare your PC
First DON'T USE THE ORIGINAL BLUBOO USB CABLE. Use only a USB-C cable from another smartphone or a universal cable. and in a USB 2 plug. The original bluboo s8 cable does not work properly.
- Download the ROM V11 on NEEDROM : Official V11 ROM for Bluboo S8
- Decompress it and open scatter file with a text editor. Change value MT6755 with MT6750 if needed
- Download TWRP : Twrp version for bluboo s8
- Decompress it and rename recovery(1).zip to recovery.zip
- Delete the file mt6750_androidscatter.txt
- Edit the file MT6755_Android_scatter.txt and change the line "platform: MT6755" to "Platform: MT6750" and save it. Rename this file to MT6750_androidscatter.txt
- Download SP FLash Tools here : last version
- If it's not done yet, install the android drivers. (search on Google)
- Install ADB drivers and utilities in a directory /ADB (see google, they are everywhere)
- Download the latest supersu .zip here : SuperSU last version

Step 2, if needed : Install the ROM stock V11 20170815
- Put your Bluboo in developer mode: Go to "settings" then "About" and then click on "build version" several times.
- Enable USB debugging: In developer tools
- Now you have to turn off the smartphone
- Launch SPFlash tools then load the V11 ROM into it
- Go in upgrade mode, not in dowload mode (Dont choose format all ! ! ! ! !)
- Clic on Download button
- connect cable and Start bluboo s8
- After flash done, reboot smartphone
Once the rom is installed, pass it also in developer mode as already done previously.
(you can, if you want, make all OTA updates before doing the rest tutorial ..)

Step 3 : Install TWRP
note that with this method, you don't need to unlock the bootloader.
- Copy the file supersu.zip in the root of the smarpthone
- Launch SPFLASH TOOLS and put the modified MT6750_androidscatter.txt on it.
- Check that there is only "recovery" checked
- Make sure the recovery points to the recovery.img file of the TWRP folder
- SPFLASH Tools must be in "download only" mode
- Click on Download
- Open a command window and go to your ADB directory
- Type ADB DEVICES. (if needed, confirm in the bluboo screen)
- If all is ok, Prepare the command line: "ADB reboot recovery", but do not validate it
- Reboot the smartphone.
- Spflashtools will flash recovery with TWRP
(update of 28 nov here)
- After flashing the recovery, remove the USB cable, press volume- and reconnect the cable to reboot in android-test-mode (or After flashing the recovery, for first reboot, press VOL- and ON to go to the test page of the smartphone) to prevent the smartphone from loading the system and returning the original recovery.
When you are in the test page (a line with chinese caractere), type ADB REBOOT RECOVERY and TWRP is loading..
(works really all times)
- The phone reboot in recovery mode and TWRP appears. (The launch of TWRP can take a little time, do not panic)
- In TWRP, start installing superSU as usual.
- Once installed, reboot the smartphone (without installing utility, if it offers it)
- The phone restarts and is rooted 
- From now on, TWRP is really installed in recovery on your smartphone, so you can install custom roms with.

To go in recovery mode, go to adb and type "ADB Reboot Recovery". that else.

[I]information :
I repeat: This method works without unblocking the bootloader.
Anyway, the vol + key does not work in fastboot mode with bluboo s8, so only a method without unlocking is possible. My method is adapted.
5th November 2017 05:30 PM 0 Thanks
ashyinvader Junior Member
So step 4 can't be done normally!?! I mean without doing step 1 and 2 ?!? Besides I tried to unlock my bootloader, did everything correctly, but I got stuck on "CHOOSE VOLUME UP TO UNLOCK BOOTLOADER in mobile screen "
Coz if I press volume up nothing happens?!? Only volume down work, that to cancels the whole process . Plz clarify and explain..
8th November 2017 05:26 PM 0 Thanks
labellee25 Member
I have the same problem with the locked boot loader. I can't pres Vol Up , only Vol Down.
10th November 2017 09:18 PM 0 Thanks
fanfan7110 Senior Member
Personally I did not need to unlock the bootloader so ..
Technically, by following the tutorial in order, there is no need to unlock the boot loader. I know that only a few bluboo s8 have unlocked ok (with the line "unlock bootloader" active in "developer option" menu), all the others have the volume + which does not work.
Anyway the unlocking of the bootloader is not useful here. Do not forget that you must be in Rom v11 !

And the photo of my bluboo s8 with twrp :


12th November 2017 06:13 PM 1 Thanks
fanfan7110 Senior Member
Tested today, the leegoo s8 ROM ported, installed with TWRP and result is wondefull ....
Much better thought than the original rom of the bluboo, lighter .. Top!

This is screen capture of the phone state :
13th November 2017 10:11 PM 0 Thanks
FreeMaN83000 Junior Member
Hello fanfan7110,
apparently you're French, so am I. Are DRMs implemented in the Leagoo ROM? Do Molotov Tv and Mycanal applications work?
thank you
18th November 2017 05:05 PM 0 Thanks
FreeMaN83000 Junior Member
Hello,
I tried the tuto but it doesn't work. When I reboot in recovery, there's an android down with a red sign and it says no command. I tried several times and it's always the same...
22nd November 2017 09:27 PM 0 Thanks
samot4 Junior Member
When you get dead android press volume up+ power.The v.11 stockrom did notvwork for me.Spflashtool gave erfors.I found another stockrom from september on a russian site that worked.No need to adb reboot recovery descriebed here just do it with the phone turned on an you will get the dead android.Power + volume up gets you into twrp.
23rd November 2017 09:16 PM 0 Thanks
FreeMaN83000 Junior Member
Hello,
Thank you for your answer, I'll try that as soon as I can.
24th November 2017 08:10 PM 0 Thanks
franky lezard Member
After you root the device can we make update the roms to go back to V20 ? or we stuck on the V11 without the update . i try so many time to root and remove the initiator app to have the launcher i want ,without luck .

---------- Post added at 03:10 PM ---------- Previous post was at 03:10 PM ----------

Quote:
Originally Posted by samot4

When you get dead android press volume up+ power.The v.11 stockrom did notvwork for me.Spflashtool gave erfors.I found another stockrom from september on a russian site that worked.No need to adb reboot recovery descriebed here just do it with the phone turned on an you will get the dead android.Power + volume up gets you into twrp.

where did you find the roms ? can you copy the link here please ?
close
Advanced Search
close