FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[Bug?] WiFi battery drain on 6.0 & 6.0.1 and workaround (Fixed since April MOB30D)

1,183 posts
Thanks Meter: 805
 
By jineshpatel30, Senior Member on 7th October 2015, 03:36 PM
Post Reply Email Thread
Google fixed this in 6.0.1 (edit : you still need to disable wifi scan in location setting edit2: Google fixed this in April MOB30D so update to any release after April'16 to get rid of this bug from source )along with instant quick setting wifi connect & many more ! So update to 6.0.1 asap. (System less root 2.61+ & Xposed v78+ is working on 6.0.1 so don't worry about it )

Edit 2: Some people are facing battery drain due Google play services (9.x.xxx) which is not anyway related to this bug present in rom. Still here is work around for you

Quote:
Originally Posted by springy

Unfortunately I still get the Wifi bug and I am on the July patch. I remember it disappeared in the May patch but reappeared in the June patch. The way I solve it is just to restart the device every day.

But I do think it may have something to do with Play Services as I do see that often as the app consuming a lot of battery

Then it's Not wifi bug due to ROM..it's entirely related to Play Service.

Work around for it is to disable 4 receivors indicated in below post.

http://forum.xda-developers.com/show...&postcount=922


PS: u can use free tool, "My android tools" from playstore.

& disable these 4 things under "RECIEVER" tab from play services

PS: some people claims that it was related to Google Connectivity Service ,but i had it disabled all the time in 6.0 & still drain was gone for me. So i believe it's not actually related to it, after all Google connectivity services is only needed for "Project Fi" (available only in USA) other ppl can simply disable it

Edit: reported to Google (with new screen shots )...here->
https://code.google.com/p/android/is...tail?id=189018
If you are also seeing this bug kindly report it in about link and star that issue as well

Workaround :

Well after using phone for entire 3 charging cycles with different settings I think main problem for this is "WiFi always scan" in location setting..many users reported how to turn it off in comments (thanks )

If you still facing this problem...

Go to Settings>Location>Scanning(top right)>Wifi Scanning ( disable it ) & Bluetooth Scanning (disable it as well)


if bug appers after few days, 1st check your "WiFi scanning" in Location again (turn it off if it's on ) it starts automatically after using navigation (randomly) !




In most cases this will solve the problem..but if you are still seeing much battery drain

Then change your Location Setting to Device only ( or you can entirely disable it if you don't relay on Location base Google Now cards )

If all of above fails Wiping Cache In Stock Recovery or Changing WiFi band in WiFi advance setting, also helps in some extreme cases ( as reported by some users )

here is video by @isrmicha for the same steps if you can't figure-out from pics,


One more thing I have noticed is Quick setting tile takes much time (15-20seconds) to connected WiFi unless we open "more settings " by clicking on down Aero on tile...in this case it will connect instantly....if you are facing this as well then do above to connect instantly
(I think Google disabled instant scanning for wifi on QS toggle..so it takes some time for scanning available networks after Turing on wifi)
(Fixed in 6.0.1)

Click below to see what's the problem with scanning ON, if you are still not aware of it

1st of all i'm fully stock...and i'm very impressed with battery life on 6.0...personally I never got SOT for than 4 hrs on Lollipop but on M it's been almost 4 and half hr and still 23% remaining so overall battery life is much improved for me and DOZE is doing it's work excellently (without any interference )

But the problem is as per stats WiFi is biggest battery drainer for me it shows about 53% use and Power used by it is also too much...i have never seen this much uses of WiFi ! It's more than Drain by Screen On

So is this some kind of bug or just different calculation method ? Seeing overall improved battery life I'm confused to call it bug





The Following 31 Users Say Thank You to jineshpatel30 For This Useful Post: [ View ] Gift jineshpatel30 Ad-Free
 
 
7th October 2015, 04:38 PM |#2  
eddiehk6's Avatar
Senior Member
Flag London
Thanks Meter: 670
 
More
Does seem quite high, even though you're getting better battery than previously. During 'normal usage' of the device, Screen ON should always be the biggest consumer.

A few things you could check / confirm and be more thorough / logical:

- Your WiFi appears always on. During this time, is it actually connected to a network, or do you always leave it on regardless? If it's actually connected to WiFi, does this usage occur on a single network, or multiple different networks?

- Do you also have "Scanning always available" enabled (In WiFi screen, Menu-> Advanced). If so, try turning it off and changing nothing else, does it make a difference?
7th October 2015, 04:53 PM |#3  
jineshpatel30's Avatar
OP Senior Member
Thanks Meter: 805
 
More
Quote:
Originally Posted by eddiehk6

Does seem quite high, even though you're getting better battery than previously. During 'normal usage' of the device, Screen ON should always be the biggest consumer.

A few things you could check / confirm and be more thorough / logical:

- Your WiFi appears always on. During this time, is it actually connected to a network, or do you always leave it on regardless? If it's actually connected to WiFi, does this usage occur on a single network, or multiple different networks?

- Do you also have "Scanning always available" enabled (In WiFi screen, Menu-> Advanced). If so, try turning it off and changing nothing else, does it make a difference?

1. That's what I was thinking..screen % should always more than anything else ( atleast when we are "actually" using phone)

2. No my WiFi wasn't always on I turned it off/on many times but it's not present in SS..that's weird ( set I forgot to Mentioned it in OP)

And I was connected to 2 different wifi networks only (1st 2-3 hrs after charging I was connected to hotspot..then for 7-8 hrs I turned off WiFi toggle before going to bed (but SS shows WiFi on in this time also !!! So it's definitely a bug)

3. There is no option to advance wifi setting to turn always scan off ( I know it was in lollipop but it's not present in M..I checked it twice )

Btw how to take a bug report ? "Take a bug report" is disabled in developer option & there is no way to turn it on (atleast I can't find it)

My battery it <5% now and I want to take bug report before putting it in charging so if someone know how to turn on bug report option plz reply fast




Edit: okay just took bug report ( I didn't enable usb debugging before ) ...now tell me how to report this bug to Google
7th October 2015, 05:33 PM |#4  
eddiehk6's Avatar
Senior Member
Flag London
Thanks Meter: 670
 
More
Quote:
Originally Posted by jineshpatel30

3. There is no option to advance wifi setting to turn always scan off ( I know it was in lollipop but it's not present in M..I checked it twice )

No idea then. I've never used M, just expected that same setting to still be there. Maybe it's buried / hidden somewhere else?

The other possibility, in the initial setup screens when you first set up the phone, did you enable the equivalent feature? Normally a check box saying that Google will scan even when WiFi is off. This is the only other thing I can think of which shows WiFi on even though you physically turned it off.

Quote:

Edit: okay just took bug report ( I didn't enabled usb debugging before ) ...now tell me how to report this bug to Google

No idea either, Google it . If you're fully stock with zero mods (or even other apps to be sure), it does seem like a strange bug.
7th October 2015, 06:25 PM |#5  
GtrCraft's Avatar
Recognized Developer
Flag Nijkerk
Thanks Meter: 11,354
 
Donate to Me
More
My Wifi is one of the lowest, 1%, 17 mah and almost 8 hours of use
7th October 2015, 06:28 PM |#6  
EddyOS's Avatar
Senior Member
Flag London
Thanks Meter: 4,018
 
More
I do not have this issue, WiFi is currently 6th on my list in battery. Now, having said that, I have WiFi on all the time as signal is bad at work and I don't use my phone a lot so I've currently got 1 day 20hrs life remaining...I don't believe it's an issue but this is only my first full day with 6.0
7th October 2015, 06:30 PM |#7  
jineshpatel30's Avatar
OP Senior Member
Thanks Meter: 805
 
More
deleted - duplicate
7th October 2015, 06:32 PM |#8  
jineshpatel30's Avatar
OP Senior Member
Thanks Meter: 805
 
More
Quote:
Originally Posted by GtrCraft

My Wifi is one of the lowest, 1%, 17 mah and almost 8 hours of use

Quote:
Originally Posted by EddyOS

I do not have this issue, WiFi is currently 6th on my list in battery. Now, having said that, I have WiFi on all the time as signal is bad at work and I don't use my phone a lot so I've currently got 1 day 20hrs life remaining...I don't believe it's an issue but this is only my first full day with 6.0

huh ! this is strange

what's your "location settings" ( i put it on high accuracy but i don't think it affect wifi drain )

and just to conform you are on official Marshmallow right ?

Edit : actually they merged my issue with one already present from Nexus 6 so i think many have this issues in M
7th October 2015, 06:34 PM |#9  
Senior Member
Thanks Meter: 177
 
More
Always scan settings are located in the location menu.

I'm a Brazilian without English Course, sorry and be comprehensive
The Following User Says Thank You to prog19 For This Useful Post: [ View ] Gift prog19 Ad-Free
7th October 2015, 06:39 PM |#10  
jineshpatel30's Avatar
OP Senior Member
Thanks Meter: 805
 
More
Quote:
Originally Posted by prog19

Always scan settings are located in the location menu.

I'm a Brazilian without English Course, sorry and be comprehensive

i disabled it on 1st boot up....btw is it same as WiFi scan in lollipop ? i though it's different and only related to Location.

anyway it was disabled all the time so it shouldn't be issue ( unless people disabled it are the only one getting this WiFi drain...if this case let me know )
7th October 2015, 06:44 PM |#11  
GtrCraft's Avatar
Recognized Developer
Flag Nijkerk
Thanks Meter: 11,354
 
Donate to Me
More
Quote:
Originally Posted by jineshpatel30

huh ! this is strange

what's your "location settings" ( i put it on high accuracy but i don't think it affect wifi drain )

and just to conform you are on official Marshmallow right ?

Edit : actually they merged my issue with one already present from Nexus 6 so i think many have this issues in M

Of course I am on Marshmallow, location is set on device only (GPS)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes