Remove All Ads from XDA
Honor View 10

exfat support almost works

1,544 posts
Thanks Meter: 1,238
Post Reply Email Thread
I added exfat support to kernel sources, then I built the kernel.

/proc/filesystems output with the new kernel.
root@hammerhead:/ # cat /proc/filesystem
cat /proc/filesystems
nodev   sysfs
nodev   rootfs
nodev   bdev
nodev   proc
nodev   cgroup
nodev   tmpfs
nodev   debugfs
nodev   sockfs
nodev   pipefs
nodev   anon_inodefs
nodev   devpts
nodev   ramfs
nodev   cifs
nodev   fuse
nodev   fusectl
nodev   selinuxfs
root@hammerhead:/ #
I can mount exfat formated pendrives/flashdrives with read and write support. If SELinux set to enforced then I can't write exfat, therefore set SELinux to permissive by
# setencorfce 0

Here come the problems. If I mount the flashdrive with the Terminal app then the drive is only accessable in the Terminal app and only as su. If I am not su in the Terminal app and type "mount" I can't even see the flashdrive in the mount table, but if I do the same thing as su then the flashdrive is there in the mount table. I checked the folder where I mounted the flasdrive with es file explorer, but I can't see anything.
Then I tried to mount the flashdrive with scriptmanager. I wrote a script which mounts the drive. The drive mounted perfectly and I can acces to the files but only in the scriptmanager app built in filexplorer. The built in terminal in scriptmanager app showes the flashdrive mountpoint in the mount table after issuing "mount" command, but the "mount" command in the Terminal app doesn't show it.

For some reasone the mounting is only lives in that app which mounted the flashdrive. For the other apps the mounting is never happend.

I tried StickMount with mount.exfat-fuse binary, and it worked perfectly the mount were available for all apps, but if I just mount the exfat formated flashdrive using only the mount.exfat-fuse binary the same thing happens just like with "mount -t exfat......" command.

Anyone has any idea why this happening?

Download link for boot.img

Edit: I tested a fat32 formated flashdrive to check is this thing happens only with exfat, but I get the same problem.

I run this command in Terminal app: mount -t vfat path-to-device path-to-mount-pount
but the same thing happens.

Here I run the mount command as su

and here without su
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-03-14-23-17-26.jpg
Views:	33
Size:	203.4 KB
ID:	2631195   Click image for larger version

Name:	Screenshot_2014-03-14-23-17-37.jpg
Views:	31
Size:	204.1 KB
ID:	2631196  
The Following User Says Thank You to bitdomo For This Useful Post: [ View ] Gift bitdomo Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes