FORUMS

[Q]: Hide ongoing notifications lockscreen Android Lollipop

38 posts
Thanks Meter: 7
 
By Nikhoss, Member on 13th November 2014, 10:40 AM
Post Reply Email Thread
Hi,

I flashed yesterday Android Lollipop on my N5 and I found out a "problem" for my use.
I am using some applications like llama, lux and UP which have persistent (or ongoing, I don't know the exact term) notifications (to be not killed I presume). My issue here is that these notifactions are displayed on my lockscreen and it is taking space for nothing.
Before I was using "slidelock", which is a lockscreen app and these persistent notifs were not displayed on the lockscreen but were still on the status bar.

Is there a way to have the same behavior?

I saw this: http://android.stackexchange.com/que...ockscreen?rq=1
but it completely removes the notification on the status bar, so I am not sure the app is still running.
The Following User Says Thank You to Nikhoss For This Useful Post: [ View ] Gift Nikhoss Ad-Free
13th November 2014, 11:15 AM |#2  
Junior Member
Flag Rotterdam
Thanks Meter: 2
 
More
Lightbulb
In the settings under Sound & notification, you can block notifications under App notifications. Just go to the persisting app and turn the slider off.
The Following 2 Users Say Thank You to Rakaus For This Useful Post: [ View ] Gift Rakaus Ad-Free
13th November 2014, 11:40 AM |#3  
OP Member
Thanks Meter: 7
 
More
Thanks but it is quite the same solution given in my link.
I wanted to know if there is a way to keep these persistent notifications in the status bar but not displaying them in the lockscreen.
In your solution, I am not sure that the apps are still running.
13th November 2014, 11:59 AM |#4  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Nikhoss

Thanks but it is quite the same solution given in my link.
I wanted to know if there is a way to keep these persistent notifications in the status bar but not displaying them in the lockscreen.
In your solution, I am not sure that the apps are still running.

One of the options you have for the Lock screen is to hide "Sensitive" notifications. If you turn that on, and then go into the Notification settings and set the apps in question as "Sensitive", they should still come up in the status bar, but not in the lock screen I think
13th November 2014, 12:38 PM |#5  
OP Member
Thanks Meter: 7
 
More
Already done that and it doesn't behave the way I would like..
Thanks anyway for your help.
I think it is just impossible to keep an app in the status bar and not displaying it in the lockscreen.
13th November 2014, 01:25 PM |#6  
Junior Member
Thanks Meter: 1
 
More
Hm I'd like to do the same with Tasker. Shame.
13th November 2014, 03:06 PM |#7  
OP Member
Thanks Meter: 7
 
More
I noticed something: Light Flow (LED notification manager) and google Now have both some kind of persistent notifications but they are not showing up in the lockscreen but they are still there when you are pulling down the notifications tab.
So I searched in app's settings for llama and lux, and both have settings like "persistent notification but no icon". I think this way, the app is not killed.
The Following 2 Users Say Thank You to Nikhoss For This Useful Post: [ View ] Gift Nikhoss Ad-Free
13th November 2014, 03:39 PM |#8  
Raistlin1's Avatar
Senior Member
Thanks Meter: 126
 
More
I was wondering about this also, for me it is the BBM app, it needs to be persistent but I would love for it not to show on the lock screen.

I know there are some apps that let you turn off the persistent notification but the app is still running, BBM doesn't have that though.
13th November 2014, 03:57 PM |#9  
danarama's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 19,167
 
More
Quote:
Originally Posted by Reoryn

One of the options you have for the Lock screen is to hide "Sensitive" notifications. If you turn that on, and then go into the Notification settings and set the apps in question as "Sensitive", they should still come up in the status bar, but not in the lock screen I think

What this does, is still show in lockscreen, but hides the "text"
13th November 2014, 05:33 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Yeah, I got around to trying it - Real shame you can't hide them altogether.
13th November 2014, 07:08 PM |#11  
Poerger's Avatar
Member
Thanks Meter: 8
 
More
I have the same problem. Im using tasker and screeble. Both should be in the notification bar - but not on the lockscreen.

A shame that its not possible (?!), my old rom could do it :/
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes