FORUMS

Nexus 5 32GB shows only 12.55GB. Cannot Use Stock Recovery, gets stuck on formating.

10 posts
Thanks Meter: 1
 
By arandomguy, Junior Member on 14th May 2020, 03:26 AM
Post Reply Email Thread
I'm having the issue of missing storage with a 32GB phone.

Trying the instructions here - https://forum.xda-developers.com/sho...78&postcount=2

The issue is the stock recovery doesn't seem to work for me. When you go to recovery mode with it flashed it gets stuck on the android symbol standing up with the spinning gear. I've left this overnight for over 10 hours.

I can resolve this if I flash TWRP recovery which then enables the phone to boot into android setup properly but it then reverts back to the issue of missing storage.
15th May 2020, 01:49 PM |#2  
Senior Member
Flag Mexico City
Thanks Meter: 9
 
More
32 become 16 GB, the last last last attempt to solve the issue
Quote:
Quote:

Originally Posted by GioVIP
i did just like you said but got again 16 instead of 32

I was in the same situation, metod 1, metod 2 any method to fix it did not work
I've solved it by doing this (make this at your own risk, FIRST be sure that your emmc is not damaged):
root your device, and put parted binary ( find it in the forum) in system/bin with execution permission.
Then reboot in twrp recovery, then in twrp recovery terminal or in adb root shell, type this :
Code:
Code:
mount system
umount /dev/block/mmcblk0p28
parted /dev/block/mmcblk0
check 28
it should say something like
Code:
Code:
Error: The backup GPT table is not at the end of the disk, as it should be.
This might mean that another operating system believes the disk is smaller.
Fix, by moving the backup to the end (and removing the old backup)?
Fix/Ignore/Cancel? Fix

Warning: Not all of the space available to /dev/block/mmcblk0 appears to be
used, you can fix the GPT to use all of the space (an extra xxxxxx blocks) or
continue with the current setting?
Fix/Ignore?Fix
answer Fix and Fix.
now type:
Code:
Code:
print
the last two partitions should be:
Code:
28      2032MB  15.8GB  13.7GB               userdata
29      15.8GB  15.8GB  5632B                grow
if EVERYTHING is like that, let's make a try, type:
Code:
Code:
mkpart primary ext4 15.8GB 25.8GB name 30 trypart
name 30 trypart
print
if you can make trypart without errors and you can see trypart with the print command then
you can proceed to the next step, that will ERASE your data ( worse your userdata partition, before recreating it), type:
Code:
Code:
rm 30
rm 29
rm 28
mkpart primary ext4 2032140288B 31268511743B name 28 userdata
name 28 userdata
mkpart primary 31268511744B 31268517375B name 29 grow
name 29 grow
print
you should see the userdata partition with the new size, and the grow partition after.
Exit from parted by typing
Code:
Code:
quit
Now reboot in fastboot mode and from pc terminal type:
Code:
Code:
fastboot format userdata
ok reboot (wait it take its time) it should be solved.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes