FORUMS

Nexus 5 is dead after screen, battery and the flex cable replacement !!

2 posts
Thanks Meter: 0
 
By Giga_97, Junior Member on 22nd February 2020, 07:22 PM
Post Reply Email Thread
Hello guys,

I had my Nexus 5 six years ago and it worked fine till the past 2 years, I had to change the screen, battery and the flex cable. I changed the battery two times before but I had to change the screen with digitizer because it had some damages.
After replacing all these stuff the phone won't boot and when plugging it into a charger it blinks for ~5 times Red LED then stops and nothing happens.
I think it might be motherboard problem but I want to check, I also tried to reach any repairshop but they keep telling me they no longer supporting the mentainance of this mobile phone and no one in Egypt would fix it.

I am really miserable but this phone means a lot to me, anyone could help me figure what is exaclty the problem??

Thanks
23rd February 2020, 08:12 PM |#2  
CriGiu's Avatar
Senior Member
Thanks Meter: 574
 
More
Quote:
Originally Posted by Giga_97

Hello guys,

I had my Nexus 5 six years ago and it worked fine till the past 2 years, I had to change the screen, battery and the flex cable. I changed the battery two times before but I had to change the screen with digitizer because it had some damages.
After replacing all these stuff the phone won't boot and when plugging it into a charger it blinks for ~5 times Red LED then stops and nothing happens.
I think it might be motherboard problem but I want to check, I also tried to reach any repairshop but they keep telling me they no longer supporting the mentainance of this mobile phone and no one in Egypt would fix it.

I am really miserable but this phone means a lot to me, anyone could help me figure what is exaclty the problem??

Thanks

Are you sure the battery isn't dead? that blinking red led it typical of a dead or empty battery, try leaving it to charge for a while
23rd February 2020, 08:27 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by CriGiu

Are you sure the battery isn't dead? that blinking red led it typical of a dead or empty battery, try leaving it to charge for a while

Thanks @GriGiu for your response.
Yes, I know that the red LED is an indicator for a dead battery, but only if the red blinking keeps going it just keeps blinking 5 or 6 times then silence without any further actions.
I tried also to replace it with 3 other battries and the results are the same, I think maybe if we have a charging circuit on the motherboard it might be damaged but how can I make sure of this???
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes