FORUMS
Remove All Ads from XDA

Nexus 5 pro. Sensor issue/radio files?

2 posts
Thanks Meter: 0
 
By Manishdhariwal27, Junior Member on 12th May 2018, 07:02 AM
Post Reply Email Thread
Well, I'm facing this issue since long time. My proximity sensor stops working after 5 minutes of turning on the phone. That is screen doesn't turns off while calling. I need to press power Button in order to turn off the display.
I tried most of the famous ROMs but all have this issue, but the cataclysm. With this ROM, issue happened but only once in a month or so. I used it since last 12 months or so. It should be noted that I have checked and verified that it's not an hardware's issue. Because it stops working exactly after 5-6 minutes.

After some research, I found that this can be related to radio files. Radio files means kernel? Not sure. I tried to find out but unable to identify which one to install. I'm using lineage is 14.1 for nexus 5. Can somebody please suggest me which version should be installed?
 
 
12th May 2018, 03:35 PM |#2  
audit13's Avatar
Recognized Contributor
Flag Toronto
Thanks Meter: 4,944
 
More
Does this happen on a stock ROM?
14th May 2018, 07:33 PM |#3  
Senior Member
Thanks Meter: 165
 
More
i have the same issue as OP said, and i think it's not hardware related problem. but i haven't tried going back to stock ROM atm
15th May 2018, 02:35 PM |#4  
audit13's Avatar
Recognized Contributor
Flag Toronto
Thanks Meter: 4,944
 
More
I know the proximity sensor has failed on a couple of phones I repaired after they were knocked, dropped, or had a screen replacement.

If it still does it on a completely unrooted stock ROM, I think it would be a hardware issue.
16th May 2018, 08:03 AM |#5  
Senior Member
Thanks Meter: 165
 
More
but the weird thing is the sensor is working fine after reboot and a couple of minutes afterwards. and then i lock the phone and put my phone, then i unlock my phone again it's not working anymore. could that be hardware issue or maybe battery issue? i have old battery and i think it needs a replacement

also i read this https://forum.xda-developers.com/goo...xus-5-t2704915 and try the method and still not working
16th May 2018, 02:18 PM |#6  
audit13's Avatar
Recognized Contributor
Flag Toronto
Thanks Meter: 4,944
 
More
Does this happen on a stock ROM too? If it does, this leads me to conclude it is a hardware issue.

I have run custom ROMs on phones and the ROMs may work fine from a few minutes to a few days. Suddenly, things start to lock up or stop working and a reboot fixes the issues until a short time later.
23rd July 2018, 07:40 PM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by audit13

Does this happen on a stock ROM too? If it does, this leads me to conclude it is a hardware issue.

I have run custom ROMs on phones and the ROMs may work fine from a few minutes to a few days. Suddenly, things start to lock up or stop working and a reboot fixes the issues until a short time later.

Yes. Any ROM including stock ROM. The only ROM with which sensor works as expected is cataclysm. It works totally fine with this which means there’s no hardware issue.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes