FORUMS
Remove All Ads from XDA

Nexus 5 tethering block?

100 posts
Thanks Meter: 18
 
By bobafuzz, Senior Member on 5th November 2013, 04:45 AM
Post Reply Email Thread
7th November 2013, 02:01 AM |#71  
DOHCtor's Avatar
Senior Member
Flag Southern California
Thanks Meter: 120
 
More
Quote:
Originally Posted by yakman66

I have the T-mobile $30 unlimited prepaid plan and I ran into the tethering block after getting my Nexus 5.

I was able to work around the issue by modifying the following sqlite database (you'll need root):
/data/data/com.android.providers.settings/databases/settings.db

You need to add a new entry to the global table called "tether_dun_required" with a value of 0.

It looks like you need to do this because some configuration data was added to Android for T-mobile that forwards tethered data to this APN: pcweb.tmobile.com
T-mobile is probably checking to see if your account has tethering enabled when you go through this APN.

After I made this change I also needed to change my APN settings so that it uses ipv4 instead of ipv6. It seems like tethering with ipv6 does not work 100% yet.

I hope this helps.

What did you use to edit settings.db ?

edit: Never mind, I figured it out. I used SQlite Editor from the Play Store.

It worked! I love you for this! I was so bummed out when I first got my N5 and couldn't tether. Thank you so much!
The Following 2 Users Say Thank You to DOHCtor For This Useful Post: [ View ] Gift DOHCtor Ad-Free
 
 
7th November 2013, 02:17 AM |#72  
Junior Member
Thanks Meter: 171
 
More
Quote:
Originally Posted by DOHCtor

What did you use to edit settings.db ?

I used the SQLite Editor app on my phone. You won't be able to modify the file directly. You need to copy the file somewhere like /sdcard, modify it, and then copy it back. Make sure the permissions and owner are correct when you copy it back.

You can probably also copy the file to your PC and edit it on your PC using any SQLite editor.

Make sure you reboot your phone after making the changes to the database.
The Following 3 Users Say Thank You to yakman66 For This Useful Post: [ View ] Gift yakman66 Ad-Free
7th November 2013, 02:19 AM |#73  
DOHCtor's Avatar
Senior Member
Flag Southern California
Thanks Meter: 120
 
More
Quote:
Originally Posted by yakman66

I used the SQLite Editor app on my phone. You won't be able to modify the file directly. You need to copy the file somewhere like /sdcard, modify it, and then copy it back. Make sure the permissions and owner are correct when you copy it back.

You can probably also copy the file to your PC and edit it on your PC using any SQLite editor.

Make sure you reboot your phone after making the changes to the database.

I figured it out. Thank you very much! You're a lifesaver! I paid $2.99 for the SQlite editor from the Play store. I'll keep it for any future use.

edit: I was able to modify it directly since I was rooted. After adding that line and setting value to 0, I saved it. Change the apn settings from ipv6 to ipv4, then rebooted the phone. Tested it out with my laptop and now all is well again.
The Following User Says Thank You to DOHCtor For This Useful Post: [ View ] Gift DOHCtor Ad-Free
7th November 2013, 02:26 AM |#74  
orthonovum's Avatar
Senior Member
Thanks Meter: 82
 
More
Quote:
Originally Posted by yakman66

I have the T-mobile $30 unlimited prepaid plan and I ran into the tethering block after getting my Nexus 5.

I was able to work around the issue by modifying the following sqlite database (you'll need root):
/data/data/com.android.providers.settings/databases/settings.db

You need to add a new entry to the global table called "tether_dun_required" with a value of 0.

It looks like you need to do this because some configuration data was added to Android for T-mobile that forwards tethered data to this APN: pcweb.tmobile.com
T-mobile is probably checking to see if your account has tethering enabled when you go through this APN.

After I made this change I also needed to change my APN settings so that it uses ipv4 instead of ipv6. It seems like tethering with ipv6 does not work 100% yet.

I hope this helps.

Need someone to see if this works on Sprint too
The Following 3 Users Say Thank You to orthonovum For This Useful Post: [ View ] Gift orthonovum Ad-Free
7th November 2013, 02:27 AM |#75  
bedoig's Avatar
Senior Member
Thanks Meter: 119
 
More
Quote:
Originally Posted by yakman66

I have the T-mobile $30 unlimited prepaid plan and I ran into the tethering block after getting my Nexus 5.

I was able to work around the issue by modifying the following sqlite database (you'll need root):
/data/data/com.android.providers.settings/databases/settings.db

You need to add a new entry to the global table called "tether_dun_required" with a value of 0.

It looks like you need to do this because some configuration data was added to Android for T-mobile that forwards tethered data to this APN: pcweb.tmobile.com
T-mobile is probably checking to see if your account has tethering enabled when you go through this APN.

After I made this change I also needed to change my APN settings so that it uses ipv4 instead of ipv6. It seems like tethering with ipv6 does not work 100% yet.

I hope this helps.

Thank you Sir!!

Sent from my Nexus 7 using XDA Premium 4 mobile app
7th November 2013, 02:28 AM |#76  
DOHCtor's Avatar
Senior Member
Flag Southern California
Thanks Meter: 120
 
More
The Following 8 Users Say Thank You to DOHCtor For This Useful Post: [ View ] Gift DOHCtor Ad-Free
7th November 2013, 02:32 AM |#77  
Member
Thanks Meter: 18
 
More
Quote:
Originally Posted by yakman66

I have the T-mobile $30 unlimited prepaid plan and I ran into the tethering block after getting my Nexus 5.

I was able to work around the issue by modifying the following sqlite database (you'll need root):
/data/data/com.android.providers.settings/databases/settings.db

You need to add a new entry to the global table called "tether_dun_required" with a value of 0.

It looks like you need to do this because some configuration data was added to Android for T-mobile that forwards tethered data to this APN: pcweb.tmobile.com
T-mobile is probably checking to see if your account has tethering enabled when you go through this APN.

After I made this change I also needed to change my APN settings so that it uses ipv4 instead of ipv6. It seems like tethering with ipv6 does not work 100% yet.

I hope this helps.

This worked flawlessly, thanks!

I used https://play.google.com/store/apps/d...qleditor&hl=en to edit the settings.db

EDIT: Also, I played around with the APN set to IPv6. It DOES work with IPv6, but it is excruciatingly slow for most hosts. Anything on Google's servers is just as fast over IPv6 as via IPv4, however.
7th November 2013, 02:43 AM |#78  
n1gh7m4r3's Avatar
Senior Member
Flag Conroe
Thanks Meter: 35
 
More
Quote:
Originally Posted by yakman66

I have the T-mobile $30 unlimited prepaid plan and I ran into the tethering block after getting my Nexus 5.

I was able to work around the issue by modifying the following sqlite database (you'll need root):
/data/data/com.android.providers.settings/databases/settings.db

You need to add a new entry to the global table called "tether_dun_required" with a value of 0.

It looks like you need to do this because some configuration data was added to Android for T-mobile that forwards tethered data to this APN: pcweb.tmobile.com
T-mobile is probably checking to see if your account has tethering enabled when you go through this APN.

After I made this change I also needed to change my APN settings so that it uses ipv4 instead of ipv6. It seems like tethering with ipv6 does not work 100% yet.

I hope this helps.

Worked like a champ, going to see if that little ditty works on the htc one gpe. Thanks.

EDIT: works on htc one gpe on tmo as well.

Sent from my Nexus 5 using Tapatalk
7th November 2013, 02:45 AM |#79  
Junior Member
Thanks Meter: 171
 
More
Quote:
Originally Posted by DOHCtor

I figured it out. Thank you very much! You're a lifesaver! I paid $2.99 for the SQlite editor from the Play store. I'll keep it for any future use.

edit: I was able to modify it directly since I was rooted. After adding that line and setting value to 0, I saved it. Change the apn settings from ipv6 to ipv4, then rebooted the phone. Tested it out with my laptop and now all is well again.

I'm glad it worked for you.

Thanks for the tip on the app. The really old version that I was using probably doesn't support root.
7th November 2013, 03:09 AM |#80  
OP Senior Member
Thanks Meter: 18
 
More
Quote:
Originally Posted by yakman66

I'm glad it worked for you.

Thanks for the tip on the app. The really old version that I was using probably doesn't support root.

Working for me to .
7th November 2013, 03:12 AM |#81  
Junior Member
Thanks Meter: 171
 
More
Quote:
Originally Posted by MattG987

EDIT: Also, I played around with the APN set to IPv6. It DOES work with IPv6, but it is excruciatingly slow for most hosts. Anything on Google's servers is just as fast over IPv6 as via IPv4, however.

IPv6 worked on my macbook, but it did not seem to work on my Nexus 7. I'll have to give it another try when I have time.

In theory we should be able to get IPv6 to work because they added 464xlat support into Android 4.3
Maybe it's a configuration issue? I guess we'll need a fix before they run out of ipv4 addresses.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes