Remove All Ads from XDA

suddenly data service not working in Nexus 5

120 posts
Thanks Meter: 2
By madroamer, Senior Member on 4th May 2014, 03:04 PM
Post Reply Email Thread

suddenly data service is not working in nexus 5. i tried all option...even tried with customer care...

i dont get edge/3g/2g signal...

9 can get calls & make calls incl sms...only data service not woking..

Even flash stock img...flashed radio downloading from progress...

i am rooted & unlocked
4th May 2014, 03:46 PM |#2  
RoyJ's Avatar
Senior Member
Thanks Meter: 2,589
Call the technical support line (not customer care) for your carrier and inquire whether or not they are working on the towers in your area. They can also "reboot" your SIM. Unlinks it and the phone reboots on the tower fresh. If they aren't doing work on towers and you flashed the factory images already, unroot (if you want) and relock and then begin the RMA process.
5th May 2014, 04:26 AM |#3  
OP Senior Member
Thanks Meter: 2
I already flashed radios and did change to stock download from Google . I m rooted now. Did with Cf root,. Wat u mean as RMA process ? Plz elaborate

Sent from my Nexus 5 using Tapatalk
5th May 2014, 03:34 PM |#4  
RoyJ's Avatar
Senior Member
Thanks Meter: 2,589
Return process with either Google or LG.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes