Remove All Ads from XDA

Wireless charging stopped working

807 posts
Thanks Meter: 143
By blinde, Senior Member on 29th April 2014, 12:59 PM
Post Reply Email Thread
Does anyone else have this kind of trouble? Wireless charging just stopped working. I've tried with two chargers and no effect. Chargers can't be broken because they both charge my older Nexus 4 just fine. USB charging works just fine but I've kind of used to wireless and it drives me crazy since it doesn't work. I haven't dropped the phone or anything, I even replaced the back cover with new genuine OEM back cover since I thought that maybe the coils in back have been damaged or something.

Could it be software issue or what?
29th April 2014, 03:56 PM |#2  
jt3's Avatar
Senior Member
Thanks Meter: 223
I had this same thing happen, although with mine, it was after a (about 2 foot) fall. It could be software, but doubtful, since you can verify that by simply turning your phone off (not in standby, but completely off), and seeing if the battery indicator comes up when you start charging. Regardless, Google will ask you to do a hard reset before they'll replace it to ensure that it's not software-related.

As I said, mine was replaced under warranty for this very issue, so Google does count this as a replaceable issue (provided you bought it from the Play Store). However, there is one thing to try first:

Draw an imaginary line across the bottom of the letters in "nexus" printed on the back cover, and follow that line until you're even with the flash. Right there, there's a clip that most people miss when replacing the cover. That clip MUST be securely fastened, or wireless charging won't work (the purpose of the clip is to keep the wireless charging pins engaged). Press down at that spot to make sure that the clip is engaged.

Barring that, I'd contact Google for replacement (or your carrier, if you bought it from there).
The Following User Says Thank You to jt3 For This Useful Post: [ View ] Gift jt3 Ad-Free
2nd May 2014, 10:24 PM |#3  
blinde's Avatar
OP Senior Member
Thanks Meter: 143
After several re-openings, it apparently finally worked. Those four little pins were somehow bit too low so that connection did last only few seconds. I pulled them up little bit with tweezers, push that copper thing on top of the battery all the way to bottom and firmly put the back cover on its place and now it's working again. I was so close sending this thing back to Google...

Somehow it still feels that it doesn't quite charge it with full power. It apparenly takes much more time than using AC charger. This wasn't the case when this problem didn't occure because it charged wirelessly very quickly.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes