FORUMS

Kindle Fire HD 10 9th gen is adding a dns server on its own.

2,188 posts
Thanks Meter: 15
 
By ChumleyEX, Senior Member on 24th November 2019, 04:28 PM
Post Reply Email Thread
Hello there, I run several services locally on my network and need a DNS server local to my network to access them. I have a DHCP and DNS server setup to handle everything I need and this works for everything on my network except my new HD 10. The tablet will get the IP/Subnet Mask/Gateway and DNS server, but then it will add googles 8.8.8.8 as well. That'd fine and all, except that the tablet/Silk will never use my 192.168.1.1 DNS to resolve my internal servers, it just uses the google DNS. I have installed a nslookup tool and it resolves everything just fine. Next, I went in and statically set the DNS server and even added a second, which works for a few minutes, but then the tablet adds 8.8.8.8 again. The hosts it's resolving are there, every computer/tablet/phone on my network can resolve it and so can nslookup. My home DNS server can resolve whatever is needed, but this tablet is forcing stuff I don't need.



What can I do, I bought this tablet to use with things on my network (specifically) and it seems to have a mind of its own.
24th November 2019, 09:10 PM |#2  
Junior Member
Thanks Meter: 0
 
More
you might try editing the hosts file on our tablets I dunno if this will apply to us but here's a site that claims to show how to edit the hosts file on non rooted devices... This may also work in your reverse lookup zone with a manual entry for 8.8.8.8 sent to your dns server as well

https://www.techrepublic.com/article...ck-ad-servers/

Dunno why you're having this issue though as you mentioned DHCP is adding both yours and Google's NS and the 192 range is non routable and Google is not authoritative for that range anyways

What's your DNS/DHCP setup like? Window or Linux?

Lastly, you may also try using NAT to redirect all traffic bound for 8.8.8.8 to your DNS servers ip but this may have the added effect of any other devices on the network headed to 8.8.8.8 to return to your DNS and be unable to resolve internet addresses

You may want to do a bit of research in that regard
24th November 2019, 09:48 PM |#3  
ChumleyEX's Avatar
OP Senior Member
Flag Temple
Thanks Meter: 15
 
More
Quote:
Originally Posted by bladerunnernexus

you might try editing the hosts file on our tablets I dunno if this will apply to us but here's a site that claims to show how to edit the hosts file on non rooted devices... This may also work in your reverse lookup zone with a manual entry for 8.8.8.8 sent to your dns server as well

https://www.techrepublic.com/article...ck-ad-servers/

Dunno why you're having this issue though as you mentioned DHCP is adding both yours and Google's NS and the 192 range is non routable and Google is not authoritative for that range anyways

What's your DNS/DHCP setup like? Window or Linux?

Lastly, you may also try using NAT to redirect all traffic bound for 8.8.8.8 to your DNS servers ip but this may have the added effect of any other devices on the network headed to 8.8.8.8 to return to your DNS and be unable to resolve internet addresses

You may want to do a bit of research in that regard

Thanks, I'll try some of what you suggested. I run pfsense for my router and it has a dns resolver I use. I run some docker stuff with traefik as the reverse proxy so I need the DNS to route to stuff internally.
25th November 2019, 04:08 AM |#4  
ChumleyEX's Avatar
OP Senior Member
Flag Temple
Thanks Meter: 15
 
More
Dns with tls is what it wanted. I got that configured and now it works. Thanks
25th November 2019, 07:38 PM |#5  
Senior Member
Thanks Meter: 106
 
More
Noticed this as well when I added my own DNS servers for accessing work. Is there anyway to remove the 3rd DNS server entry of 8.8.8.8?
1st December 2019, 06:22 AM |#6  
Junior Member
Thanks Meter: 1
 
More
I posted this on another forum as well but I wanted to post it here for anyone who might find this. This is a hidden option in the Fire OS so I had to use ADB to turn it off. So far it appears to persist across reboots.

adb shell settings put global private_dns_mode OPTION (off was what I used) FYI no quotes just private_dns_mode off

Options are
* - opportunistic (Auto)
* - off (disabled)

There is also a "private_dns_default_mode" as well that I set to off but i'm not sure if that did anything.
The Following User Says Thank You to jwoodard80 For This Useful Post: [ View ] Gift jwoodard80 Ad-Free
1st December 2019, 01:21 PM |#7  
Senior Member
Thanks Meter: 106
 
More
Quote:
Originally Posted by jwoodard80

I posted this on another forum as well but I wanted to post it here for anyone who might find this. This is a hidden option in the Fire OS so I had to use ADB to turn it off. So far it appears to persist across reboots.

adb shell settings put global private_dns_mode OPTION (off was what I used) FYI no quotes just private_dns_mode off

Options are
* - opportunistic (Auto)
* - off (disabled)

There is also a "private_dns_default_mode" as well that I set to off but i'm not sure if that did anything.

Oh you wonderful, wonderful person, you. This did the trick, although, it took a bit of time to make out what the exact command you were referring to was. So, to make it clearer to anybody else want to try this, it's
Code:
adb shell settings put global private_dns_mode off
Of course, the prerequisites of enabling developer options and enabling debugging as well as having a pc with adb installed and set up are assumed to be already fulfilled.
The Following 2 Users Say Thank You to lusephur For This Useful Post: [ View ] Gift lusephur Ad-Free
15th December 2019, 06:32 PM |#8  
Member
Flag Munich
Thanks Meter: 9
 
More
Hey guys,

I just read your posts here and treid to deactivate this pretty strange behaviour. Unfortunately, it didn't work as expected. I ran the command after enabling developer options and confirming the new connection. ADB worked without any error but still, the Fire HD10 added the 8.8.8.8 DNS server on my WiFi connection. I deactivated the connection and even deleted it to set it up again, nothing worked..
Is there anything I missed?

Thanks,
Matthias
27th December 2019, 04:11 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Persistent 8.8.8.8
I also changed both parameters to OFF using adb but without any results on the FIRE 7. My guess is that they used the 8.8.8.8 DNS for their ad-based servers and as this tablet is ad-enabled (which actually makes them less expensive to buy) they wont allow changing this without rooting the device. Any suggestions ???
27th December 2019, 11:16 PM |#10  
Member
Flag Munich
Thanks Meter: 9
 
More
Well, I finally solved it on network side: I used a NAT firewall rule to ensure all traffic via port 53 (=DNS queries without encryption) goes to my internal DNS server. Of course, if the server is within your network, you'll have to add an exception for traffic to port 53 for the server.
The main qustion is if your router will support custom NAT rules.

BR,
Matthias
4th January 2020, 10:16 PM |#11  
Senior Member
Thanks Meter: 11
 
More
The adb shell settings stuff did not work for me either.
Instead of adding a nat rule I simply deny all traffic to 8.8.8.8 and 8.8.4.4. As the fires use my local dns servers as fallback everythimg now works as expected - including blocked adds in browsers.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes