FORUMS
Remove All Ads from XDA

I can not decompile

215 posts
Thanks Meter: 74
 
By BoRoU, Senior Member on 22nd January 2015, 09:23 AM
Post Reply Email Thread
Hi guys. I'm trying to decompile the framework-res.apk and always gives me error. Well the truth is that the first error gives me trying to assign the framework with:
Code:
 java -jar apktool.jar if framework-res.apk
I get this error:

Code:
Exception in thread "main" brut.androlib.AndrolibException: Multiple resources: spec=0x01040308 string/lockscreen_carrier_default, config=[DEFAULT]
    at brut.androlib.res.data.ResConfig.addResource(ResConfig.java:63)
    at brut.androlib.res.data.ResConfig.addResource(ResConfig.java:56)
    at brut.androlib.res.decoder.ARSCDecoder.readEntry(ARSCDecoder.java:193)
    at brut.androlib.res.decoder.ARSCDecoder.readConfig(ARSCDecoder.java:162)
    at brut.androlib.res.decoder.ARSCDecoder.readType(ARSCDecoder.java:128)
    at brut.androlib.res.decoder.ARSCDecoder.readPackage(ARSCDecoder.java:103)
    at brut.androlib.res.decoder.ARSCDecoder.readTable(ARSCDecoder.java:81)
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:49)
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:40)
    at brut.androlib.res.AndrolibResources.installFramework(AndrolibResources.java:678)
    at brut.androlib.Androlib.installFramework(Androlib.java:645)
    at brut.apktool.Main.cmdInstallFramework(Main.java:252)
    at brut.apktool.Main.main(Main.java:91)
I tried with all apktool I've seen and always the same error.
Any idea how to fix it?

Thanks.
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes