FORUMS
Remove All Ads from XDA

only 4G/LTE only

13 posts
Thanks Meter: 0
 
By sumonhowlader, Junior Member on 15th November 2018, 12:40 PM
Post Reply Email Thread
How to active only 4G/LTE only on honor 8x? I used database editor but not found that option for 4g
 
 
20th November 2018, 11:17 AM |#2  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
Try code *#*#6130#*#* in Call. For me it not work, but I have Honor 8X Max, not Honor 8X.
20th November 2018, 12:00 PM |#3  
Junior Member
Thanks Meter: 1
 
More
Honor 8X 4G only network
Download "setting database editor" from playstore.open app search down file "hw_networkmode _preference" "9,3,2,1".tap edit to "9,3,2,1,11".
Note:just add ( ,11 ) only.
Close apps and restart phone.open setting~wireless&network ~mobile network~preferred network mode you can see Only 4G/only LTE. available on sim 1 and sim 2.
The Following User Says Thank You to greenada For This Useful Post: [ View ] Gift greenada Ad-Free
21st November 2018, 06:41 AM |#4  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
I opened app Setting Database Editor and there no item 'hw_networkmode _preference'.
21st November 2018, 11:50 AM |#5  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by jamesbond22

I opened app Setting Database Editor and there no item 'hw_networkmode _preference'.

try scroll down slowly to search in app you can see that.my device is Honor 8X.
25th November 2018, 01:40 PM |#6  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
Certainly there is no element 'hw_networkmode_preference' in app. But exist element 'network_mode_4G_pre=-1'. Maybe I need to edit it...?
10th December 2018, 03:16 AM |#7  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
I added line:
Code:
"hw_networkmode_preference" "9,3,2,1,11"
Then I restarted phone and still no added option 'Only 4G'.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20181210-040609.jpg
Views:	872
Size:	190.9 KB
ID:	4662073   Click image for larger version

Name:	Screenshot_20181210-040629.jpg
Views:	846
Size:	132.2 KB
ID:	4662074  
10th December 2018, 10:34 AM |#8  
Honor Supporter
Recognized Contributor
Thanks Meter: 807
 
More
Quote:
Originally Posted by jamesbond22

I added line:

Code:
"hw_networkmode_preference" "9,3,2,1,11"
Then I restarted phone and still no added option 'Only 4G'.

try this solution

https://forum.xda-developers.com/sho...7&postcount=11
10th December 2018, 01:29 PM |#9  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
Quote:
Originally Posted by miststudent2011

try this solution

https://forum.xda-developers.com/sho...7&postcount=11

Still nothing happens. My phone is not rooted and there is problem...?
10th December 2018, 01:45 PM |#10  
Honor Supporter
Recognized Contributor
Thanks Meter: 807
 
More
Quote:
Originally Posted by jamesbond22

Still nothing happens. My phone is not rooted and there is problem...?

You dont need root for that.
13th December 2018, 06:17 AM |#11  
Senior Member
Flag Kartuzy
Thanks Meter: 27
 
More
For now I see this lines:
Code:
"hw_networkmode_preference" "9,3,2,1,11"
"hw_add_4g_only" "260"
"network_mode_4G_pre" "-1"
"hw_global_networkmode_settings_enable" "1"
I don't know why, but I can't get option 'Only LTE'.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes