FORUMS
Remove All Ads from XDA

[unofficial][linux3.4][native][tarchive][revised]ArchLinuxARM release for HP TouchPad

211 posts
Thanks Meter: 340
 
Post Reply Email Thread
19th February 2015, 06:03 AM |#11  
metal1f3's Avatar
Senior Member
Arkansas
Thanks Meter: 69
 
More
Quote:
Originally Posted by castrwilliam

Unfortunately, even though web OS isn't required for any functionality (back in the TP ubuntu days it was needed for audio), I stupidly left /dev/store/root (web OS root) in the /etc/fstab file for this build.

Next build will include optional portable VSXu player, several emulators, newer Mesa GL, and an audio patch. I'll archive it as soon as I can slim it down.

GNOME 3 even sorta works, but don't actually use it because there are unrendered black squares and it's quite slow on this device.

Cant wait! My touchpad is awesome now. Arch ftw.
 
 
5th March 2015, 09:33 PM |#12  
Member
Thanks Meter: 14
 
More
This is awesome! Thanks a lot, castrwilliam! Nearly everything is working well for me, even KDE!
Chromium has very good touch support. You can enable pinch-to-zoom in chrome://flags . Extemsions, such as uMatrix, work fine. Finally, a good web browser on HP touchpad!

However, I do have a couple small questions.

In KDE, when I enable compositing in kwin_gles using opengl, the colors are reversed (blue is displayed as orange). Is there any way to fix this? When using xrender, it's ok, but I have to disable lots of effects to get decent performance. HW acceleration would be nice.

In future images, could you please include touchegg-gce from AUR? It's really helpful, and I'd imagine that pretty much anyone using this without hw keyboard and mouse would find it useful.

Stupid newbie question (Sorry, I'm new to Arch Linux): Speaking of AUR, is there an easy way to automatically set arch to 'armv7l' in PKGBUILDs in yaourt? It's kind of a pain to edit them every time.
6th April 2015, 02:47 PM |#13  
blmvxer's Avatar
Senior Member
Thanks Meter: 618
 
Donate to Me
More
Quote:
Originally Posted by castrwilliam

Unfortunately, even though web OS isn't required for any functionality (back in the TP ubuntu days it was needed for audio), I stupidly left /dev/store/root (web OS root) in the /etc/fstab file for this build.

Next build will include optional portable VSXu player, several emulators, newer Mesa GL, and an audio patch. I'll archive it as soon as I can slim it down.

GNOME 3 even sorta works, but don't actually use it because there are unrendered black squares and it's quite slow on this device.

Are you planning on reviving Ubuntu for the Touchpad?

Sent from my LG-ls990 using XDA Free mobile app
9th April 2015, 09:31 PM |#14  
rebel1699's Avatar
Senior Member
Flag Oklahoma
Thanks Meter: 1,473
 
More
Started running this last night. But, it takes a little extra work. I run evervolv 5.0.2 dulaboot with webos. I also use twrp. With all those, /boot is too small to add. About .5Mb too small. My solution was to cut uImage.TWRP from boot and store a copy elsewhere until needed. That gave me the nesecarry room I needed. When I need TWRP again, I will temp move uImage.Arch and put twrp back in.
11th December 2015, 07:19 PM |#15  
Shiggity's Avatar
Senior Member
Thanks Meter: 28
 
More
Is anyone still working on this? I'm what I hope is charging my TouchPad and I want to try this again.
12th December 2015, 11:35 PM |#16  
blmvxer's Avatar
Senior Member
Thanks Meter: 618
 
Donate to Me
More
Quote:
Originally Posted by Shiggity

Is anyone still working on this? I'm what I hope is charging my TouchPad and I want to try this again.

I started working on some stuff with it the other day.
The Following User Says Thank You to blmvxer For This Useful Post: [ View ] Gift blmvxer Ad-Free
13th December 2015, 03:39 PM |#17  
Shiggity's Avatar
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by blmvxer

I started working on some stuff with it the other day.

Cool. Are you around right now to help me get it installed? How would we talk about it? iRC via PMs?

---------- Post added at 02:59 PM ---------- Previous post was at 02:15 PM ----------

BTW, for my current attempt I'm basically using this https://github.com/crimsonredmk/Arch...nstallation.md but when it talks about the uImage and rootfs I'm using castrwilliam's. I'd ultimately like to use the latest rolling release available for ALARM, but I want to see what happens with that's currently available.

---------- Post added at 03:39 PM ---------- Previous post was at 02:59 PM ----------

Aaaannnnd I can't seem to get my root partition on /dev/store/arch-root to mount under the requested by kernel /local/arch without it kernel panicking first... >_>
13th December 2015, 06:08 PM |#18  
blmvxer's Avatar
Senior Member
Thanks Meter: 618
 
Donate to Me
More
Quote:
Originally Posted by Shiggity

Cool. Are you around right now to help me get it installed? How would we talk about it? iRC via PMs?

---------- Post added at 02:59 PM ---------- Previous post was at 02:15 PM ----------

BTW, for my current attempt I'm basically using this https://github.com/crimsonredmk/Arch...nstallation.md but when it talks about the uImage and rootfs I'm using castrwilliam's. I'd ultimately like to use the latest rolling release available for ALARM, but I want to see what happens with that's currently available.

---------- Post added at 03:39 PM ---------- Previous post was at 02:59 PM ----------

Aaaannnnd I can't seem to get my root partition on /dev/store/arch-root to mount under the requested by kernel /local/arch without it kernel panicking first... >_>

I'm working on making it work currently.
13th December 2015, 06:21 PM |#19  
Shiggity's Avatar
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by blmvxer

I'm working on making it work currently.

Sweet. Let me know when you have it working and I'll try it on my 32 GB TP.

---------- Post added at 06:21 PM ---------- Previous post was at 06:21 PM ----------

I also messaged you on your FB a few hours ago. @blmvxer
13th December 2015, 06:22 PM |#20  
blmvxer's Avatar
Senior Member
Thanks Meter: 618
 
Donate to Me
More
Quote:
Originally Posted by Shiggity

Sweet. Let me know when you have it working and I'll try it on my 32 GB TP.

---------- Post added at 06:21 PM ---------- Previous post was at 06:21 PM ----------

I also messaged you on your FB a few hours ago. @blmvxer

I have to charge my tablet up so I can reinstall webos, but from what I can see it should work with the link you have me.
13th December 2015, 06:25 PM |#21  
Shiggity's Avatar
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by blmvxer

I have to charge my tablet up so I can reinstall webos, but from what I can see it should work with the link you have me.

Yeah.. from dead this tablet takes ages to properly charge... maybe at least mine did since I couldn't find a proper AC adapter... lol

Let me know when you've got something. My issue was getting the root partition mounting properly... >_> Are you going to try what I did? Using crimsonred's github installation.md but substituting the uImage and rootfs with @castrwilliam's?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes