FORUMS
Remove All Ads from XDA

Remove NFC and Other Status Bar Icons Without Root [needs ADB][Marshmallow only]

180 posts
Thanks Meter: 43
 
By D_JWhite, Senior Member on 26th November 2016, 08:12 PM
Post Reply Email Thread
I got my 10 today after waiting since it was released. On thing that got me was the ugly NFC icon, it is horrible!

Right bare with me...

You need a working ADB setup

Code:
Tap Settings > About > Software Information > More
Keep tapping build number until you're told you're a developer.

Plug your phone into your computer and open command prompt in your ADB folder. Type:

Code:
adb devices
You should see your device show up. Following this type

Code:
adb shell settings put secure icon_blacklist [comma separated codes here] && adb reboot
For example, if you want to get rid of the NFC icon and the Bluetooth icon your command would look like this:

Code:
adb shell settings put secure icon_blacklist nfc,bluetooth && adb reboot
Note the lack of space between the NFC and Bluetooth commands.

That's it; Done!

Enjoy a less cluttered status bar!

Edit:
Omar302 reminded me that you can hide other status bar icons using this method. This is a (likely incomplete) list of icons

Code:
Name		Settings Description
cast		Cast
hotspot		Hotspot
bluetooth	Bluetooth
zen		Do not disturb
alarm_clock	Alarm 
managed_profile	Work profile
wifi		Wi-Fi
ethernet	Ethernet
mobile		Cellular Data
airplane	Airplane Mode
One more thing worth noting:
Quote:
Originally Posted by omar302

Note: Hiding an icon will cause the other icons to re-appear, so you will need to make the command to hide all your iccons with one command. Separate names of the icons with a comma ",".

So if you are tweaking the status bar one by one, keep a copy of your command in notepad
The Following 12 Users Say Thank You to D_JWhite For This Useful Post: [ View ] Gift D_JWhite Ad-Free
 
 
27th November 2016, 10:02 AM |#2  
omar302's Avatar
Senior Member
Flag Doha
Thanks Meter: 541
 
More
Thanks a lot. from your post I was able to search & find this post & this page. I was able to hide the Bluetooth & alarm clock icons using this command:


Code:
adb shell settings put secure icon_blacklist bluetooth,alarm_clock

Note: Hiding an icon will cause the other icons to re-appear, so you will need to make the command to hide all your icons with one command. Separate names of the icons with a comma ",".
27th November 2016, 10:21 AM |#3  
D_JWhite's Avatar
OP Senior Member
Flag Birkenhead, Wirral
Thanks Meter: 43
 
More
Quote:
Originally Posted by omar302

Thanks a lot. from your post I was able to search & find this post & this page. I was able to hide the Bluetooth & alarm clock icons using this command:


Code:
adb shell settings put secure icon_blacklist bluetooth,alarm_clock

Note: Hiding an icon will cause the other icons to re-appear, so you will need to make the command to hide all your iccons with one command. Separate names of the icons with a comma ",".

Cheers!

I've updated the OP 👍
27th November 2016, 10:36 AM |#4  
Junior Member
Thanks Meter: 1
 
More
This doesn't appear to work in Nougat
27th November 2016, 10:38 AM |#5  
D_JWhite's Avatar
OP Senior Member
Flag Birkenhead, Wirral
Thanks Meter: 43
 
More
Quote:
Originally Posted by winkins01

This doesn't appear to work in Nougat

I'm a peasant who's still on Marshmallow (has xposed sdk 24 been released?), I don't have Nougat to mess around with. I'll update the title accordingly.
25th January 2017, 06:50 AM |#6  
Junior Member
Flag Cebu City
Thanks Meter: 3
 
More
I just tried this on latest WWE Nougat (2.41.401.3) and it works.

Just a heads up, setting this to only `nfc,bluetooth` will enable the "rotate" icon (which shows if auto rotate is enabled). I had to also include the `rotate` setting to blacklist it. I think a complete list of available icons is listed here: https://android.googlesource.com/pla...ues/config.xml
The Following User Says Thank You to ramonmaruko For This Useful Post: [ View ] Gift ramonmaruko Ad-Free
12th February 2017, 06:51 AM |#7  
omar302's Avatar
Senior Member
Flag Doha
Thanks Meter: 541
 
More
Quote:
Originally Posted by ramonmaruko

I just tried this on latest WWE Nougat (2.41.401.3) and it works.

Just a heads up, setting this to only `nfc,bluetooth` will enable the "rotate" icon (which shows if auto rotate is enabled). I had to also include the `rotate` setting to blacklist it. I think a complete list of available icons is listed here: https://android.googlesource.com/pla...ues/config.xml

Thanks. I did not notice this as I usually leave auto rotate on. Turned it off (portrait mode) and the icon appeared. Adding "rotate" to my list removes it along with bluetooth & alarm:

Code:
adb shell settings put secure icon_blacklist bluetooth,alarm_clock,rotate
Would be nice if someone would check what is the defaul black list before making anychanges by running this command:

Code:
adb shell settings get secure icon_blacklist
Also, maybe OP could modify the title to show this also works in Nougat.
The Following User Says Thank You to omar302 For This Useful Post: [ View ] Gift omar302 Ad-Free
12th February 2017, 08:37 AM |#8  
Member
Lifos
Thanks Meter: 23
 
More
Thumbs up
Quote:
Originally Posted by omar302

Thanks. I did not notice this as I usually leave auto rotate on. Turned it off (portrait mode) and the icon appeared. Adding "rotate" to my list removes it along with bluetooth & alarm:

Code:
adb shell settings put secure icon_blacklist bluetooth,alarm_clock,rotate
Would be nice if someone would check what is the defaul black list before making anychanges by running this command:

Code:
adb shell settings get secure icon_blacklist
Also, maybe OP could modify the title to show this also works in Nougat.

Thanks, it works with latest EU Nougat.

Result of command before making any changes is:
Code:
adb shell settings get secure icon_blacklist
null
And is there any way to hide boomsound and night mode icons?
The Following 2 Users Say Thank You to chinke For This Useful Post: [ View ] Gift chinke Ad-Free
20th March 2017, 03:47 PM |#9  
Senior Member
Thanks Meter: 55
 
More
I'm on N and the alarm icon is finally gone (YAY!), but it didn't work for the NFC icon. Maybe on N it's not just nfc for the command?
18th April 2017, 09:02 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by dragunbayne

I'm on N and the alarm icon is finally gone (YAY!), but it didn't work for the NFC icon. Maybe on N it's not just nfc for the command?

On Samsung use command nfc_on instead of nfc
24th April 2017, 01:56 PM |#11  
Senior Member
Thanks Meter: 55
 
More
Quote:
Originally Posted by fritshobbe

On Samsung use command nfc_on instead of nfc

Thanks for the tip, but it did not work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes