FORUMS
Remove All Ads from XDA

[Q] How to solve "Error executing updater binary zip"?

16 posts
Thanks Meter: 1
 
By DaveMcKirk, Junior Member on 30th June 2017, 10:27 AM
Post Reply Email Thread
Hi
I am not sure if anyone is still reading this forum, but I recently found my old Desire S and wanted to flash a ROM to it to revive it.
But I stumbled upon several problems.

The phone has currently twrp v2.8.7.1 installed, but simply installing a rom zip file with it always delivers the same error:
E:Error exectuting updater binary in zip '/sdcard/CM-11S-UNOFFICIAL-BR1-saga.zip
Error flashing zip 'sdcard/...'
I tried several roms I found in this forum, but most of the download links seem to be offline by now. I do not really care which rom is installed. The only goal was to find one which is working and the phone can be used with it.

It is not possible to mount->sd-ext in twrp even though an sd card is installed.
Mount->data is only possible when the sd-card is inserted. If it is removed mounting data is not possible.
Yesterday I had some trouble with wiping most of the available partitions in twrp, but today it seems to work properly, except wipe->advanced->internal storage which results in the error: "Invalid partition selection"
It is probably also worth mentioning that wipe->Format Data->yes was performed, and therefore barely any data is currently on the phone.
ADB and Fastboot commands can be executed from the pc and are being processed.


That's pretty much every information I think would be beneficial to find a solution to the flashing problem.
I also found the thread "[Q] How can I install Mokee rom?" in this forum, where the same problem ("exectuting updater binary in zip ...") seems to be solved by installing a newer version of twrp. But since I think, that the installed one on my phone is the newest, I only think that I could try downgrading the recovery. Not sure if this would help, and where to find an older recovery.

Thanks in advance for any possible solutions to approach the given problem.

Edit:
I installed recovery-clockwork-touch-5.8.1.5-saga to try a different recovery. Then I pushed the rom via adb. The installation failed with:
"set_metadata_recursive: some changes failed
E: Error in /sdcard/rom.zip
(Status 7)
Installation aborted."

Edit2: SOLVED
If someone else should have similar problems:
The error message from cwm seems to indicate that the used rom is not flashable with this version of cwm.
I was able to install the ics rom aokp_saga_milestone-6-120708-2354 with cwm version recovery-clockwork-touch-5.8.1.5-saga (both can be found in the download section https://forum.xda-developers.com/sho....php?t=1146601
 
 
30th June 2017, 07:45 PM |#2  
Senior Member
Flag Kraków
Thanks Meter: 719
 
More
Try 4ext recovery v1.0.0.6 RC3 build8.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes