FORUMS
Remove All Ads from XDA

HTC One M8 - Water damage, repair and battery problem

75 posts
Thanks Meter: 6
 
By andyb2000, Member on 9th June 2018, 08:50 AM
Post Reply Email Thread
Hi all,
My dear HTC One M8 took an unfortunate dive into water recently, I got it out pretty quickly (it was submerged) and shook it dry as fast as I could, then tore the unit down to get the battery disconnected as fast as I could (Screen jumped on, and vibrate motor was on constantly).
After getting the battery disconnected, stripping it down and drying it out, cleaning, etc.
I ordered a new battery and USB charge board as knew those would be most likely culprits.

Anyway, left existing USB and battery in, and after a few days of ensuring dry, etc, connected battery up and usb to charge, phone screen lit up and showed battery with electrical lightning symbol, a few seconds later then the battery with red exclamation mark (point) on screen.
Using my USB voltage/current meter I saw that battery charge current went to around 0.2amps but stayed constant, so I left it to do it's thing.
Powered it on and it's working! All good, touch working, all functions. However battery has an exclamation mark inside it when booted, and if connected to charger whilst phone is on charge current goes up when screen is on, etc (As though the phone is pulling current from the charger) but when idle the charge current drops to 0.
So it won't charge whilst turned on.
I then changed the battery and usb charge port. SAME, no difference. I've even tried a 3rd battery to be sure and it's the same, so I don't think it's the battery or the
usb charge port itself.

So debugging it, using "Ampere" app to see battery state. It says Unknown and often has unusual temperature values (- values or very low). Battery status is UNKNOWN.

I've connected up on adb to take a look and several things are odd, if I pull the battery stats:
Code:
130|shell@htc_m8:/ $ dumpsys battery 

Current Battery Service state:
   AC powered: false
   USB powered: true
   Wireless powered: false
   Overload: false
   USB overheat: false
   Extension: 0
   PowerJacketExist: false
   PowerJacketStatus: 0
   PowerJacketLevel: 0
   PluginStatus: true
   Unsupport Charger: false
   status: 1
   health: 2
   present: true
   level: 87
   scale: 100
   voltage: 4120
   temperature: 288
   technology: Li-poly
shell@htc_m8:/ $ dumpsys batteryproperties 

ac: 0 usb: 1 wireless: 0
status: 1 health: 2 present: 1
level: 87 voltage: 4187 temp: 287
shell@htc_m8:/ $
So the status is 1 = Unknown.

Does anyone know how I can 'influence' this, even by forcing it using dumpsys to set a variable?
I've tried all the usual tricks, power off, hold all buttons, power on holding for 2-3 minutes to reset battery, delete the batterystats.bin under recovery, etc.

Any ideas?
 
 
13th June 2018, 09:06 AM |#2  
OP Member
Flag North-East, UK
Thanks Meter: 6
 
More
By means of an update, it seems I can charge the phone, BUT it has to be turned off. When turned off, plug the charger in you get the charge symbol which then goes to the battery with red exclamation mark in it, but it continues to pull around 0.5amps and charges fully.

When the phone is turned on and booted up, plug the charger in and the battery exclamation mark appears, charge goes on 0.3amps then drops to 0.01amps and sits there so doesn't pull charge.

So that takes me over to something else, what is it in the o/s that's controlling charge rate?
13th June 2018, 03:54 PM |#3  
redpoint73's Avatar
Recognized Contributor
Thanks Meter: 6,516
 
More
Quote:
Originally Posted by andyb2000

So that takes me over to something else, what is it in the o/s that's controlling charge rate?

I'm not really a "hardware" guy. But just throwing out what I can, hoping it helps in some way.

It's something on the phone (exactly what, I don't know) in conjunction with a "smart" chip on the battery itself. So it's possible you just have a bad battery (pretty common for a water damaged phone, from what I've heard). In which case, a malfunctioning battery is not something to trifle with. An overcharged battery can lead to fire or explosion! And I'm not sure how far you want to go replacing the battery on a phone that is over 4 years old; when it might not completely fix the problem (may also be a short or other damage to the phone's board, etc.).
13th June 2018, 03:58 PM |#4  
OP Member
Flag North-East, UK
Thanks Meter: 6
 
More
Hi,
Thanks for the information, yep I do a lot of electronics and dealt with Li-Ion batteries for some time.

I have replaced the battery with two other alternatives as I also suspected the Li-ion control circuitry being the source of the issue, but alas it isn't. Voltage on the li-ion cells is fine, and the charge circuitry is responding correctly with voltage and level cutoffs in the correct ranges.
I also replaced the USB charge port which handles the charge regulation technology for the phone also, but to no avail.

My current focus is on the main circuit board, as I believe there is a temperature sensor used to monitor the battery temperature and this is giving me unusual readings which I'd suspect the O/S is controlling charge due to that.

Cheers for the input though!
Post Reply Subscribe to Thread

Tags
htc

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes