FORUMS
Remove All Ads from XDA

[GUIDE] Fix Fastboot on Windows 8.1 [Latest fix as of 8/25/14]

191 posts
Thanks Meter: 127
 
By dr3amsINdigital, Senior Member on 25th August 2014, 09:32 PM
Post Reply Email Thread
I know there are multiple fixes out there for getting Windows 8.1 to detect HTC phones while in fastboot mode, but some are dependent on whether you have an Intel or AMD processor and USB 2.0 or 3.0. This is the latest fix, and should work on all types of PCs and HTC phones. It worked for me on my computer with Windows 8.1 x64, Intel processor, and USB 2.0.

This is a repost of a thread by @izi501 in the Wildfire S forums; I just wanted to help spread the word. Credit goes to Auth from 4PDA and @niks255.

The issue has something to do with the BOS descriptor in Windows 8.1. It has been fixed in update rollup 2967917.

Instructions:
1. Install update rollup 2967917 for Windows 8.1.
- To check if you have the update installed already, go to Control Panel > Programs and Features > View Installed Updates > type "KB2967917" in the search box.
- If you don't have the update installed, open Windows Update to install it.
2. Download the attached file Fastboot.reg.txt and change the extension to Fastboot.reg.
3. Right click on the Start button and choose Command Prompt (admin). Then type "regedit" and press enter.
4. Go to File > Import > choose Fastboot.reg.

That should be it; Windows 8.1 should now be able to detect your phone when in fastboot mode!
Attached Files
File Type: txt Fastboot.reg.txt - [Click for QR Code] (324 Bytes, 78424 views)
The Following 91 Users Say Thank You to dr3amsINdigital For This Useful Post: [ View ] Gift dr3amsINdigital Ad-Free
 
 
26th August 2014, 09:48 AM |#2  
niks255's Avatar
Senior Member
Thanks Meter: 238
 
Donate to Me
More
Yes it will fix this issue for all PC's. Read about it here http://blogs.msdn.com/b/usbcoreblog/...h-code-43.aspx
I'm wondering why my reg file works for One S. Your device must have a different code, so it means a different registry key. Did you check it for yourself?
26th August 2014, 04:57 PM |#3  
dr3amsINdigital's Avatar
OP Senior Member
Thanks Meter: 127
 
More
Quote:
Originally Posted by niks255

Yes it will fix this issue for all PC's. Read about it here http://blogs.msdn.com/b/usbcoreblog/...h-code-43.aspx
I'm wondering why my reg file works for One S. Your device must have a different code, so it means a different registry key. Did you check it for yourself?

I wasn't aware that the reg file was supposed to be device-specific. I didn't check for codes specific to the One S, but I used your reg file and it worked fine for me. I don't have the phone anymore, so I can't check. Maybe someone else can verify the registry keys.

Anyway, thanks for the fix!

Sent from my OnePlus One using Tapatalk
30th August 2014, 02:12 PM |#4  
Senior Member
Thanks Meter: 73
 
More
It works.

Thanks you
13th September 2014, 05:21 PM |#5  
Jack_Surfer's Avatar
Senior Member
Flag Gdansk
Thanks Meter: 14
 
More
You saved my day
THANK YOU VERY MUCH, SIR !!!
7th October 2014, 01:26 AM |#6  
KkdGab's Avatar
Senior Member
Flag Auckland
Thanks Meter: 56
 
More
Is this for all htc devices?

EDIT: nvm it worked!!!
7th October 2014, 10:29 PM |#7  
Senior Member
Thanks Meter: 2,207
 
More
Quote:
Originally Posted by KkdGab

Is this for all htc devices?

EDIT: nvm it worked!!!

it should work for every single android device having problems with fastboot
23rd October 2014, 01:37 AM |#8  
Junior Member
Thanks Meter: 1
 
More
Works on Windows Technical Preview as well!!
The Following User Says Thank You to e_dawg For This Useful Post: [ View ] Gift e_dawg Ad-Free
14th November 2014, 03:17 PM |#9  
NetPerseo's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by dr3amsindigital

i know there are multiple fixes out there for getting windows 8.1 to detect htc phones while in fastboot mode, but some are dependent on whether you have an intel or amd processor and usb 2.0 or 3.0. This is the latest fix, and should work on all types of pcs. It worked for me on my computer with windows 8.1 x64, intel processor, and usb 2.0. I have a s4 one s; i'm not sure if this works with s3.

This is a repost of a thread by @izi501 in the wildfire s forums; i just wanted to help spread the word. Credit goes to auth from 4pda and @niks255.

The issue has something to do with the bos descriptor in windows 8.1. It has been fixed in update rollup 2967917.

instructions:

  1. install update rollup 2967917 for windows 8.1
    • to check if you have the update installed already, go to control panel > programs and features > view installed updates > type "kb2967917" in the search box.
    • if you don't have the update installed, open windows update to install it.

  2. download the attached file fastboot.reg.txt and change the extension to fastboot.reg.

  3. right click on the start button and choose command prompt (admin). Then type "regedit" and press enter.

  4. go to file > import > choose fastboot.reg.
that should be it; windows 8.1 should now be able to detect your phone when in fastboot mode! This will probably be one of my last posts here. I needed this fix to restore to stock, since i just sold my phone (i've moved on to the oneplus one). Thanks to all the devs out there that have made the htc one s so great!

perfect
27th November 2014, 10:28 PM |#10  
xxking10's Avatar
Junior Member
Thanks Meter: 1
 
More
thanks its running
29th November 2014, 09:33 AM |#11  
Senior Member
Flag Somewhere around the corner...
Thanks Meter: 32
 
More
thanks so much, it works great!!
Post Reply Subscribe to Thread

Tags
fastboot, htc, windows 8.1, windows 8.1 fastboot fix

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes