Remove All Ads from XDA

[Q] HW problem or not? - No baseband / IMEI after failed(?) OTA 4.2.2 on rooted HOX

4 posts
Thanks Meter: 0
By Jine, Junior Member on 5th July 2014, 02:24 PM
Post Reply Email Thread

EDIT: First post ever on XDA - since 2009! Haha - that must be a new personal record...

I was running a stock rooted S-ON device, CID: HTC__Y13 (Stock + CWM + SuperSU - and Link2SD) until a few days ago. I've ignored the OTA upgrades for heartbleed etc forever, but now i accidentally hit the wrong button and accepted it.

Somehow, somewhere, something went really, terribly bad...

After reboot, IMEI / Baseband was gone... (On the phone anyway)
Flightmode was in the state "Turning off..." (but it never does)

Fastboot still shows everything correctly:

(bootloader) version: 0.5a
(bootloader) version-bootloader: 1.72.0000
(bootloader) version-baseband: 5.1204.167.31
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 4.18.401.4
(bootloader) serialno: HT23WW13xxxx
(bootloader) imei: 359188xxxxxxx
(bootloader) product: endeavoru
(bootloader) platform: HBOOT-T30S
(bootloader) modelid: PJ4610000
(bootloader) cidnum: HTC__Y13
(bootloader) battery-status: good
(bootloader) battery-voltage: 3730mV
(bootloader) devpower: 24
(bootloader) partition-layout: None
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: None
(bootloader) hbootpreupdate: 2
(bootloader) gencheckpt: 0
all: Done!

I've tested with multiple, reflashed the radio, restored with my own past NANDROID-backups (before the OTA-mistake). I've relocked/unlocked it i don't know how many times. I've tested CM11 (4.4.3) and factory reset:ed it multiple times.... I've tested Viper 4.1.1 and pretty much EVERYTHING I can think of. Now I'm back on FULLY stock (from nandroid-backup after factory reset), stock recovery and stock boot.img, FULLY OTA updated afterwards, relocked bootloader and unrooted android, and still no IMEI/Baseband....

RUU doesn't work (HTC__Y13 doesn't have a new?)....

Worth mentioning is that it doesn't even complain about NOT having a SIM-card in it, doesn't matter if it have one or not. (No "Insert SIM-card" message)... Dialing 911 or simlar just prints "Turning radio on...." but it never does.

I've read multiple older threads with people with the same problem, and i think i've tried pretty much everything there is...

What the heck is wrong and what should I do about it? ANY ideas what so ever?

Before I started trying newer/other's - fastboot returned another version-main...

(bootloader) version: 0.5a
(bootloader) version-bootloader: 1.72.0000
(bootloader) version-baseband: 5.1204.167.31
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 4.18.401.2
5th July 2014, 06:39 PM |#2  
OP Junior Member
Thanks Meter: 0
After some serious debugging and crawling to TONS of logfiles (I actually didn't know that android stored previous system/kernel-logs in /devlog!)
I found this, which is very disturbing... Seems to me (without any deeper knowledge in Android, only of Linux in general) that there is in fact a HW-error in the tegra3 USB-bus connecting to the radio/GSM-IC...

5th July 2014, 06:49 PM |#3  
S3LEE's Avatar
Flag Liverpool
Thanks Meter: 6
Post Reply Subscribe to Thread

4.2.2, baseband, imei, ota, radio

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes