FORUMS
Remove All Ads from XDA

Compile of CM12.1 error

331 posts
Thanks Meter: 119
 
By milda25, Senior Member on 7th September 2015, 05:06 PM
Post Reply Email Thread
30th September 2015, 03:15 AM |#31  
Senior Member
Flag Atlanta, GA
Thanks Meter: 535
 
More
Quote:
Originally Posted by milda25

Didn't help for me Last try, when I find some time, I will try clean install of everything (Linux, developing tools, ...) and we will see.

Sent from my One X using XDA Free mobile app

I've tried that multiple times, and it didn't help. The only other thing I would try along those lines is a clean install using an older version of Ubuntu or perhaps a different distribution of linux. Ubuntu 15.04 clean install on my Intel core 2 quad w/ 6GB Ram doesn't work still (and it used to before september).
 
 
12th October 2015, 08:54 PM |#32  
OP Senior Member
Thanks Meter: 119
 
More
I'm solved problem with completely new installation. I'm working on virtual PC (VMware). I created new virtual machine, new linux instalation (Mint), settings all for building CM from scratch. Main virtual HW configuration: 6 CPU cores, 8GB RAM, 150 GB SSD HDD. Time of complete building: 93 minutes. Don't know why my previous configuration stop working. My solution is install all from scratch.
The Following 2 Users Say Thank You to milda25 For This Useful Post: [ View ] Gift milda25 Ad-Free
18th December 2015, 02:05 AM |#33  
svetius's Avatar
User Experience Admin
Thanks Meter: 7,118
 
More
Compile test
moonbutt74
3rd March 2016, 11:22 PM |#34  
Guest
Thanks Meter: 0
 
More
Doc,

Thanks!

This did it for me
Code:
mka org.cyanogenmod.platform-res
m
19th July 2017, 08:04 AM |#35  
Member
Flag Zwevegem
Thanks Meter: 104
 
More
Quote:
Originally Posted by milda25

Hi devs,

I would like to ask you about this problem:
Many times I have compiled succesfully CM ROM (12.1) without any problems. Compiles still the same (same machine, same OS, ...) and since yesterday I get this error. I can not solve it. Please, does anyone know what to do?
Thanks in advance.

Code:
target Strip: recovery (/root/android/system/out/target/product/endeavoru/obj/EXECUTABLES/recovery_intermediates/recovery)
----- Making recovery image ------
Copying baseline ramdisk...
Modifying ramdisk contents...
cp: nelze získat informace o*„/root/android/system/out/target/product/endeavoru/root/init.recovery.*.rc“: Adresář nebo soubor neexistuje
make: [/root/android/system/out/target/product/endeavoru/ramdisk-recovery.img] Error 1 (ignored)
/root/android/system/out/target/product/endeavoru/recovery.img maxsize=8562048 blocksize=4224 total=7170048 reserve=88704
Made recovery image: /root/android/system/out/target/product/endeavoru/recovery.img
target Java: org.cyanogenmod.platform.sdk (/root/android/system/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes)
javac: file not found: /root/android/system/out/target/common/obj/APPS/org.cyanogenmod.platform-res_intermediates/src/cyanogenmod/platform/Manifest.java
Usage: javac <options> <source files>
use -help for a list of possible options
make: *** [/root/android/system/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes-full-debug.jar] Error 41

#### make failed to build some targets (03:30 (mm:ss)) ####

Sorry for bumping an old post, just got the same error...
So nobody tried to remove the ccache folder yet?
The Following User Says Thank You to VBCerobil For This Useful Post: [ View ] Gift VBCerobil Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes