FORUMS
Remove All Ads from XDA

Looking for correct RUU.exe

145 posts
Thanks Meter: 33
 
By worf105, Senior Member on 29th January 2016, 11:26 AM
Post Reply Email Thread
Hello all XDA members,

I am looking for the correct RUU.exe for my HTC One M7. Its on Vodafone UK (VODAP001) and HBOOT 1.61.000 and is S-On. I have already relocked the bootloader and flashed the stock recovery back. I have found and tried many RUU.zip from here and HTC but I have learned that as I am S-on I am unable to go this route. This HTC One m7 was running a custom ROM and TWRP but since I am giving it my Father I needed it back to stock and ready to receive any OTA updates that Vodafone throw out.

Thank you all

Andrew
 
 
29th January 2016, 11:39 AM |#2  
Recognized Contributor
Thanks Meter: 3,585
 
Donate to Me
More
Quote:
Originally Posted by worf105

Hello all XDA members,

I am looking for the correct RUU.exe for my HTC One M7. Its on Vodafone UK (VODAP001) and HBOOT 1.61.000 and is S-On. I have already relocked the bootloader and flashed the stock recovery back. I have found and tried many RUU.zip from here and HTC but I have learned that as I am S-on I am unable to go this route. This HTC One m7 was running a custom ROM and TWRP but since I am giving it my Father I needed it back to stock and ready to receive any OTA updates that Vodafone throw out.

Thank you all

Andrew

Can you please post the output of "fastboot getvar all" (hide your imei and sn before posting)
Will be easier to point you the correct RUU.

Btw is KatKiss 5.1 working fine? Haven't played with my tf101 for a while!
The Following User Says Thank You to alray For This Useful Post: [ View ] Gift alray Ad-Free
29th January 2016, 11:46 AM |#3  
worf105's Avatar
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 33
 
More
Thank you for your quick reply and as requested here is the output to fastboot getvar all:

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.61.0000
(bootloader) version-baseband: 4T.35.3218.16
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 7.18.161.30
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: Sxxxxxxxxxxxxx
(bootloader) imei: xxxxxxxxxxxxxxxxx
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0710000
(bootloader) cidnum: VODAP001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4154mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-92aee636
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

Kind Regards,

Andrew
29th January 2016, 11:48 AM |#4  
worf105's Avatar
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 33
 
More
Quote:

Btw is KatKiss 5.1 working fine? Haven't played with my tf101 for a while!

Yes Lollipop 5.1 is working great and I have had no problems. Hopefully TimDuru will be presenting Marshmallow soon for the TF101
29th January 2016, 11:57 AM |#5  
Recognized Contributor
Thanks Meter: 3,585
 
Donate to Me
More
Quote:
Originally Posted by worf105

Thank you for your quick reply and as requested here is the output to fastboot getvar all:

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.61.0000
(bootloader) version-baseband: 4T.35.3218.16
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 7.18.161.30
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: Sxxxxxxxxxxxxx
(bootloader) imei: xxxxxxxxxxxxxxxxx
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0710000
(bootloader) cidnum: VODAP001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4154mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-92aee636
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

Kind Regards,

Andrew

The latest RUU for that version is 7.18.161.21. Since your phone is S-ON you can only flash RUU that are the same version or higher than your actual version (7.18.161.30). There is a way to bypass this. Go to this thread and read at the end of my post (post #2) under "how to downgrade with s-on". Once done and your version-main is showing 7.18.161.2 instead of 7.18.161.30 , flash the 7.18.161.21 RUU using instructions of post #1 (RUU file is at post #2). Don't forget to use the fastboot version provided at post #1, the normal fastboot version won't work to flash a lollipop RUU.

Quote:
Originally Posted by worf105

Yes Lollipop 5.1 is working great and I have had no problems. Hopefully TimDuru will be presenting Marshmallow soon for the TF101

Its amazing how this dev is still supporting this device, will try to update
The Following User Says Thank You to alray For This Useful Post: [ View ] Gift alray Ad-Free
29th January 2016, 12:12 PM |#6  
worf105's Avatar
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 33
 
More
Thank you alray

Will let you know how I get on with your instructions.

Ye TimDuru has done a great job in supporting the TF101. If he never I would have bought another tablet years ago.

Kindest Regards,

Andrew
29th January 2016, 01:37 PM |#7  
worf105's Avatar
OP Senior Member
Flag Kirkcaldy
Thanks Meter: 33
 
More
I worked a treat, thank you alray for your expert help in this matter.

Gratefully yours,

Andrew
29th January 2016, 01:54 PM |#8  
Recognized Contributor
Thanks Meter: 3,585
 
Donate to Me
More
Quote:
Originally Posted by worf105

I worked a treat, thank you alray for your expert help in this matter.

Gratefully yours,

Andrew

You're welcome
The Following User Says Thank You to alray For This Useful Post: [ View ] Gift alray Ad-Free
15th April 2019, 08:11 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by alray

The latest RUU for that version is 7.18.161.21. Since your phone is S-ON you can only flash RUU that are the same version or higher than your actual version (7.18.161.30). There is a way to bypass this. Go to this thread and read at the end of my post (post #2) under "how to downgrade with s-on". Once done and your version-main is showing 7.18.161.2 instead of 7.18.161.30 , flash the 7.18.161.21 RUU using instructions of post #1 (RUU file is at post #2). Don't forget to use the fastboot version provided at post #1, the normal fastboot version won't work to flash a lollipop RUU.


Its amazing how this dev is still supporting this device, will try to update

hi do you can helme whith my HTC wls RUU
15th April 2019, 10:18 PM |#10  
Recognized Contributor
Thanks Meter: 3,585
 
Donate to Me
More
Quote:
Originally Posted by jhon8500

hi do you can helme whith my HTC wls RUU

Yes, what is the problem?
18th April 2019, 01:30 AM |#11  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by alray

Yes, what is the problem?

okay thanks for replying I have a htc one m7 wls I tried to install a rom of cyanogen but I could not install it I decided to return my htc to s-on with the intention of reinstalling the rom stock of factory but I could not find it the intetnado install by SDK but I get the error "error: device '(null)' not found" and by means of the installer of the ruu by means of .exe says it is not appropriate if you can help me I would appreciate this,

this information of my device:
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.61.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: FA33YS901134
(bootloader) imei:xxxxxxxxxxxxx
(bootloader) meid: xxxxxxxxxxx
(bootloader) product: m7_wls
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0720000
(bootloader) cidnum: 11111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 3841mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-0e2a13e5
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes