FORUMS

 View Poll Results: The best OS for Huawei P20 Pro is?

EMUI 8.1
 
26 Vote(s)
15.48%
EMUI 9.0
 
67 Vote(s)
39.88%
AOSP 9.0
 
58 Vote(s)
34.52%
LineageOS 15.1
 
9 Vote(s)
5.36%
Other
 
8 Vote(s)
4.76%

[UBR] First Ever Android 9.0 for Huawei P20 Pro

381 posts
Thanks Meter: 510
 
Thread Closed Email Thread
13th December 2018, 03:12 PM |#441  
FirstEver's Avatar
OP Senior Member
Flag London
Thanks Meter: 510
 
Donate to Me
More
Quote:
Originally Posted by Vedrick

Magisk 18.0 was there and wanted to install itself from a zip file but the install failed every time, but after I flashed 17.3 on it, Magisk updated itself properly to v18.0. This is a great daily driver, thank you for the hard work.

It looks like the ROM is not rooted, only Magisk Manager app is installed.
You can download the latest Magisk ZIP from Magisk Manager, but you need to flash it in TWRP.
You don't need to install the previous version
13th December 2018, 03:16 PM |#442  
LJAM96's Avatar
Member
Thanks Meter: 15
 
More
The new LineageOS ROM has seemingly fixed NFC but cant get the Huawei camera app to work properly. Could look at helping eachother out to get to fix some bugs in eachothers ROMs
13th December 2018, 07:01 PM |#443  
Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by LJAM96

The new LineageOS ROM has seemingly fixed NFC but cant get the Huawei camera app to work properly. Could look at helping eachother out to get to fix some bugs in eachothers ROMs

Also doesn't have gestures.
14th December 2018, 01:45 AM |#444  
Senior Member
Thanks Meter: 119
 
More
Quote:
Originally Posted by LJAM96

The new LineageOS ROM has seemingly fixed NFC but cant get the Huawei camera app to work properly. Could look at helping eachother out to get to fix some bugs in eachothers ROMs

Have you tried https://forum.xda-developers.com/pro...oid-p-t3840110 ?
14th December 2018, 05:09 AM |#445  
Vedrick's Avatar
Senior Member
Flag Winnipeg
Thanks Meter: 47
 
More
Magisk module called: System Accent Theme (Colors) for P add a few color theme options to the quick settings area.
14th December 2018, 09:44 AM |#446  
macosx86's Avatar
Junior Member
Flag Paris
Thanks Meter: 0
 
More
So, has anyone got it to work on CLT29-432?
14th December 2018, 09:58 AM |#447  
Senior Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by macosx86

So, has anyone got it to work on CLT29-432?

Yes. But no charging LED and problems with push notifications (mainly WhatsApp). No NFC of course.
14th December 2018, 10:08 AM |#448  
starbase64's Avatar
Senior Member
Thanks Meter: 1,678
 
Donate to Me
More
Quote:
Originally Posted by macosx86

So, has anyone got it to work on CLT29-432?

i have always bootloop or stuck in boot screen.
14th December 2018, 11:57 AM |#449  
macosx86's Avatar
Junior Member
Flag Paris
Thanks Meter: 0
 
More
Quote:
Originally Posted by starbase64

i have always bootloop or stuck in boot screen.

Yup! Same here, although I have no problem restoring to eRecovery like some others seem to have

---------- Post added at 12:57 PM ---------- Previous post was at 12:54 PM ----------

Quote:
Originally Posted by ChangeToTower

Yes. But no charging LED and problems with push notifications (mainly WhatsApp). No NFC of course.

Did you install from emui or upgrade from previous AOSP?
14th December 2018, 12:28 PM |#450  
Senior Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by macosx86

Yup! Same here, although I have no problem restoring to eRecovery like some others seem to have

---------- Post added at 12:57 PM ---------- Previous post was at 12:54 PM ----------



Did you install from emui or upgrade from previous AOSP?

From clean EMUI, latest 8.1..
14th December 2018, 12:29 PM |#451  
Senior Member
Flag Slough
Thanks Meter: 648
 
More
Quote:
Originally Posted by macosx86

Yup! Same here, although I have no problem restoring to eRecovery like some others seem to have

---------- Post added at 12:57 PM ---------- Previous post was at 12:54 PM ----------



Did you install from emui or upgrade from previous AOSP?

I have faced these issues. My device was keep booting in to EMUI recovery. I finally unbricked my device. See the steps I have shared in this link. https://forum.xda-developers.com/hua...9c432-t3878714

I have now downgraded to 8.1. I am not going to flash 9.0 until root exploit becomes available.
Thread Closed Subscribe to Thread

Tags
android 9, android pie, aosp, first ever, huawei p20 pro
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes