FORUMS
Remove All Ads from XDA

P20 Pro - Microphone issues

47 posts
Thanks Meter: 13
 
By Alle090, Member on 22nd April 2018, 06:48 PM
Post Reply Email Thread
Hello,

I got myself a Huawei P20 Pro and am fairly satisfied with it atm. But there is one issue I have now and that is that apps like Line, Teamspeak 3 and even the phone app is using the wrong microphone when using a Bluetooth headset or even an USB C -> 3,5 mm headset.
One thing that I do remember now that I am writing this, is that I have Boldbeast Recorder installed, which is a call recording app. But I never had these issues with my Samsung S7 Edge.

Anyone else having similar issues?


Update;

I made a call earlier today and had these issues, but using the handset itself. But after a while even calling seems to not be working.
I did a quick reboot and now, huzzaa, everything works again...
The Following User Says Thank You to Alle090 For This Useful Post: [ View ] Gift Alle090 Ad-Free
 
 
24th April 2018, 01:45 PM |#2  
Member
Thanks Meter: 12
 
More
I have Huawei P20 Pro and I use Boldbeast call recorder. It works fine with the handset as well as work Bluetooth
The Following User Says Thank You to anilhk For This Useful Post: [ View ] Gift anilhk Ad-Free
27th April 2018, 05:46 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Same problems and more....
Quote:
Originally Posted by Alle090

Hello,

I got myself a Huawei P20 Pro and am fairly satisfied with it atm. But there is one issue I have now and that is that apps like Line, Teamspeak 3 and even the phone app is using the wrong microphone when using a Bluetooth headset or even an USB C -> 3,5 mm headset.
One thing that I do remember now that I am writing this, is that I have Boldbeast Recorder installed, which is a call recording app. But I never had these issues with my Samsung S7 Edge.

Anyone else having similar issues?


Update;

I made a call earlier today and had these issues, but using the handset itself. But after a while even calling seems to not be working.
I did a quick reboot and now, huzzaa, everything works again...

I have the same problems with my P20 Pro! I can't make calls after a while with apps like messenger och WhatsApp, and after a while even audio when recording video I gone! A restart works for a while but then back to same behavior! This is really bad if they want to compete on the high end market... Hoping for a system update that fixes this ASAP!
27th April 2018, 06:57 PM |#4  
Alle090's Avatar
OP Member
Flag Stockholm
Thanks Meter: 13
 
More
Quote:
Originally Posted by anilhk

I have Huawei P20 Pro and I use Boldbeast call recorder. It works fine with the handset as well as work Bluetooth

Hmm, I think it happens for me whenever I use my Bluetooth headset (Jabra EVOLVE 65 MS). After I stop using it and go back to my USB-C -> 3,5mm headset it has that weird bug again.


Quote:
Originally Posted by popeppel

I have the same problems with my P20 Pro! I can't make calls after a while with apps like messenger och WhatsApp, and after a while even audio when recording video I gone! A restart works for a while but then back to same behavior! This is really bad if they want to compete on the high end market... Hoping for a system update that fixes this ASAP!

For me it all starts working after a reboot :s


I got 3 days more to decide whether to keep it or not :s
28th April 2018, 05:32 PM |#5  
Alle090's Avatar
OP Member
Flag Stockholm
Thanks Meter: 13
 
More
So, I ended up returning my phone and got myself a Samnsung S9+ DS....
I am sorry!
22nd May 2018, 11:13 AM |#6  
Member
Thanks Meter: 12
 
More
I said earlier I don't have problem, but I do have problems with phone calls. The other party cannot hear me well. Maybe it is something to do with using Boldbeast. It records well, but maybe it interferes with phone calls. Can someone confirm this?
29th May 2018, 03:32 PM |#7  
Junior Member
Thanks Meter: 4
 
More
I'm regularly having the same issue.. Occasionally the other person at the start of a call can't hear me..

I have only yet encountered the issue with actual phone calls not whatsapp voice calls etc..

So I'm wondering if it's perhaps a VoLTE bug?

Or the only other thing I can think of is that perhaps the USB-C to 3.5mm headphone adapter plays around with the audio pipeline and doesn't reset.. Just speculation
29th May 2018, 11:02 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Microphone error
Same to me here... Is there any solution? My friend can't hear me at all on the phone call... But when I playing PUBG with microphone enable they said my voice just like cartoon....
30th May 2018, 08:07 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Private space is the key. I guess
Switching to private space.. ans switching back.. make u lose mic in calls.
I am sure of that.
30th May 2018, 07:59 PM |#10  
Junior Member
Thanks Meter: 4
 
More
There seems to be a few causes

Potentially:
1/ going into private space
2/ after using usb-c headphone adapter
3/ after using Bluetooth Audio

Still wondering if it's a VoLTE thing or if it also happens with whatsapp during a microphone. If it's only effecting phone calls and not apps that use the microphone that would point to volte or some other part of the call pipeline rather than the general audio pipeline

The only solution I have is to restart the phone.. That works

..
The Following User Says Thank You to dgoncalves81 For This Useful Post: [ View ] Gift dgoncalves81 Ad-Free
26th June 2018, 04:57 PM |#11  
Member
Flag Pasig City
Thanks Meter: 0
 
More
It seems like a firmware issue connected to the mic. Hope this gets resolved soon.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes