FORUMS
Remove All Ads from XDA

Google Maps Issue

4 posts
Thanks Meter: 1
 
By marzlol, Junior Member on 7th April 2018, 02:56 PM
Post Reply Email Thread
Just thought i would make a threat to address the google maps being laggy / unresponsive.

It can usually be fixed by changing the display to HD+ mode if this was bugging anyone like it was myself.
The Following User Says Thank You to marzlol For This Useful Post: [ View ] Gift marzlol Ad-Free
 
 
8th April 2018, 10:02 AM |#2  
Member
Thanks Meter: 10
 
More
i actually do have that problem- in hd+ mode :/
8th April 2018, 01:17 PM |#3  
Member
Thanks Meter: 10
 
More
Quote:
Originally Posted by marzlol

Just thought i would make a threat to address the google maps being laggy / unresponsive.

It can usually be fixed by changing the display to HD+ mode if this was bugging anyone like it was myself.

Thanks, that did help but not ideal. We can't not enjoy the FD+ just because it will slow down Google Maps. Come on Google, sort it out!!
8th April 2018, 01:41 PM |#4  
Member
Thanks Meter: 15
 
More
I guess Google blames it on Huawei, and Huawei blames it on Google. The fact remains that these problems were also reported on the Mate 10, 6 months ago and no progress has been made.
9th April 2018, 03:32 AM |#5  
Senior Member
Thanks Meter: 33
 
More
Don't have this issue. CLT-L09 variant.
9th April 2018, 09:25 AM |#6  
paul678's Avatar
Senior Member
Flag Craiova
Thanks Meter: 623
 
More
Came here from the P20 forum. I have the same problem on my device.
9th April 2018, 10:10 AM |#7  
Senior Member
Thanks Meter: 38
 
More
CLT-L09 here, used maps yesterday with no problems or lag
9th April 2018, 10:51 AM |#8  
Senior Member
Thanks Meter: 14
 
More
Good to see it's not just me.
It's laggy as hell for me. Far slower than it was on my LG G4 that I just moved from. So slow and jumpy!
9th April 2018, 11:53 AM |#9  
Junior Member
Thanks Meter: 4
 
More
Same issue here, hopefully either Huawei or Google will fix the issue over next week or so. (I can use the workaround till then but it is mildly annoying)
9th April 2018, 07:21 PM |#10  
Senior Member
Flag Swindon
Thanks Meter: 63
 
More
Strange how some people have this issue and others not. Maybe it's region dependent? I have a UK P20 Pro (Three network - dual sim) and I have been using it for navigation for a few days now with no issues. It is pretty much running the same as it did on my Galaxy S8+.

Not noticed lag anywhere so far! Scrolling is better than it was on any of my previous Samsung devices.

My only issue is the stock icons and launcher. It looks too outdated. I'll stick Nova on it soon when I have the time to set it all up.
9th April 2018, 07:26 PM |#11  
Member
Thanks Meter: 10
 
More
Quote:
Originally Posted by Highspeed123

Strange how some people have this issue and others not. Maybe it's region dependent? I have a UK P20 Pro (Three network - dual sim) and I have been using it for navigation for a few days now with no issues. It is pretty much running the same as it did on my Galaxy S8+.

Not noticed lag anywhere so far! Scrolling is better than it was on any of my previous Samsung devices.

My only issue is the stock icons and launcher. It looks too outdated. I'll stick Nova on it soon when I have the time to set it all up.

I have the same phone (P20 Pro Dual SIM from Three), though as per one of the previous comments, mine is a CLT-L29 as opposed to CLT-L09. Could that be the reason?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes