FORUMS
Remove All Ads from XDA

Huawei P9 Lite stuck on bootloop, can't enter recovery mode

4 posts
Thanks Meter: 0
 
By ellanyx, Junior Member on 3rd May 2017, 06:21 PM
Post Reply Email Thread
Hello, I'm new to xda, in fact I registered just to ask for help. My p9 lite got stuck on huawei logo, when i try to turn off the device it just reboots 2 times and then just stays on huawei logo. I can enter fastboot and rescue mode, but i have not enabled usb debugging and oem unlock on the device earlier. To be honest this is my first android device, in the past i used only windows phones, so you could say i'm completely new to this. Any suggestions on how to recover my phone or flash any rom into it? I'd be very glad if someone helped me find the solution to this problem. Not sure if i made a thread in the correct place, direct me if i'm mistaken
 
 
3rd May 2017, 08:12 PM |#2  
Junior Member
Thanks Meter: 0
 
More
There are few different versions of P9 Lite, look at the back of the phone to the bottom to see the numbers beside VSN and let us know.

1) Also when the phone is turned off plug in the usb to a computer or charging adapter
2) Hold down volume up & power
3) Let go of the power button when you feel the buzz while still holding the volume up button
4) Download latest version & recovery.
5) Go to Settings>Developer Options>USB Debugging On
5B) If you don't see Developer Options in settings, then go to Settings>About Phone>Build Number & ( tap the Build Number untill it unlocks)
6) Update us on the status, hope it works out.
3rd May 2017, 09:18 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by GloryNation

There are few different versions of P9 Lite, look at the back of the phone to the bottom to see the numbers beside VSN and let us know.

1) Also when the phone is turned off plug in the usb to a computer or charging adapter
2) Hold down volume up & power
3) Let go of the power button when you feel the buzz while still holding the volume up button
4) Download latest version & recovery.
5) Go to Settings>Developer Options>USB Debugging On
5B) If you don't see Developer Options in settings, then go to Settings>About Phone>Build Number & ( tap the Build Number untill it unlocks)
6) Update us on the status, hope it works out.

tried to enter recovery, still not work. can't go to developer options because phone is stuck on logo, can't power off. couldn't find any solution that works anywhere, been searching for more than 6 hours, still no use. phone model is VNS-L21 forgot to mention earlier
3rd May 2017, 10:36 PM |#4  
Junior Member
Thanks Meter: 0
 
More
What exactly were you doing before this happened and does your computer recognize your phone when plugged in at all.

Try holding volume up & down together & plug phone in when it reboots on you, & report back with what you see. If anything at all.
4th May 2017, 09:25 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by GloryNation

What exactly were you doing before this happened and does your computer recognize your phone when plugged in at all.

Try holding volume up & down together & plug phone in when it reboots on you, & report back with what you see. If anything at all.

I tried to install nougat update, computer recognizes it only in fastboot. holding volume buttons haven't changed anything still no progress. the thing is i had installed nougat a moth or so ago and it worked fine, then rolled back to marshmallow and now this. i'm pretty sure i tried to install correct package, because it was the same i had installed earlier
4th May 2017, 10:14 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Did you download a adb tool on your computer that have the 'fastboot.exe' file? If so open that folder,
Have the mouse curser hover in that folder, hold down shift & right click the mouse
Open command prompt
Connect phone as is in fastboot mode
Type adb devices & press enter
Type adb continue & press enter
6th May 2017, 08:08 AM |#7  
Member
Thanks Meter: 3
 
More
Hi,
I have the same issue as ellanyx.
my phone can only be stucked while booting or if I connect my phone to a computer, I'm able to boot it in fastboot.
as ellanyx, I didn't enable usb-debug nor OEM unlock option...
so when I'm in fastboot, I type the command "fastboot oem unlock xxxxxx" (hopefully the different data needed are the correct ones mentioned on the box of the phone) I get this error message:

C:\Users\Dieu\Downloads\SRKToolHuawei-STABLE-V1.3-20160619>fastboot oem unlock xxxxx
...
FAILED (remote: Command not allowed)
finished. total time: 0.016s

and off course the other options like "fastboot flash recovery recovery.img "... doesn't work.

I can't use the adb commands neither.
when I type the commande, as mentioned above, "adb devices" or "adb continue", nothing works.

So I'm a bit desesperate
do you have any solution for this kind of issue?
thanks
6th May 2017, 09:30 AM |#8  
Alexxxx1's Avatar
Senior Member
Flag Belgrade
Thanks Meter: 244
 
More
Dude, so the last firmware on your phone was MM or N? If it was MM you should put stock firmware appropriate for your model in dload folder on SD card and put volume+volume-power, and thats it. If you stack on N,....then I dont know because dload method doesnt work with N, or maybe works if you can find stock firmware with recovery for N.
Regards
6th May 2017, 04:02 PM |#9  
Member
Thanks Meter: 3
 
More
Unfortunately I can't update with the 3 button update otherwise it would indeed solvemy problem.
6th May 2017, 05:27 PM |#10  
Alexxxx1's Avatar
Senior Member
Flag Belgrade
Thanks Meter: 244
 
More
Quote:
Originally Posted by pyromana

Unfortunately I can't update with the 3 button update otherwise it would indeed solvemy problem.

Probably you didnt have correct Oeminfo for MM if dload method didnt work....Try to conect phone with Toolkit and follow procedure for flashing oeminfo and custombin, after that flash stock recovrry and b161 via dload metod. You will find it on forum here.
Regards
6th May 2017, 06:22 PM |#11  
Member
Thanks Meter: 3
 
More
the procedure from SRK toolkit?

would it be possible to provide it? because I can't unlock the OEM and I didn't tick the USB debug think.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes