FORUMS
Remove All Ads from XDA

[Solved] Stock firmware update failing on Huawei U8800-51

5 posts
Thanks Meter: 1
 
By Eadwulf, Junior Member on 20th September 2014, 07:04 AM
Post Reply Email Thread
I bricked my Ideos X5 U8800-51 while attempting to upgrade to Android 2.3.5. I was unable to boot the phone or access the boot/recovery menu for a factory reset, and the only thing I could do was load the pink screen. My backup image failed to restore the phone/OS, and I ended up having to reformat the SDcard (FAT32) and insert the dload from the official Android 2.2.2 firmware available directly on the Huawei website. I did manage to restore the "image" folder in pink screen with a backup I made well before attempting any of this.

When I attempt to flash to the stock Android 2.2.2 from Huawei, it begins the update process, only to say "update failed" a few moments after step 2/2 starts. The standard advice of removing the battery and powering the phone with the charger has not fixed the issue. It leaves behind the following in the error log on the SDcard:

Code:
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
Failure: OSBL°æ±¾¼ì²éʧ°Ü.
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!

I've attempted to replace the contents of the "image" folder with various editions of the relevant .img and .mbn files for the U8800-51 that I've located online to no avail. I've also attempted other forms of firmware for the U8800-51, again with no success.

If anyone can provide a solution, either with an image folder that's guaranteed to work or otherwise, it'd be much appreciated.
 
 
20th September 2014, 10:09 PM |#2  
OP Junior Member
Thanks Meter: 1
 
More
I've also tried out of desperation to use the stock firmware for the standard U8800 as well with the same results. I don't understand why the devil a blank phone refuses to flash any of the official firmware that's designed specifically for it. The hardware appears to be perfectly fine. Unfortunately I don't seem to be covered by warranty, so I can't get a replacement even if it wasn't.

Serves me right for trying to work with some cheap off-brand phone...
21st September 2014, 12:45 AM |#3  
OP Junior Member
Thanks Meter: 1
 
More
Trial and error indicates that the contents of the image folder don't matter in this case. Unfortunately I still have yet to find a version of firmware that this phone will accept.
30th September 2014, 10:28 PM |#4  
OP Junior Member
Thanks Meter: 1
 
More
Resolved. I was finally able to find a working backup image from a third party.
10th October 2014, 03:43 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Eadwulf

Resolved. I was finally able to find a working backup image from a third party.

Hi, Can you say where you got this image, and is it the original Froyo 2.2.2 for Consumer Cellular / At&t ? I've upgraded my U8800-51 IDEOS X5 from Consumer Cellular and have lost wifi and bluetooth, and would like to downgrade. Thanks in advance
11th October 2014, 02:52 AM |#6  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by fgleich

Hi, Can you say where you got this image, and is it the original Froyo 2.2.2 for Consumer Cellular / At&t ? I've upgraded my U8800-51 IDEOS X5 from Consumer Cellular and have lost wifi and bluetooth, and would like to downgrade. Thanks in advance

Took me a while because this blasted thing won't let me post external links, but it turns out someone posted it here: http://forum.xda-developers.com/show....php?t=1889305

Go to the section in the OP entitled "Reverting to Stock Froyo" and follow the instructions very carefully. The files are in the google drive link at the bottom of the OP (may need a google account to access them), in the u8800-51 ROM Flashing Tools -> 00 Back to Stock subfolder.
The Following User Says Thank You to Eadwulf For This Useful Post: [ View ] Gift Eadwulf Ad-Free
27th October 2014, 08:45 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Thank you thank you ! I managed to get the phone working like new again. I had to get the pink screen to work correctly first, which is a separate issue, and has posts that show you how to do that. Once I did that, I was able to flash the phone with the correct img ( actually, it wasn't the one that came with this model phone, but it works ) . Anyway, I have 2 working phones now, identical or close enough. What I'm trying to say is one phone has the AT&T system on it, and the other phone has the Consumer Cellular system on it, but they are close enough that it doesn't matter. Thanks to you folks and a lot of study, I was able to do this.
fgleich

---------- Post added at 01:45 PM ---------- Previous post was at 01:24 PM ----------

btw, I can provide the consumer cellular img file if anyone wants it. The one that you are refering to is the AT&T img file.
14th February 2018, 01:52 AM |#8  
Junior Member
Thanks Meter: 1
 
More
I

Sent from my HWCUN-L6735 using XDA Labs

---------- Post added at 02:52 AM ---------- Previous post was at 02:50 AM ----------

J

Sent from my HWCUN-L6735 using XDA Labs
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes