FORUMS
Remove All Ads from XDA

[ROM][UNOFFICIAL] OmniRom - Android 5.1

1,067 posts
Thanks Meter: 1,163
 
By faZevoLv, Senior Member on 11th March 2015, 07:37 PM
Post Reply Email Thread

OmniRom

omni1
Code:
/*
/* Your warranty is now void.
/*
/* I am not responsible for bricked devices or dead SD cards.
/* Please do some research if you have any concerns 
/* about using custom ROMs/Kernels.
/* YOU are choosing to make these modifications, and if
/* you point the finger at me for messing up your device, I will laugh at you.
/*
About
- This is a clean build of OmniRom and android version 5.1, along with my custom kernel and some extra GCC flags such as graphite courtesy of the SaberMod team.

Bugs
- Backlight sensor
- Occasionally does not boot

Downloads
Omni-5.1-20150319-tate-HOMEMADE.zip


XDA:DevDB Information
OmniRom - android 5.1, ROM for the Amazon 7" Kindle Fire HD

Contributors
faZevoLv
ROM OS Version: Lollipop
ROM Kernel: Linux 3.0.x
Based On: OmniRom

Version Information
Status: Beta

Created 2015-03-11
Last Updated 2015-03-16
The Following 25 Users Say Thank You to faZevoLv For This Useful Post: [ View ] Gift faZevoLv Ad-Free
 
 
11th March 2015, 07:38 PM |#2  
faZevoLv's Avatar
OP Senior Member
Flag Nantwich
Thanks Meter: 1,163
 
More

Changelog
19/03 - Synced the latest Omni sources
19/03 - Updated to the latest SaberMod toolchains
19/03 - Frameworks/base: Modified the lowmemorykiller to saner values
19/03 - Used DEXPREOPT for a faster first boot
19/03 - Tuned the rom to cortex-a9
19/03 - Build: Increase the performance of whole static libs
_
15/03 - Using the latest glibc2.15-4.8 host toolchain from Google
15/03 - Updated SaberMod toolchains
15/03 - Cherry-picked opticharger/squisher from liquidsmooth to reduce apps PNG sizes to increase performance
15/03 - Latest OmniRom sources
15/03 - Kernel: Fix-up the lowmemorykiller module and update to LMK from 3.4 kernel
15/03 - Enable graphite and O3 optimisation flags for kindle specific libs
_
13/03 - Built using GCC graphite flags from SaberMod
13/03 - Rom built with adroideabi-4.9 from SaberMod
13/03 - Latest OmniRom sources
_
11/03 - Initial release

Extras
Gapps
FML-PA-GApps-Micro-5.1-20150310-UNOFFICIAL.zip

Superuser
UPDATE-SuperSU-v2.46.zip
The Following 12 Users Say Thank You to faZevoLv For This Useful Post: [ View ] Gift faZevoLv Ad-Free
11th March 2015, 07:46 PM |#3  
Senior Member
Flag charleston wv
Thanks Meter: 169
 
More
Dont see link?
11th March 2015, 07:56 PM |#4  
faZevoLv's Avatar
OP Senior Member
Flag Nantwich
Thanks Meter: 1,163
 
More
Quote:
Originally Posted by cell2011

Dont see link?

it will be in the downloads section once its finished uploading, itll take about 15 minutes
The Following 4 Users Say Thank You to faZevoLv For This Useful Post: [ View ] Gift faZevoLv Ad-Free
11th March 2015, 08:26 PM |#5  
bryanchapman9999's Avatar
Senior Member
Thanks Meter: 74
 
More
Wow, I'm sat here about to do a clean flash of CM12 as mine has become dog slow. Hitting F5 now!

Will install and report back.

Many thanks!

---------- Post added at 07:26 PM ---------- Previous post was at 07:03 PM ----------

Is there a gapps for 5.1?? or will any of the PA gapps 5.0.x be OK?
11th March 2015, 08:38 PM |#6  
Senior Member
Flag charleston wv
Thanks Meter: 169
 
More
Any gapps needed for this rom? Or all included?

---------- Post added at 03:38 PM ---------- Previous post was at 03:32 PM ----------

Quote:
Originally Posted by bryanchapman9999

Wow, I'm sat here about to do a clean flash of CM12 as mine has become dog slow. Hitting F5 now!

Will install and report back.

Many thanks!

---------- Post added at 07:26 PM ---------- Previous post was at 07:03 PM ----------I heard banks minimal is ok but thats on unofficial build on nexus 4 someone ported 5.1. Im on this rom too its very nice smooth but no gapps

Is there a gapps for 5.1?? or will any of the PA gapps 5.0.x be OK?

I heard banks minimal is ok but thats on unofficial build on nexus 4 someone ported 5.1. Im on this rom too its very nice smooth but no gapps
11th March 2015, 08:38 PM |#7  
faZevoLv's Avatar
OP Senior Member
Flag Nantwich
Thanks Meter: 1,163
 
More
Quote:
Originally Posted by cell2011

Any gapps needed for this rom? Or all included?

gapps are never included in my roms, so just download the latest lollipop gapps and flash it
The Following 3 Users Say Thank You to faZevoLv For This Useful Post: [ View ] Gift faZevoLv Ad-Free
11th March 2015, 08:38 PM |#8  
bryanchapman9999's Avatar
Senior Member
Thanks Meter: 74
 
More
Quote:
Originally Posted by cell2011

Any gapps needed for this rom? Or all included?

Gapps are not included - I'm just downloading the latest PA gapps and will give that a go.

Installed fine and seems really good so far. Certainly quick and smooth.

@OP, whats does OmniSwitch do??
11th March 2015, 08:49 PM |#9  
faZevoLv's Avatar
OP Senior Member
Flag Nantwich
Thanks Meter: 1,163
 
More
Quote:
Originally Posted by bryanchapman9999

Gapps are not included - I'm just downloading the latest PA gapps and will give that a go.

Installed fine and seems really good so far. Certainly quick and smooth.

@OP, whats does OmniSwitch do??

its a recents app switcher made by the omnirom team, try it out
The Following 4 Users Say Thank You to faZevoLv For This Useful Post: [ View ] Gift faZevoLv Ad-Free
11th March 2015, 08:57 PM |#10  
bryanchapman9999's Avatar
Senior Member
Thanks Meter: 74
 
More
Quote:
Originally Posted by faZevoLv

its a recents app switcher made by the omnirom team, try it out

Cool thanks.

Which gapps to use? Latest PA gapps I can find fails to flash - wrong Android version
11th March 2015, 08:58 PM |#11  
Senior Member
Flag charleston wv
Thanks Meter: 169
 
More
Im trying to find stock core gapps for 5.1. I tried to google this cant find? It would be nice to have the new updated apps for 5.1 or a dump or some sort of apks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes