FORUMS
Remove All Ads from XDA

TWRP + Root Working on 14S rom X820

162 posts
Thanks Meter: 67
 
By julianhrojas, Senior Member on 19th May 2016, 03:12 PM
Post Reply Email Thread
This is my first post here, so please excuse me for my english, i'm from chile (spanish).

I'm gonna do a little tutorial to Install TWRP and root on Leeco X820....just received yesterday.

First we gonna need the official ROM 14S from here:

http://g3.letv.cn/188/43/59/letv-hdt...=5&splatid=500

And the Pack that i prepared here:

https://dl.dropboxusercontent.com/u/...wrp%2Broot.rar

Now:

Step 1: Unzip the file twrp+root.rar and Put the file BETA-SuperSU-v2.72-20160510112018.zip on the internal memory,
put LE_X2_X820-CN-FN-FEXCNFN5601405103S-5.6.014S.zip file on the internal memory too (this 2 files)
Step 2: Power off the phone
step 3: Enter to Fastboot mode (turn on pressing volume down)(http://www.netded.com/uploads/allimg...14151201_1.png)
Step 4: on the folder that you created to unzip (example C:/twrp+root) press and hold SHIFT then right mouse click and go to "open command line window here" (or something like that in english)
step5: Connect your phone and wait to install the drivers
step6: on the command line write: "fastboot oem unlock"
step7: If that's ok then write: "fastboot flash recovery Le_X820_TWRP.img"
step8: If that's ok now you have the recovery twrp (chinese) installed (if this not work 1st time, do it again)
setp9: Reboot your phone on recovery mode (holding power button + volume up) (from fastboot, you don't reboot in normal mode)
step10: you gonna see the recovery in chinese, but don't worry, this recovery is the same that always and the options are on the same order: http://www.teamsuperluminal.org/wp-c...02/twrp3_4.png
step11: go to install and flash the 14S rom (if you want), and if you want to keep your rom (probably 13S) just flash the SuperSU beta file.

If you want to Install a clean rom 14S with google play support (recomended), you have to wipe, then Flash the ROM 14s, and then flash this GAPPS (working fine) http://opengapps.org/ (just choose download ARM64+Android 6.0+ Pico version) and then flash the SuperSU beta file provided.

https://dl.dropboxusercontent.com/u/...519-115831.jpg
https://dl.dropboxusercontent.com/u/...519-100924.jpg
https://dl.dropboxusercontent.com/u/...519-100944.jpg
https://dl.dropboxusercontent.com/u/...519-112614.jpg

If you want to change the Language (in my case spanish), you can always use Morelocale (from playstore) with Root privileges
The Following 11 Users Say Thank You to julianhrojas For This Useful Post: [ View ] Gift julianhrojas Ad-Free
 
 
19th May 2016, 03:16 PM |#2  
OP Senior Member
Thanks Meter: 67
 
More
Greetings from Chile!!!!!
20th May 2016, 12:05 AM |#3  
Member
Thanks Meter: 21
 
More
This is great but I have a problem . I did fastboot and it said "sending TWRP" okay and "writing Twrp okay"and all well to step 9. It boots to the recovery(LeEco recovery) that came on the phone. Can I bypass that ?
20th May 2016, 12:47 AM |#4  
OP Senior Member
Thanks Meter: 67
 
More
Quote:
Originally Posted by MadMicro

This is great but I have a problem . I did fastboot and it said "sending TWRP" okay and "writing Twrp okay"and all well to step 9. It boots to the recovery(LeEco recovery) that came on the phone. Can I bypass that ?

do it again, it works for me the 2nd time...and dont let the phone reboot in normal mode...reboot from bastboot into recovery from the fastboot mode pressing and holding On buttond and vol up
The Following 2 Users Say Thank You to julianhrojas For This Useful Post: [ View ] Gift julianhrojas Ad-Free
20th May 2016, 10:35 PM |#5  
Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by julianhrojas

do it again, it works for me the 2nd time...and dont let the phone reboot in normal mode...reboot from bastboot into recovery from the fastboot mode pressing and holding On buttond and vol up

Very much appreciated, Thanks
I did it again and got Twrp working. I did the wipes and flashed the Rom smoothly. I also flashed the gapps file but it said it was incompatible I then booted to system, shut down and tried and failed to get TWRP so I did whole fastboot twice again and booted TWRP and flashed the file that was “incompatible” with no errors. But I get a number(5-7)”incompatible ‘/cust’ ??? (invalid argument)” with all TWRP operations .
Before leaving I went to 3rd block on rt of TWRP home screen and then to world globe on rt and changed language to English and TWRP is now in English. I then went to bootloader and deleted/inactivated the stock LeEco recovery and can now boot to TWRP normally(power+volme up).
However although I do have the Google Play store app. I keep getting message to say google services has stopped. When I try to add a google account on settings or click on play store app it spends a long time “checking info” and after 1 hour its still checking info.Does anyone have a solution ?
21st May 2016, 01:54 AM |#6  
OP Senior Member
Thanks Meter: 67
 
More
Quote:
Originally Posted by MadMicro

Very much appreciated, Thanks
I did it again and got Twrp working. I did the wipes and flashed the Rom smoothly. I also flashed the gapps file but it said it was incompatible I then booted to system, shut down and tried and failed to get TWRP so I did whole fastboot twice again and booted TWRP and flashed the file that was “incompatible” with no errors. But I get a number(5-7)”incompatible ‘/cust’ ??? (invalid argument)” with all TWRP operations .
Before leaving I went to 3rd block on rt of TWRP home screen and then to world globe on rt and changed language to English and TWRP is now in English. I then went to bootloader and deleted/inactivated the stock LeEco recovery and can now boot to TWRP normally(power+volme up).
However although I do have the Google Play store app. I keep getting message to say google services has stopped. When I try to add a google account on settings or click on play store app it spends a long time “checking info” and after 1 hour its still checking info.Does anyone have a solution ?

Do.you have flashed the pico version of gapps arm64??...that zip clean and delete all the previous versions of play store and then install the newest. I had problems with playstore too but with the gapps pico flashed all runs fine for me
21st May 2016, 12:16 PM |#7  
Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by julianhrojas

Do.you have flashed the pico version of gapps arm64??...that zip clean and delete all the previous versions of play store and then install the newest. I had problems with playstore too but with the gapps pico flashed all runs fine for me

First it tells me pico version is incompatible then it installed it . I also tried the Arm64 mini version but same result. I get lots of "Com.letv.android.phonecontrol not working" and "Sorry google play services has stopped "
How do you delete apps ? In settings .app management I can disable or force stop but not uninstall. When I press and hold there no uninstall to drag to. When disabled they dissapear but come back when I do factory reset or wipe cache dalvic an data....weird. i have repeated everything a few times but nothing changes .
I havent put a sim card in yet
I have not setup a LeEco acount yet either,.....necessary ?
Even tho I have picked English I still get a lot of status messages in Chinese .
Help appreciated !!!
21st May 2016, 02:08 PM |#8  
Member
Thanks Meter: 21
 
More
Click image for larger version

Name:	uploadfromtaptalk1463836035776.jpg
Views:	1974
Size:	88.7 KB
ID:	3757709
21st May 2016, 03:36 PM |#9  
OP Senior Member
Thanks Meter: 67
 
More
Quote:
Originally Posted by MadMicro

Attachment 3757709

I can do a backup of my system and upload it...if you want it you tell me...only if you know how restore a backup from twrp (you have to generate the code yo name the folder in backup)
The Following User Says Thank You to julianhrojas For This Useful Post: [ View ] Gift julianhrojas Ad-Free
21st May 2016, 03:40 PM |#10  
Member
Thanks Meter: 21
 
More
Well I think I am at end of road anyhow.
I use TWRP to backup and restore my own phone (not le max 2) but maybe its best if you tell me steps
Please let me use your backup as my le max 2 is a brick at moment
23rd May 2016, 03:26 AM |#11  
Junior Member
Flag Birobidzhan
Thanks Meter: 0
 
More
Install google play store (x820)
1) - INSTALL GOOGLE PLAY STORE(X820) htt*://impressivedroid.com/guide-install-google-play-store-on-le-2-x620/
2) - open play market and input login and password
3) - go to TWRP and install GAPPS ARM64+Android 6.0+ Pico version
Work it fine, no errors.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes