FORUMS

[ROM] [ZR] [LB/UB] [5.1.1] [.222] PureX Z v1.0 port from @Rajeev

303 posts
Thanks Meter: 279
 
By uncomment, Senior Member on 1st October 2015, 09:03 AM
Post Reply Email Thread
From @Rajeev (great dev for Z)

Test on my ZR (Lock bootloader)

Test on Unlock Bootloader by @rahulvr


FEATURES VERSION 1

Based On latest Xperia Z 5.1.1
Fully Deodexed Without Playstore Bug
Patched Services jar ( Superuser Mod )
Stock Kernel Integrated to Rom
Fully rooted with latest SuperSU
Fully Working Init.d Support
Xperia Z5 Calculator
Xperia Z5 Clock
Xperia Z5 Setup Wizard
Xperia Z5 Calendar
Xperia Z5 Sound Enhancement + X Loud Features
Xperia Z5 Image Enhancement
Xperia Z5 X Reality + Supervivid
Xperia Z5 Clock Widget
Xperia Z5 Home + Widgets
Xperia Z5 Smallapps Launcher
Xperia Z5 Smallapps
Xperia Z5 Backup & Restore
Xperia Z5 Themes & Theme Picker
Xperia Z5 Wallpapers
Xperia Z5 White - Balance
Xperia Z5 Live Wallpaper
Xperia Z5 Media Sounds
Xperia Z5 Messaging App + Cost Saving
Xperia Z5 Phonebook + Extra
Xperia Z5 My Xperia
Xperia Z5 Online Remote Camera
Xperia Z5 Email
Xperia Z5 Style Potrait
Xperia Z5 Weather Widget Release
Xperia Z5 Photo Widget Release
Xperia Z5 Sony Entrance 2
Added Call Recoding
Added 2G / 3G Only Mod
Disabled Data Notification When Turn On / Off
New PureX Bootlogo
Heavily Removed Bloatwares
More +++


DOWNLOAD

ROM Version 1 :

- ZR-lockeddualrecovery2.8.22: http://nut.xperia-files.com

- Rom: https://drive.google.com/file/d/0B-h...ew?usp=sharing

- V2 OTA : http://forum.xda-developers.com/show...0&postcount=17 (flash after flash rom V1)

INSTRUCTIONS FOR v1
- Copy Rom and recovery To Phone
- Enter Recovery
- Wipe all (system, data, cache, dalvik cache)
- Flash ROM
- Flash ZR recovery (avoid no recovery after flash rom)
- Reboot Ur Phone
- First Boot Will Take Time Upto 18 Minutes
- Enjoy

Source: http://forum.xda-developers.com/xper...-v1-0-t3212535

CREDITS

@Rajeev

|RXS MoonBreakers| |NUT| | Chainfire| |lagucool| |baris27| |Uncle Lucifer|

Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-10-01-10-52-17.jpg
Views:	6596
Size:	67.7 KB
ID:	3492058   Click image for larger version

Name:	Screenshot_2015-10-01-10-52-40.jpg
Views:	6370
Size:	69.2 KB
ID:	3492059   Click image for larger version

Name:	Screenshot_2015-10-01-10-53-25.png
Views:	6418
Size:	77.8 KB
ID:	3492060   Click image for larger version

Name:	Screenshot_2015-10-01-10-54-18.png
Views:	6312
Size:	91.0 KB
ID:	3492061  
The Following 19 Users Say Thank You to uncomment For This Useful Post: [ View ] Gift uncomment Ad-Free
1st October 2015, 09:18 AM |#2  
Rajeev's Avatar
Recognized Contributor
Flag Chennai , I N D I A
Thanks Meter: 26,590
 
Donate to Me
More
Great work my friend...
The Following 4 Users Say Thank You to Rajeev For This Useful Post: [ View ] Gift Rajeev Ad-Free
2nd October 2015, 07:36 PM |#3  
Member
Flag Diyarbakır
Thanks Meter: 24
 
More
nice work for this device!
2nd October 2015, 08:22 PM |#4  
Senior Member
Flag Mumbai
Thanks Meter: 136
 
More
Great work man!
Hope it will get updated like the 5.0.2 aroma port with that awesome zombie kernel, sound mods like viper4android, and much more cool stuff!
3rd October 2015, 03:57 AM |#5  
OP Senior Member
Thanks Meter: 279
 
More
Quote:
Originally Posted by neildalal

Great work man!
Hope it will get updated like the 5.0.2 aroma port with that awesome zombie kernel, sound mods like viper4android, and much more cool stuff!

You can find options like sound mode ... in Z forum

Sent from my C6603 using XDA Free mobile app
4th October 2015, 06:43 AM |#6  
Member
Thanks Meter: 34
 
More
Thanks for the great work. Everything seems to work except Bluetooth. The device switches on Bluetooth but does not discover any nearby devices. This problem also occurs in Safe Mode. Can you think of a reason why this might be?

Also, a minor issue: the device's model number is given as C6603....
4th October 2015, 08:02 AM |#7  
OP Senior Member
Thanks Meter: 279
 
More
Quote:
Originally Posted by axel007

Thanks for the great work. Everything seems to work except Bluetooth. The device switches on Bluetooth but does not discover any nearby devices. This problem also occurs in Safe Mode. Can you think of a reason why this might be?

Also, a minor issue: the device's model number is given as C6603....

- In normal mode, bluetooth connected with another devices. I think in safe mode not working for security

- If you dont like your device name is C6603, rename it to C5503:

open build.prop in system/ and edit all string "C66" by "C55" and "Xperia Z" by " Xperia ZR"
The Following User Says Thank You to uncomment For This Useful Post: [ View ] Gift uncomment Ad-Free
4th October 2015, 09:37 AM |#8  
Member
Thanks Meter: 34
 
More
BT issues
I performed a factory reset and the very first thing I tried after that is bluetooth. No luck - still not working. It switches on, scans for devices but doesn't find any.
Before I decided on the factory reset, it detected my laptop for a few seconds when I rebooted the laptop, but then lost it again. It never detected my bluetooth headsets. Googling around, it seems that 5.1.1 is causing BT trouble on various devices. Also, by the way, Safe Mode does not disable BT. Trying in safe mode is a regular trouble shooting procedure for BT issues.

I don't care about the device name, just thought I should mention it.

A bigger problem is the absence of the Xperia diagnostic tool that usually is accessible from Settings/About Phone. It's not there. I downloaded the "light" version from the Playstore but this crashes every time I start it up.



Quote:
Originally Posted by uncomment

- In normal mode, bluetooth connected with another devices. I think in safe mode not working for security

- If you dont like your device name is C6603, rename it to C5503:

open build.prop in system/ and edit all string "C66" by "C55" and "Xperia Z" by " Xperia ZR"



---------- Post added at 04:37 PM ---------- Previous post was at 04:30 PM ----------

Whoah, wait a moment! I just switched one of my headsets to pairing mode, then switched the BT on the phone off and on and off and on like crazy, then waited (with BT on) and suddenly it detected the headset and paired. Weird. ADDITIONAL COMMENT NEXT DAY: no further BT issues. I have been able to pair another headset and a bunch of Trackr Bravo trackers. So I can confirm that all major functions on this phone work and the ROM is very nice indeed.

I'll report further if I find out anything else.

Quote:
Originally Posted by axel007

I performed a factory reset and the very first thing I tried after that is bluetooth. No luck - still not working. It switches on, scans for devices but doesn't find any.
Before I decided on the factory reset, it detected my laptop for a few seconds when I rebooted the laptop, but then lost it again. It never detected my bluetooth headsets. Googling around, it seems that 5.1.1 is causing BT trouble on various devices. Also, by the way, Safe Mode does not disable BT. Trying in safe mode is a regular trouble shooting procedure for BT issues.

I don't care about the device name, just thought I should mention it.

A bigger problem is the absence of the Xperia diagnostic tool that usually is accessible from Settings/About Phone. It's not there. I downloaded the "light" version from the Playstore but this crashes every time I start it up.

5th October 2015, 01:30 AM |#9  
Member
Thanks Meter: 34
 
More
Thanks.
uncomment and Rajeev, thanks very much for making this available for the ZR. This is so nice. I came from a 4.2.2 on a DoCoMo branded Xperia A. The improvements in 5.1.1 are enormous. This phone's life expectancy just increased by at least a year.

Great job!!
The Following User Says Thank You to axel007 For This Useful Post: [ View ] Gift axel007 Ad-Free
6th October 2015, 06:05 PM |#11  
Junior Member
Thanks Meter: 7
 
More
tested and working well on unlocked bootloader too..
The Following 2 Users Say Thank You to rahulvr For This Useful Post: [ View ] Gift rahulvr Ad-Free
Post Reply Subscribe to Thread

Tags
development

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes