Remove All Ads from XDA

Tablet not powering on? Brick?

54 posts
Thanks Meter: 17
Post Reply Email Thread
The device responds to any button presses with the image that says 0% battery. When plugged in long enough it stays on "Needs more power to turn on." It has power, it can continuously respond to button presses with that bright image for hours on end. Attempting to boot into recovery/download mode responds with the same screen no matter how long I press it. Holding the power button for any period of time while unplugged results in it showing the battery 0% and then going to blank screen a few times then staying on a blank screen while immediately responding to any other button presses with 0% battery. Holding it while plugged in results in an infinite flashing 0% battery logo that flashes on for a split second every few seconds. Help?
2nd September 2014, 11:11 PM |#2  
Ravynmagi's Avatar
Senior Member
Thanks Meter: 201
Something similar has happened to me.

I installed TWRP and CM11 on it a few weeks ago. It had been running fine. A couple days ago I accidentally let the battery run completely out. Now it won't charge or power on.

It doesn't appear to be charging at all, doesn't get warm like it normally would when charging. Pressing the power button does nothing now, first time I tried to power it on I saw the plug image indicating no charge, but now I get nothing at all.

I've tried holding the power button for 30 seconds (and longer). I've tried holding the power and volume down buttons together. I've left it plugged in all night. It seems to be completely dead now.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes