Remove All Ads from XDA
Honor View 10

CPU Frequency staying higher tan it should

501 posts
Thanks Meter: 285
By Floodland, Senior Member on 17th August 2014, 01:12 AM
Post Reply Email Thread
I am currently using CloudyFlex 2.6, clean install, but it started with several different ROMs, kernels and configurations...
The thing is: Unless I use conservative governor (tried with interactive/ondemand/intelliactive/alucard), the CPU frequency for the first core stays higher than it should while idling.

Even with less than 10% CPU usage, I find CPU_0 sticking with +1ghz frequency, some time ago the same governors with similar loads slowed down to 300mhz while idling (the expected), now none but conservative seems to respect the established thresholds for slowing down.
For interactive CPU_0 ramps to max_speed, then goes down to defined highspeed_freq parameter and stays there for no good reason or load (3% CPU usage, 6% for several seconds and it still stays at highspeed_freq).
It should go down to 300mhz until new heavy load (80/90% or whatever threshold defined) , but it does not, and I cannot find the reason for it (even played with governor controls without being able to deactivate this battery wasting behavior).

I think something changed recently, but the worst at all is that all kernels seems to be affected (cloudykernel, dorimanx, simple kernel) I already tried disabling all init.d scripts (just in case), disabled xposed framework, uninstalled tweakers, and I cannot find the culprit, clean install, same issue. Different ROMs, same issue... Only conservative slow down as it should.

Any clue on recent cpu handling changes that might produce this behavior? Other users that might try if you see the same behavior?

Thanks in advance
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes