Remove All Ads from XDA

The dreaded RED 2? Problem returning to stock? TRY THIS!

1,009 posts
Thanks Meter: 674
By Jessooca, Senior Member on 30th August 2014, 07:57 AM
Post Reply Email Thread
This is for those of you who tried to UNroot your phone but were unable to, IF you are on Windows 8.1 there are many people who have not been able to restore there phones using WolfGart's method, and end up with a big RED 2 on their screen. Which, I myself did.

IF you had any problems using his method and have been unable to unroot your phone and return to stock, try this method. This is not all my doing here, mostly others and I have compiled it into a nice thread with pics to follow along to.

This will delete everything off your phone, backup any important information!!

As there is already several guides you can follow to Unroot and return your LG G3 to stock, I myself got stuck at 94% many times, I couldn't understand why and instead of the RED number 3, I had the RED number 2 on my screen, Thanks to a post shared by fellow XDA'er AlanVenu I got my phone back up and running.

ALL the files you need are posted below:

***First things first, IF you are using Windows 8/8.1 you need to disable "Driver Signature Enforcement" in the advanced start up settings.****

This is how you fix this issue if you cannot get your Sprint LG G3 back to stock IF you are stuck...
1a. Install the LG usb drivers, wait for this to finish BEFORE you plug in your device.
1b. Power off your phone. Press and hold the power button and select "Power off" and then "OK" on the LG G3.
2. Press and hold the volume up. Keep holding and plug in a microUSB to your phone. You should now see "Firmware Update", if you don't take the battery out and do it again.
*Note: Make sure the USB is already plugged into the computer before performing step 2!
3. Open up Device Manager on your computer.
4. Find "Ports (COM & LPT)", click on the tab on the left to expand it. You should see "LGE Mobile USB Serial Port (COM)".

5. Double click on "LGE Mobile USB Serial Port (COM)" > then Port Settings > then Advanced > next to "COM Port Number:" choose "COM41", then click OK. YOU MUST DO THIS STEP!!!

6. Click on "OK" and then "OK" again.

7. NOW ...Unzip "" and install Setup_LGFlashTool_1.8.6.527.exe.
Its Provided in this link, if you don't have it :
Pay attention to this next step!
Note: At the last installation step when it asks you to "Run LGFlashTool" uncheck it. Then click "Finish".

9. In the "LGFlashTool" folder there is a file called "MegaLock.dll". Right Click and Copy this file, now open your hard drive where you installed it and paste it in C:\LG\LGFlashTool if it does not ask you to replace the one currently there, you've done something wrong. Do it again.
Note: The "C:" is your main Windows hard drive, I suppose yours could have a different letter.

10. Download the LG G3 stock firmware for your specific LG G3 model using the link below. Make sure you download both the .dll and zip file.

Download LG G3 Stock Firmware (.dll & zipped .TOT) for your device {{the first link in each is the dll, followed by the tot file you'll need both!
F400K :
11. After you have downloaded these, Unzip the larger file and you will see .TOT in the unzipped folder. You now have a .TOT and a .dll file for your LG G3.

12. Open LGFashTool, this icon should now be on your desktop. If it isn't look in C:\LG\LGFlashTool folder.

13. Click on "Select Manual Mode".

14. Click on "..." and choose the .dll that you just downloaded.

15. FIRST, Click on "Add" and choose the .TOT stock firmware that you just downloaded and unzipped.... now you MUST click on BOARD DL....Now click on OK

16. Click on the yellow arrow located at the top left of the program and wait until the middle gray box disappears.

...Screen shot of the middle grey box below.... JUST WAIT it'll finish....

17. You should now see only 1 yellow box that says "READY!!". All the other ports should say "DISABLE". IF it does not say PORT 41 then you didn't do step 5 above correctly, you MUST do step 5 correctly.

18. Now unplug your phone from the usb cord, and plug it back in.

You should now see "Waiting for Connection.".... after you've plugged the phone back in, it will begin to flash your phone.... be patient and let it do it's thing.

19. NOW your phone will flash and end up at a screen that says AAT Mini OS, blah blah blah... Disregard what it says on the screen (mine said "Do Not Touch the screen" or something along those lines) and press the OK on the screen and now PRESS and HOLD the POWER button on the back of your phone, then Tap on the screen where it says NORMAL
Again it's "Normal & Power button"

20. Your phone will reboot and you're now restored!
21. If it doesn't reboot, take out the battery, put it back in, and power on your phone.

Let me know shout out to those who actually did all the work to make this happen, I simply took several people's work and compiled it into a step by step with pictures to help you fix the dreaded BIG RED 2 on the screen, instead of the 3 you should've got.
Thanks! AlanVenu for sharing this in the thread which he found on another site, I myself have tested all of the above, multiple times and it works without a hitch.
Of course WolfGart for creating the Restore your LG G3 To Stock Thread.

IF I have left anyone else out, don't be a jerk, just let me know. I am not here to pi$$ in anyone's corn flakes, or steal anyone's glory, just trying to make things easy for those who have issues.
The Following 62 Users Say Thank You to Jessooca For This Useful Post: [ View ] Gift Jessooca Ad-Free
31st August 2014, 01:33 AM |#2  
customworx's Avatar
Senior Member
Flag Bobingen / Augsburg
Thanks Meter: 143
Donate to Me
Wow, nice tut great work mate
31st August 2014, 11:07 AM |#3  
D0MINO's Avatar
Senior Member
Thanks Meter: 34
I have win 8.1 and tried this method a few times but it did not work and would say it failed to activate the download mode. When I tried it on my desktop Win 7 it worked perfectly and just as you mention. I don't understand how this method above is meant to work on Win 8.1 as it appears exactly the same as wolfgarts? ..unless I missed something? (I came across this thread after I eventually figured out how to fix the issues with wolfgarts method).

I must commend you on your detailed explanation of this method all in one place and step by step as tbh, I found wolfgarts a little unclear and confusing. This is along the lines of how he should have written it as I was frustrated by having to refer to another page for the method and then trawl through 25 pages to find out that I should just use Win 7 to avoid any problems.

Just aswell I didn't get rid of my desktop but am wondering if anyone has managed to use a VM with Win 7 to successfully flash via this method? I only have an XP VM and tried it through that but for some reason it was throwing up errors when I tried to allow direct access to USB devices via VirtualBox.
31st August 2014, 08:50 PM |#4  
thznutz87's Avatar
Senior Member
Thanks Meter: 183
I had the red 2. I just let it get to the reboot and held vol+ and re-ran the flash tool. Side note my dl mode displayed differnt numbers the second time after holding vol+ to go back to dl mode. After the second flash it booted just fine. I had to flash it twice without letting it go to aat mode the first time.

Sent from my LGLS990 using Tapatalk
31st August 2014, 09:21 PM |#5  
Senior Member
Flag Antalya
Thanks Meter: 4
did u have tot file for d855tr?
i was tried with d855 global tot file but wasnt success...
1st September 2014, 05:04 PM |#6  
Senior Member
Thanks Meter: 168
Microsoft VirtualPC does not emulate USB ports, so trying to run this in that VM will not work.
1st September 2014, 05:46 PM |#7  
D0MINO's Avatar
Senior Member
Thanks Meter: 34
Originally Posted by trent999

Microsoft VirtualPC does not emulate USB ports, so trying to run this in that VM will not work.

I don't use MS VirtualPC but Oracle VirtualBox. I know that I can directly open/connect USB flash drives and webcams through VirtualBox in a XP VM with close to 0 issues (it has always worked 9/10 before but inconveniently on this occasion it wasn't allowing me to connect to a USB device directly), so am guessing perhaps G3 flashing might be possible too if I ran a Win 7 VM in it?

Sent from my LG-D855 using Tapatalk
3rd September 2014, 05:55 AM |#8  
Jessooca's Avatar
OP Senior Member
Flag Palo Alto, CA
Thanks Meter: 674
Not sure why you'd have had issues on Win 8.1 64 bit, which is the laptop I used. I would suggest if anyone else encounters in inability to do this on Win 8 or 8.1 to uninstall their drivers, reboot their computer and reinstall the latest drivers first.

**It's possible that the issue may have been in Win 8/8.1 you should Disable Driver Signature Enforcement first.......
Do the following to do that.

1. Open the Windows 8 Charms bar. {Hover your mouse to the right hand bottom corner to display the Charms Bar then click on Settings}

2. Select “Change PC Settings”

3. The PC Settings window will open. Select “General” from the left hand menu. Scroll the right target window to the bottom and select “Restart now” under Advanced startup

4. Select "Troubleshoot" from the Choose an option screen.

5. Select “Advanced options” from the troubleshoot menu.

6. Select “Startup Settings” from the Advanced Options menu.

7. You will be prompted with another Restart Windows to change options screen. Click “Restart”

8. Select #7) Disable driver signature enforcement” by pressing the number 7 key on your keyboard.

After it's booted back up then try the method method
The Following 3 Users Say Thank You to Jessooca For This Useful Post: [ View ] Gift Jessooca Ad-Free
7th September 2014, 03:39 PM |#9  
hyelton's Avatar
Recognized Contributor
Flag Wilmington
Thanks Meter: 6,141
Donate to Me
Not sure what you mean by the title , but after going through and reading the OP this info/ guide has already been posted long ago.

Unless I'm missing something it's the same guide.
Sent from my D6503 using Tapatalk
The Following User Says Thank You to hyelton For This Useful Post: [ View ] Gift hyelton Ad-Free
7th September 2014, 04:11 PM |#10  
gregbradley's Avatar
Forum Moderator
Flag Probably marking work or drinking beer...Maybe both
Thanks Meter: 6,608
Donate to Me
I am moving this "Guide" to the general section.

Please do not post "guides" and "How Too" threads in the development section

Thread Moved
7th September 2014, 05:35 PM |#11  
Jessooca's Avatar
OP Senior Member
Flag Palo Alto, CA
Thanks Meter: 674
Send me a link to this same guide, I'd appreciate it. Fixing the phone with the Red 2 not the Red 3, isn't the same thing, this was merely to help those with pics, explaining using pics how to get the 41com port especially... I would have assumed there was a thread, but I haven't seen the one for the Red 2. I know the Red 3 exists, and again, it was merely meant to help those stuck on the 2, it's not the same as stuck on the red 3.

In the past week, I've receieved more than 20 messages from those thanking me, so apparently they couldn't find the other thread either. lol

Thanks again, like my post said and the purpose of XDA I was merely trying to help those who need it, some people get in way too far over their heads and don't read enough before messing with their phones.


Originally Posted by hyelton

Not sure what you mean by the title , but after going through and reading the OP this info/ guide has already been posted long ago.

Unless I'm missing something it's the same guide.
Sent from my D6503 using Tapatalk

The Following User Says Thank You to Jessooca For This Useful Post: [ View ] Gift Jessooca Ad-Free
Post Reply Subscribe to Thread

94%, big 2, red 2, stock, unroot

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes