FORUMS
Remove All Ads from XDA

hotspot/tethering with no internet acess

3 posts
Thanks Meter: 2
 
By dubcmj, Junior Member on 20th March 2015, 04:17 AM
Post Reply Email Thread
Hi all,

I have an issue when trying to use wifi hotspot or USB tethering. I am able to connect to the G3 without any issues, but when I connect there is no Internet access on the device I connect with (the G3 still has Internet access when tethered). I have tested this with my laptop and also a different phone and neither device can access the Internet when tethered to the G3. I have also tested the sim card in another device, and confirmed that the sim is not the cause of the problem - the G3 is definitely the cause.

Does anyone have any idea why this might be happening, or how to fix it? I'd prefer not to root the phone.

Details:
LG G3 D855, 32 GB version.
Software: V20c-SEA
I am not rooted and I'm using the stock ROM.
 
 
20th March 2015, 06:00 AM |#2  
OP Junior Member
Thanks Meter: 2
 
More
I have just discovered that tethering will work on my phone when I disable 4G.

i.e. when I select "GSM/WCDMA auto" as my preferred network mode, tethering works.
when I select "GSM/WCDMA/LTE auto", tethering will not work (as described in first post).

Does anyone know why LTE would prevent tethering from working?
20th March 2015, 06:20 AM |#3  
OP Junior Member
Thanks Meter: 2
 
More
OK, so I finally managed to find a very simple solution to my own problem. I'll post here in case anyone else has the same problem.

In phone settings, go to:
Tethering & Networks --> Mobile Networks --> Access point names
Click on your relevant APN to get into the settings.
Edit "APN type" and delete it so it's empty (mine previously said "default").
Save the changes.

That's it! Tethering should work now.
The Following 2 Users Say Thank You to dubcmj For This Useful Post: [ View ] Gift dubcmj Ad-Free
8th September 2015, 02:12 PM |#4  
Junior Member
Thanks Meter: 0
 
More
That's fantastic dubcmj!!!

Worked perfectly for me too. So happy right now!
1st February 2016, 02:50 AM |#5  
Senior Member
Ottawa
Thanks Meter: 57
 
More
I got a Rogers G3 and had no internet access after connect to hotspot. The Rogers APN cannot be edited. So I created a new APN with just the name and ltemobile.apn, leave all other settings blank. Tethering works now.
5th May 2016, 11:54 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by dubcmj

Hi all,

I have an issue when trying to use wifi hotspot or USB tethering. I am able to connect to the G3 without any issues, but when I connect there is no Internet access on the device I connect with (the G3 still has Internet access when tethered). I have tested this with my laptop and also a different phone and neither device can access the Internet when tethered to the G3. I have also tested the sim card in another device, and confirmed that the sim is not the cause of the problem - the G3 is definitely the cause.

Does anyone have any idea why this might be happening, or how to fix it? I'd prefer not to root the phone.

Details:
LG G3 D855, 32 GB version.
Software: V20c-SEA
I am not rooted and I'm using the stock ROM.

Yep. Exact same problem.

---------- Post added at 11:54 PM ---------- Previous post was at 11:45 PM ----------

Good thread. The above didn't solve for my issue but pointed me in the right direction. My network provider (OPTUS AUSTRALIA) had multiple APN's. Tethering with the default APN failed to allow internet access via wifi hotspot. I changed the APN to default using a different APN and reconnected my laptop and this now works. The alternative was to turn the phone off and on again which was driving me nuts. I hope this helps anyone else with the same issue.
19th September 2016, 04:20 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Thanx.
Worked for me.

Thanks.
14th December 2016, 04:21 AM |#8  
Junior Member
Thanks Meter: 1
 
More
Great my LG-H831 G5 was also fixed by this so thanks.
I've got that settings with text message by my wireless career ... So I guess they are to blame for together with LG's crappy heavily customized roms


Quote:
Originally Posted by dubcmj

OK, so I finally managed to find a very simple solution to my own problem. I'll post here in case anyone else has the same problem there full with problems like that

In phone settings, go to:
Tethering & Networks --> Mobile Networks --> Access point names
Click on your relevant APN to get into the settings.
Edit "APN type" and delete it so it's empty (mine previously said "default").
Save the changes.

That's it! Tethering should work now.

The Following User Says Thank You to inphasis For This Useful Post: [ View ] Gift inphasis Ad-Free
23rd May 2017, 08:08 PM |#9  
Member
Flag Pijnacker
Thanks Meter: 1
 
More
Quote:
Originally Posted by dubcmj

OK, so I finally managed to find a very simple solution to my own problem. I'll post here in case anyone else has the same problem.

In phone settings, go to:
Tethering & Networks --> Mobile Networks --> Access point names
Click on your relevant APN to get into the settings.
Edit "APN type" and delete it so it's empty (mine previously said "default").
Save the changes.

That's it! Tethering should work now.

Thanks so much for this! I have a completely different cell phone (Samsung Galaxy S7 edge) with Vodafone NL and had the same issue.
My APN type was set to "default,supl,mms,xcap" by default, and deleting it so it's empty and saving the changes resolved the problem right away!
20th July 2017, 09:46 AM |#10  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by dubcmj

OK, so I finally managed to find a very simple solution to my own problem. I'll post here in case anyone else has the same problem.

In phone settings, go to:
Tethering & Networks --> Mobile Networks --> Access point names
Click on your relevant APN to get into the settings.
Edit "APN type" and delete it so it's empty (mine previously said "default").
Save the changes.

That's it! Tethering should work now.

Thank you my friend i'm looking for a solution the last year... Now i can tether my connection!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes