Remove All Ads from XDA

LG G3 - GPS sees satellites but wont lock on?

9 posts
Thanks Meter: 0
By Croots, Junior Member on 26th August 2014, 03:50 AM
Post Reply Email Thread
I've searched the forum and have read about the issues others are having with GPS however my issue is completely different then what everyone else has experienced. I've already ordered a new phone from Rogers but I am so mind boggled with what is going on that I needed to post and ask to see if anyone can explain this.

Carrier - Rogers
Model - D852 (Interesting to note, although the sticker on the phone/box and software say D852 the engraving on the plastic components under the battery cover say D850)

So the phone sees the GPS satellites however will not get a lock on at all. I have high mode accuracy enabled. The GPS icon in the status bar stays light grey and in navigation just says searching for satellites. I downloaded GPS Test app and it shows that it sees satellites however will not get a lock their either. I've even tried going into the LG secret menu and test the GPS from their, same problem. I've done a factory reset and it still didn't work.

Is this just a plain old hardware issue or am I missing something?

Click image for larger version

Name:	Screenshot_2014-08-25-22-20-54.png
Views:	402
Size:	48.6 KB
ID:	2912397

Click image for larger version

Name:	Screenshot_2014-08-25-22-22-47.png
Views:	386
Size:	61.5 KB
ID:	2912398

Click image for larger version

Name:	Screenshot_2014-08-25-22-20-59.png
Views:	394
Size:	72.1 KB
ID:	2912399

Click image for larger version

Name:	Screenshot_2014-08-25-22-21-02.png
Views:	289
Size:	56.7 KB
ID:	2912400

Click image for larger version

Name:	Screenshot_2014-08-25-22-21-06.png
Views:	253
Size:	45.9 KB
ID:	2912401
26th August 2014, 05:38 AM |#2  
deadlyheart4u's Avatar
Senior Member
Flag Kolkata
Thanks Meter: 117
Do a reset of phone
26th August 2014, 06:08 AM |#3  
OP Junior Member
Thanks Meter: 0
Originally Posted by deadlyheart4u

Do a reset of phone

I've already done one twice. Event tried switching from Dalvik to ART and back.
26th August 2014, 07:02 AM |#4  
corrsea's Avatar
Senior Member
Thanks Meter: 712
Try switching off all location services. Reboot your phone then switch them on again.

Sent from my LG-D855 using Tapatalk
26th August 2014, 10:33 PM |#5  
Flag Zagreb
Thanks Meter: 7
Go to location in settings and select gps and network for gps. Maybe you have only network selected and gps wont lock any satelite. I tried to selected only network and gps dont lock.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes