FORUMS

[PORT] LG QuickRemote for AOSP MM

136 posts
Thanks Meter: 163
 
By Jc_master, Senior Member on 26th January 2016, 11:18 PM
Post Reply Email Thread
Hello, i bring to you the QuickRemote app for your AOSP Marshmallow rom, CM13 or any rom based on CM13 (Resurrection Remix, Bliss, AICP), you may ask, "Why would i want QuickRemote on my AOSP rom if MM has native IR support and Peel or Anymote works without all this mambo jambo?
Well, even though what i just said is true, no remote controller app has the learning method enabled, even on a stock rom, only QuickRemote can enable the IR receiver to learn a controller that does not appear on the device/manufacturers list.
So, that's the reason we want QuickRemote to work on our AOSP rom.

So, before anything, i would like to thank @hikarisei23 because in a comment of his post HERE i found the files for QuickRemote to work on MM wich leads to the second person i want to thank wich is @syndre who on said comment, posted the files that worked on MM, also @KronicSkillz who helped a lot to troubleshoot and also confirmed that the method i'm posting here works.

Well, this is it, after personally testing with: Resurrection Remix, AICP and Bliss, all of them MM amd CM13 based, all of them with the stock kernel and Lambda Kernel i'm confident enough to post it here, days of testing and troubleshooting and 3 different roms later.


So first, the mandatory disclaimer, im not responsible for any problem that may result from using my method and the files i'm providing you, either with your phone or your self-esteem, it's your responsibility to read, re-read and only do what you are comfortable with.


What you will need:


1. - The phone, this only has been tested with Lg G2 and Lg G3, this may or may not work on another LG phone with IR, you can try, but at your own risk.
2. - The Rom, this only have been tested with AOSP roms either CM13 or CM13 based roms, again, you can try in another rom but at your own risk.
3. - Obviously a Custom Recovery (twrp, cwm, philz)
4. - The three zips im leaving at the end of the post, QRemote_AOSP_MM.zip Fix_Part1.zip and Fix_Part2.zip.
5. - Maybe necessary or not, depending on your rom, Universal init.d from Playstore HERE and Selinux Mode Changer from HERE.
6. - Root Access.

Ok, once you checked and have everything needed, we have to make a little prep on your Rom before starting to flash the zips.

Rom Preparation 100% Needed


You need to set Selinux to permissive, here is where you may or may not need Selinux Mode Changer, First go into "About Device" on your phone settings and in the bottom you will find an indicator for Selinux state, if its "Permissive" you are good to go, some Roms and Kernels have this set to Permissive by default, if it's Enforcing, search in your Rom or Kernel settings, some of them have an option to set it to Permissive, if your rom does not have any option to change it, you will need Selinux Mode Changer, you install it and set Selinux to permissive, after reboot you can check in About Device again to see if it succeded, if it does not work, try again and check the original post, most of the answers are there, i cant give support for this app, also, this app needs root rights, and preferably two reboots after setting Selinux to Permissive.

Next you need to have init.d support, again, some roms have it, but at least for the test that me and the other users did, even though you are pretty sure init.d is enabled it's better to just install Universal init.d from the Play Store and enable init.d manually after doing so, reboot the system at least two times and grant Root access.


Installation!


Now we are ready to start flashing, reboot into recovery and RECOMMENDED, do a Nandroid Backup just in case, but at the moment no boot loops or any other problems had raised from flashing this, but again, just in case. After that, flash the first file: QRemote_AOSP_MM.zip, reboot your system and let it settle for a bit, 1 minute at least.

Now is the part where almost everyone has problems, you have to check in your Sdcard root for a log file named Qremote.log, if the file is there, it means init.d is enabled and in the file it will say if Selinux is Ok, if you don't have the file, check back the first two prep steps and try again.

Now if everything is going ok, is time for the second file, Fix_Part1.zip, reboot and let the system settle again, you may have some force close errors from QuickRemote or QuicksetSDK, its ok, you can try and check if QuickRemote is working, in allmost every case it will not work just yet, but you may have some luck.

Now, is the time to flash the third file, Fix_Part2.zip, again, reboot and let the system settle, now, you should have a working QuickRemote app on you AOSP MM Rom.
This are the steps, if you need more information about what all of this is doing and why you need Selinux and init.d, also why you need to flash 3 files, you can read the troubleshooting section where i explain what i understand about it.


TROUBLESHOOTING


Well, if you are here, it means that this didn't work as planned, so lets make this like a FAQ so you just search your problem and get the answer for it.

P.- I can't see QuickRemote on my app drawer. A: be sure that QuickRemote.apk is not showing as "com.lge...." and has the default green Android icon on your app drawer, sometimes and for reasons unknown to me, this happens for the first day or so, it will automatically change to QuickRemote and it will have the correct icon at least 5 hours after you installed it, it can take more time. A2: Maybe the flashing proccess was not successful, re-flash the file, it will automatically delete previously flashed files and install a new copy of them.

P. - I get force close messages for QuickRemote or QuicksetSDK after completing the proccess. A: try to run QuickRemote after the system settled, most of the times is 1 minute, in some roms and for reasons unknown to me, this messages will appear at boot but after the system settled, you will be able to run QuickRemote without any problem.

P. - QuickRemote opens up but no manufacturers are showing and it also gets really slow. A: this problem shows when either QuicksetSDK is not correctly installed or Selinux is not set to permissive, the solution for the first problem is in my 2 part fix, the version of Selinux included in the first zip, works great with MM but for some reason it will not work out of the box, i dont know if it's missing some files but it may or may not even show under system apps list on your settings menu, what my 2 part fix does is that, deletes the version of QuicksetSDK that the first flash installs and installs a temporary copy of QuicksetSDK wich i believe, writes information needed for QuicksetSDK to work properly, but this newer temporary QuicksetSDK apk, will allmost never work on MM, you can try but allmost every time it will not work, it will constantly force close, so the second fix zip, will delete this temporary QuicksetSDK and the folder it creates in your Sdcard root and install the previous version of QuicksetSDK again, and now, if everything went well, it will work as it's supposed to, i really dont know why exactly, but it works.
A2: the first thing you will notice when you switch to MM is that allmost every app will ask for permission to your Sdcard or camera or microphone wich in LP was not doing, since 4.3 Google is taking extra steps to ensure that you and your information are better protected one of this steps is Selinux (Security Enhanced Linux) wich, for putting it in simple terms, is like a sandbox for your system, only some trust-signed apps can get out of that sandbox and copy files etc... Into your system, those not-so privileged apps cant output anything outside the sanbox and thats why you need to disable or "set to permissive" Selinux, so QuicksetSDK can make the changes necessary for QuickRemote to do its work, it's true that now your system is in a degree "more vulnerable" but if you are a user of this forum, the odds to install something that will damage your system or jeopardize your information are minimal, you need to be really silly to fall for those "your system has problems" or "your battery is gonna explode if you don't install this app" ads that appear on your phone on the daily basis, so, dont worry, but at the same time, just be carefull and have some common sense, if there is a way for this to work with Selinux set to Enforcing, i will update it in the same second.

P. - QuickRemote force closes whenever i try to open it. A: this is caused by either a bad zip flash, or problems with Selinux or init.d, follow the previous answer and the first installation steps again.

P. - I can see QuickRemote and QuicksetSDK on my apps list, no force closes but still no manufacturers. A: Be sure init.d is enabled, i had problems with Roms that had "native init.d support" and emulated init.d will not work, the only way i got no problems with this was with Universal init.d, install that even though you are "pretty sure" your rom supports init.d, the 10QuickRemote.sh script on your init.d tries to get your country to see if you will use the app in, either Korean or any other supported language, it will also give some permissions to a file and it will check if Selinux is Permissive and finally, it will log this to a file called Qremote.log on the root of your Sd, if you have problems and you cant see the file, the problem is 99% most of the time, init.d.

P.- I don't want to flash three files, isn't there a simpler way? A: Unfortunately no, at this moment and after A LOT of testing etc... This is the only effective way i found.

P. - I'm afraid to set Selinux to permissive and leave the door open for all kind of bad ju ju and stuff to invade my sacred Android system, what can i do? A: Skip this hole thing, at the moment, the only way to make this work on AOSP MM is by doing the previous, just be careful, get some common sense and everything will be just fine.

Well, thats all i can think of right now, if you have suggestions, problems or a better way to make this work, please tell me in the comments or PM me, i'm glad to help as far as i can, i hope this helps, i leave you with the needed files and proof that it works.

QRemote_AOSP_MM.zip - MEGA - DRIVE
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20160126-111602.png
Views:	15014
Size:	199.1 KB
ID:	3623439   Click image for larger version

Name:	Screenshot_20160126-111608.jpg
Views:	15274
Size:	144.6 KB
ID:	3623440   Click image for larger version

Name:	Screenshot_20160126-111612.png
Views:	14858
Size:	64.3 KB
ID:	3623441   Click image for larger version

Name:	Screenshot_20160126-111617.png
Views:	14434
Size:	145.1 KB
ID:	3623442   Click image for larger version

Name:	Screenshot_20160126-111621.png
Views:	14002
Size:	74.6 KB
ID:	3623443   Click image for larger version

Name:	Screenshot_20160126-111625.png
Views:	13782
Size:	84.1 KB
ID:	3623444   Click image for larger version

Name:	Screenshot_20160126-111633.png
Views:	14130
Size:	125.4 KB
ID:	3623445   Click image for larger version

Name:	Screenshot_20160126-111657.png
Views:	13572
Size:	156.4 KB
ID:	3623446   Click image for larger version

Name:	Screenshot_20160125-215353.png
Views:	13216
Size:	103.5 KB
ID:	3623449   Click image for larger version

Name:	Screenshot_20160125-215401.png
Views:	11920
Size:	61.8 KB
ID:	3623450   Click image for larger version

Name:	Screenshot_20160125-215406.png
Views:	11536
Size:	142.6 KB
ID:	3623451   Click image for larger version

Name:	Screenshot_20160125-215410.png
Views:	10382
Size:	72.1 KB
ID:	3623452   Click image for larger version

Name:	Screenshot_20160125-215416.png
Views:	9912
Size:	82.7 KB
ID:	3623457   Click image for larger version

Name:	Screenshot_20160125-215427.png
Views:	9694
Size:	102.0 KB
ID:	3623458  
Attached Files
File Type: zip Fix_Part1.zip - [Click for QR Code] (7.84 MB, 20674 views)
File Type: zip Fix_Part2.zip - [Click for QR Code] (7.35 MB, 18654 views)
The Following 64 Users Say Thank You to Jc_master For This Useful Post: [ View ] Gift Jc_master Ad-Free
27th January 2016, 04:12 AM |#2  
nice you started a new thread!

Ive been messing around with this a lot the last few days and I have been seeing the same fix you were talking about by swapping the quickset apks back and forth. Ive put together a zip for flashing that I think would make things as easy as possible for people to get the list to show up.

The script in this one sets the correct permissions for everything on flash. It will instal;l the L version of Quickset, which doesnt show the manufactures list. The M quickset apk also gets flashed but i just put it in /system, so its there and can be moved easily. When you boot the first time after flashing, the the ROM uses the L version. All you should have to do then is use a file manager app to move the QuicksetSDK.apk from /system to /system/app/QuicksertAPK/ replacing the one thats there already. Set perms to 644 if necessary. Now wipe tjhe app data for quickset app, forcing the new one to restart, you dont even have to reboot.

Last thing is you have to delete the Quickset Settings folder made by the lollipop quickset. The Marshmallow version will make a working folder of its own the first time you start Quick Remote.

I like your idea to make fixes in separate flashes, that is probably easier


link to my 01262016.AOSP-6.x.x-M_LGQuickRemote_v4.50.19.zip on MEGA
The Following 10 Users Say Thank You to syndre For This Useful Post: [ View ] Gift syndre Ad-Free
27th January 2016, 06:21 AM |#3  
Member
Thanks Meter: 15
 
More
it's working great!
tnx!
27th January 2016, 11:09 AM |#4  
KronicSkillz's Avatar
Senior Member
Thanks Meter: 213
 
More
i just ran a nightly update on mokee6 which is cm13 similar and i had to reflash the fixes to get it working again and strange thing is i noticed lib folder is gone from quickset sdk folder but it's working

another thing i noticed is quickset sdk is not in my apps list so don't use that as a way to test if it's working either see if manufactures show up after waiting a bit or try the learning feature to test app functionality

im using d852 with stock mokee6 kernel btw of anyone's wondering and yes i have all apps selected
27th January 2016, 01:44 PM |#5  
marcdw's Avatar
Senior Member
Flag Baldwin Park
Thanks Meter: 2,920
 
More
The mult-zip installation also worked out here on BrokenOS. Remote is working fine.
Originally I used "init.d scripts support" app to handle the init.d file. Worked just fine, BTW. Reason for that is I wasn't sure what would happen if I used Universal Init.d with Broken as it has a directory full of tweaks.
On later examination I see that each script needs to be enabled before it will run (via Settings. True/false values are then looked up in a cfg file).
So I reckon I can safely use Universal Init.d.

LG G3 D851, BrokenOS MM ROM, Tapatalk 4.9.5
27th January 2016, 02:26 PM |#6  
Roi007leaf's Avatar
Recognized Contributor
Flag Petah Tiqwa
Thanks Meter: 3,090
 
Donate to Me
More
can i delete universal init.d after enabling it?
27th January 2016, 03:55 PM |#7  
OP Senior Member
Flag Ciudad Juarez
Thanks Meter: 163
 
More
@syndre well yes, i think that flashing zip it's pretty straight forward, your new method is simpler but i think that just flashing and not having to deal with system folders and permissions is better for the less tech savvy, but a little more hideous because of the various reboots
27th January 2016, 03:56 PM |#8  
OP Senior Member
Flag Ciudad Juarez
Thanks Meter: 163
 
More
Quote:
Originally Posted by smolchy

it's working great!
tnx!

You're welcome
27th January 2016, 04:00 PM |#9  
OP Senior Member
Flag Ciudad Juarez
Thanks Meter: 163
 
More
@marcdw yes, the thing with Universal init.d is that it really enables init.d at boot, Resurrection Remix and AICP also have their individual init.d scripts and they run, i don't know why the QuickRemote script does not run, and Universal init.d does not mess with the existing scripts, so it's not harmful for the system and runs the script at boot and thats what we want
The Following User Says Thank You to Jc_master For This Useful Post: [ View ] Gift Jc_master Ad-Free
27th January 2016, 04:07 PM |#10  
OP Senior Member
Flag Ciudad Juarez
Thanks Meter: 163
 
More
@KronicSkillz well, I'm glad it works, i used the QuicksetSDK thingy because it seemed like it was the only consistent thing, sometimes the Quickset Setup folder would not show, or it will show with the first QuicksetSDK but at least at first QuicksetSDK would not show in the apps list, after the first fix it would and it would show again, i will put it in the post, thanks for the feedback
27th January 2016, 04:13 PM |#11  
OP Senior Member
Flag Ciudad Juarez
Thanks Meter: 163
 
More
Quote:
Originally Posted by Roi007leaf

can i delete universal init.d after enabling it?

I think you can i but i have not tested that, if you do, tell me what that did to update the post, i keep Universal init.d for other scripts that i have installed so i need it, if you only use it for QuickRemote i dont think you'll have a problem
Post Reply Subscribe to Thread

Tags
6.0 mm, aosp, ir sensor, lg apps, quickremote

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes